Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Протягивание формулы (объединенные и необъединенные ячейки) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протягивание формулы (объединенные и необъединенные ячейки) (Формулы/Formulas)
Протягивание формулы (объединенные и необъединенные ячейки)
Alex1018 Дата: Понедельник, 24.08.2020, 17:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, великие умы и мастера MS Office!

Столкнулся со следующей проблемой при создании прикреплённого файла:

Формулы вытаскивают данные из листа "Исходные данные", перенося их на лист "ЖСР". Лист "ЖСР" в каждой строке имеет одновременно и нормальные, и объединенные ячейки. Формулы в строках 1 и 2 прописаны вручную и, вроде, прекрасно выполняют свою задачу. НО! При попытке протянуть формулы на весь лист "ЖСР" умная программа категорически не воспринимает ручной труд и с упорством искусственного интеллекта заполняет данные, пропуская каждую вторую строку из исходного документа.

Поясню:

В листе "Исходные данные" в колонке 57 указаны "wp" в хронологическом порядке. Для каждого из "wp" есть своя информация, которая в первой строке листа "ЖСР" заполняется по формулам. При попытке протянуть формулу ниже должен получиться следующий результат: строка 1,2 - wp-18 и его характеристики, строка 3,4 - wp-02 и его характеристики, строка 4,5 - wp-04 и его характеристики и т.д. На деле при протягивании отображается wp-18, а потом wp-04, пропуская wp-02.

Какой ритуальный танец поможет устранить эту неприятность, не прибегая к макросам?
К сообщению приложен файл: 1588151.xlsx(63.3 Kb)
 
Ответить
СообщениеЗдравствуйте, великие умы и мастера MS Office!

Столкнулся со следующей проблемой при создании прикреплённого файла:

Формулы вытаскивают данные из листа "Исходные данные", перенося их на лист "ЖСР". Лист "ЖСР" в каждой строке имеет одновременно и нормальные, и объединенные ячейки. Формулы в строках 1 и 2 прописаны вручную и, вроде, прекрасно выполняют свою задачу. НО! При попытке протянуть формулы на весь лист "ЖСР" умная программа категорически не воспринимает ручной труд и с упорством искусственного интеллекта заполняет данные, пропуская каждую вторую строку из исходного документа.

Поясню:

В листе "Исходные данные" в колонке 57 указаны "wp" в хронологическом порядке. Для каждого из "wp" есть своя информация, которая в первой строке листа "ЖСР" заполняется по формулам. При попытке протянуть формулу ниже должен получиться следующий результат: строка 1,2 - wp-18 и его характеристики, строка 3,4 - wp-02 и его характеристики, строка 4,5 - wp-04 и его характеристики и т.д. На деле при протягивании отображается wp-18, а потом wp-04, пропуская wp-02.

Какой ритуальный танец поможет устранить эту неприятность, не прибегая к макросам?

Автор - Alex1018
Дата добавления - 24.08.2020 в 17:39
Alex1018 Дата: Вторник, 25.08.2020, 07:25 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вопрос решился по средствам СЦЕПИТЬ.

Пропала эстетика, но всё работает.

Если всё же есть способ воплощения в жизнь изначальной задумки, буду рад его услышать.
 
Ответить
СообщениеВопрос решился по средствам СЦЕПИТЬ.

Пропала эстетика, но всё работает.

Если всё же есть способ воплощения в жизнь изначальной задумки, буду рад его услышать.

Автор - Alex1018
Дата добавления - 25.08.2020 в 07:25
Pelena Дата: Вторник, 25.08.2020, 07:52 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
способ воплощения в жизнь изначальной задумки

Код
=ИНДЕКС('Исходные данные'!$BE$5:$BE$34;СТРОКА(A2)/2)&""


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
способ воплощения в жизнь изначальной задумки

Код
=ИНДЕКС('Исходные данные'!$BE$5:$BE$34;СТРОКА(A2)/2)&""

Автор - Pelena
Дата добавления - 25.08.2020 в 07:52
Alex1018 Дата: Суббота, 29.08.2020, 08:42 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, Не уловил суть решения.

Попытался прописать данную формулу перед уже имеющимися в листе ЖСР, ничего не получается.

Можно на живом примере в документе из вложения, если не затруднит?
 
Ответить
СообщениеPelena, Не уловил суть решения.

Попытался прописать данную формулу перед уже имеющимися в листе ЖСР, ничего не получается.

Можно на живом примере в документе из вложения, если не затруднит?

Автор - Alex1018
Дата добавления - 29.08.2020 в 08:42
Pelena Дата: Суббота, 29.08.2020, 08:56 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16655
Репутация: 3600 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
можно
К сообщению приложен файл: 6323420.xlsx(62.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеможно

Автор - Pelena
Дата добавления - 29.08.2020 в 08:56
Alex1018 Дата: Суббота, 29.08.2020, 09:06 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, всё гениальное просто.

Премного благодарен!
 
Ответить
СообщениеPelena, всё гениальное просто.

Премного благодарен!

Автор - Alex1018
Дата добавления - 29.08.2020 в 09:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протягивание формулы (объединенные и необъединенные ячейки) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!