Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод значений массива по заданному номеру столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений массива по заданному номеру столбца (Формулы/Formulas)
Вывод значений массива по заданному номеру столбца
94016 Дата: Среда, 26.08.2020, 17:29 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте. Прошу помощи в решении следующей задачи. Есть массив, который включает в себя артикул, наименование, ед. измерения и энное количество столбцов с количеством. Наименование столбца= это номер объекта, на котором все это добро смонтировано. Мне нужно решить следующую задачу: как задача максимум - ввести тот или иной номер столбца и получить все не пустые строки таблицы. Как минимум ввести в формуле номер нужного столбца для вывода и получить искомую выборку.
Благодарю за помощь.
К сообщению приложен файл: 5641471.xls(26.5 Kb)
 
Ответить
СообщениеЗдравствуйте. Прошу помощи в решении следующей задачи. Есть массив, который включает в себя артикул, наименование, ед. измерения и энное количество столбцов с количеством. Наименование столбца= это номер объекта, на котором все это добро смонтировано. Мне нужно решить следующую задачу: как задача максимум - ввести тот или иной номер столбца и получить все не пустые строки таблицы. Как минимум ввести в формуле номер нужного столбца для вывода и получить искомую выборку.
Благодарю за помощь.

Автор - 94016
Дата добавления - 26.08.2020 в 17:29
прохожий2019 Дата: Среда, 26.08.2020, 17:44 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 364
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$G$10;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ИНДЕКС($D$5:$G$10;;ПОИСКПОЗ($J$3;$D$4:$G$4;)));СТРОКА($D$5:$D$10);"");СТРОКА(B1));СТОЛБЕЦ(B5));"")
К сообщению приложен файл: 0776914.xls(30.5 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$G$10;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ИНДЕКС($D$5:$G$10;;ПОИСКПОЗ($J$3;$D$4:$G$4;)));СТРОКА($D$5:$D$10);"");СТРОКА(B1));СТОЛБЕЦ(B5));"")

Автор - прохожий2019
Дата добавления - 26.08.2020 в 17:44
94016 Дата: Среда, 26.08.2020, 17:49 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Благодарю!!! Пол жизни мне съэкономили respect
 
Ответить
СообщениеБлагодарю!!! Пол жизни мне съэкономили respect

Автор - 94016
Дата добавления - 26.08.2020 в 17:49
bmv98rus Дата: Среда, 26.08.2020, 18:11 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3219
Репутация: 554 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IFERROR(INDEX(A:A;AGGREGATE(15;6;ROW($A$5:$A$10)/(INDEX($D$5:$G$10;;MATCH($J$3;$D$4:$G$4;))<>"");ROWS($I$5:I5)));"")

Остальное проще

Если вдруг данных много, то одна универсальная формула даст большую нагрузку при расчетах.
К сообщению приложен файл: example1841.xlsx(11.3 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 26.08.2020, 18:13
 
Ответить
Сообщение
Код
=IFERROR(INDEX(A:A;AGGREGATE(15;6;ROW($A$5:$A$10)/(INDEX($D$5:$G$10;;MATCH($J$3;$D$4:$G$4;))<>"");ROWS($I$5:I5)));"")

Остальное проще

Если вдруг данных много, то одна универсальная формула даст большую нагрузку при расчетах.

Автор - bmv98rus
Дата добавления - 26.08.2020 в 18:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значений массива по заданному номеру столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!