Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт количества отфильтрованных ячеек с определенным сдрж - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества отфильтрованных ячеек с определенным сдрж (Формулы/Formulas)
Подсчёт количества отфильтрованных ячеек с определенным сдрж
vitos88 Дата: Пятница, 28.08.2020, 09:42 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 5 ±
Замечаний: 0% ±

Добрый день! Нужно посчитать количество ячеек, в которых встречается слово "положительный" хотя бы 1 раз. Но подсчитывать нужно в определенном отфильтрованном диапазоне дат (по типу "промежуточныеитоги"). Есть ли такой способ без применения дополнительных столбцов?
К сообщению приложен файл: _Microsoft_Exce.xlsx(11.2 Kb)
 
Ответить
СообщениеДобрый день! Нужно посчитать количество ячеек, в которых встречается слово "положительный" хотя бы 1 раз. Но подсчитывать нужно в определенном отфильтрованном диапазоне дат (по типу "промежуточныеитоги"). Есть ли такой способ без применения дополнительных столбцов?

Автор - vitos88
Дата добавления - 28.08.2020 в 09:42
прохожий2019 Дата: Пятница, 28.08.2020, 09:58 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
Код
=СЧЁТ(ПОИСК("положительный";B:B))
К сообщению приложен файл: 6524117.xlsx(12.7 Kb)
 
Ответить
Сообщение
Код
=СЧЁТ(ПОИСК("положительный";B:B))

Автор - прохожий2019
Дата добавления - 28.08.2020 в 09:58
Pelena Дата: Пятница, 28.08.2020, 10:06 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16641
Репутация: 3598 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(B1;СТРОКА($1:$233);0))*ЕЧИСЛО(ПОИСК("положительный";$B$2:$B$234)))
К сообщению приложен файл: 4167486.xlsx(12.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(B1;СТРОКА($1:$233);0))*ЕЧИСЛО(ПОИСК("положительный";$B$2:$B$234)))

Автор - Pelena
Дата добавления - 28.08.2020 в 10:06
vitos88 Дата: Пятница, 28.08.2020, 10:07 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 5 ±
Замечаний: 0% ±

прохожий2019, эта формула не работает при фильтровании по дате.
 
Ответить
Сообщениепрохожий2019, эта формула не работает при фильтровании по дате.

Автор - vitos88
Дата добавления - 28.08.2020 в 10:07
vitos88 Дата: Пятница, 28.08.2020, 10:09 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 5 ±
Замечаний: 0% ±

Pelena, Спасибо! Работает!
 
Ответить
СообщениеPelena, Спасибо! Работает!

Автор - vitos88
Дата добавления - 28.08.2020 в 10:09
vitos88 Дата: Пятница, 28.08.2020, 11:45 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 5 ±
Замечаний: 0% ±

Pelena, Как сделать, чтобы корректно работало в прилагаемом файле. Формула вставлена в последнюю графу.
К сообщению приложен файл: __.xlsx(79.5 Kb)
 
Ответить
СообщениеPelena, Как сделать, чтобы корректно работало в прилагаемом файле. Формула вставлена в последнюю графу.

Автор - vitos88
Дата добавления - 28.08.2020 в 11:45
прохожий2019 Дата: Пятница, 28.08.2020, 11:55 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
А что конкретно не работает?


Сообщение отредактировал прохожий2019 - Пятница, 28.08.2020, 12:09
 
Ответить
СообщениеА что конкретно не работает?

Автор - прохожий2019
Дата добавления - 28.08.2020 в 11:55
Pelena Дата: Пятница, 28.08.2020, 14:57 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 16641
Репутация: 3598 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Я бы вставила формулу в другую ячейку, т.к. получается циклическая ссылка (ячейка Р4).
Хотя всё равно считает, что удивительно %)

либо СМЕЩ можно сделать от Р5
Код
=СЦЕПИТЬ("Результат
(";СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(P5;СТРОКА($5:$10237)-5;0))*ЕЧИСЛО(ПОИСК("ожит";$P$5:$P$10237)));" положит.)")

а в остальном, присоединяюсь к вопросу
Цитата прохожий2019, 28.08.2020 в 11:55, в сообщении № 7 ()
А что конкретно не работает?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЯ бы вставила формулу в другую ячейку, т.к. получается циклическая ссылка (ячейка Р4).
Хотя всё равно считает, что удивительно %)

либо СМЕЩ можно сделать от Р5
Код
=СЦЕПИТЬ("Результат
(";СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;СМЕЩ(P5;СТРОКА($5:$10237)-5;0))*ЕЧИСЛО(ПОИСК("ожит";$P$5:$P$10237)));" положит.)")

а в остальном, присоединяюсь к вопросу
Цитата прохожий2019, 28.08.2020 в 11:55, в сообщении № 7 ()
А что конкретно не работает?

Автор - Pelena
Дата добавления - 28.08.2020 в 14:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт количества отфильтрованных ячеек с определенным сдрж (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!