Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/расчет хранения по партиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет хранения по партиям (Формулы/Formulas)
расчет хранения по партиям
Kati Дата: Пятница, 04.09.2020, 11:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрий день. Помогите, пожалуйста, с решением расчета хранения, если партия списывается частями по ФИФО. Я в екселе не могу посчитать сколько дней хранилось, так как партии по приходу разбиваются при расходе. Подскажите, пожалуйста,это вообще реально сделать в екселе?
К сообщению приложен файл: 111.xlsx(10.9 Kb)
 
Ответить
СообщениеДобрий день. Помогите, пожалуйста, с решением расчета хранения, если партия списывается частями по ФИФО. Я в екселе не могу посчитать сколько дней хранилось, так как партии по приходу разбиваются при расходе. Подскажите, пожалуйста,это вообще реально сделать в екселе?

Автор - Kati
Дата добавления - 04.09.2020 в 11:35
Kati Дата: Пятница, 04.09.2020, 12:05 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
вручную получается такое колличество
К сообщению приложен файл: 222.xlsx(10.9 Kb)
 
Ответить
Сообщениевручную получается такое колличество

Автор - Kati
Дата добавления - 04.09.2020 в 12:05
Pelena Дата: Пятница, 04.09.2020, 15:39 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Если правильно поняла, что партия хранится, пока полностью не израсходуется. Формула массива
Код
=ЕСЛИ(B4=0;"";ЕСЛИОШИБКА(ИНДЕКС(A5:$A$65;ПОИСКПОЗ(ИСТИНА;СУММ($B$4:B4)<СУММЕСЛИ($A5:$A$65;"<="&$A5:$A$65;$C5:$C$65)+СУММ($C3:C$4);0));$A$65)-A4)
К сообщению приложен файл: 4146971.xlsx(13.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла, что партия хранится, пока полностью не израсходуется. Формула массива
Код
=ЕСЛИ(B4=0;"";ЕСЛИОШИБКА(ИНДЕКС(A5:$A$65;ПОИСКПОЗ(ИСТИНА;СУММ($B$4:B4)<СУММЕСЛИ($A5:$A$65;"<="&$A5:$A$65;$C5:$C$65)+СУММ($C3:C$4);0));$A$65)-A4)

Автор - Pelena
Дата добавления - 04.09.2020 в 15:39
Kati Дата: Пятница, 04.09.2020, 17:35 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, не так все просто. первая партия 78380 хранилась 69700- 4 дня, и 8680 - 11 дней. для этого я пыталась паралельно создать автоматическую разбивку, чтоб прописать там формулу расчета
 
Ответить
СообщениеPelena, не так все просто. первая партия 78380 хранилась 69700- 4 дня, и 8680 - 11 дней. для этого я пыталась паралельно создать автоматическую разбивку, чтоб прописать там формулу расчета

Автор - Kati
Дата добавления - 04.09.2020 в 17:35
Pelena Дата: Пятница, 04.09.2020, 17:49 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Нарисуйте вручную, в каком виде Вы хотите получить результат


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНарисуйте вручную, в каком виде Вы хотите получить результат

Автор - Pelena
Дата добавления - 04.09.2020 в 17:49
Kati Дата: Пятница, 04.09.2020, 20:32 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, не совпадает. партия 44260 от 9.08 хранилась 12 дней, а партия 45140 от 10.08 хранилась 11 дней...
 
Ответить
СообщениеPelena, не совпадает. партия 44260 от 9.08 хранилась 12 дней, а партия 45140 от 10.08 хранилась 11 дней...

Автор - Kati
Дата добавления - 04.09.2020 в 20:32
Pelena Дата: Пятница, 04.09.2020, 20:46 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Обоснуйте


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеОбоснуйте

Автор - Pelena
Дата добавления - 04.09.2020 в 20:46
Светлый Дата: Пятница, 04.09.2020, 23:03 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1485
Репутация: 387 ±
Замечаний: 0% ±

Excel 2010, 2013
Я вот такую массивную формулу нарисовал для столбца E:
Код
=ЕСЛИ(C4>0;СТРОКА()-СТРОКА(B$4)-ПОИСКПОЗ(СУММ(C$3:C3);СУММЕСЛИ(СМЕЩ(B$3;;;СТРОКА(B$2:B2));"<>"));"")
Считает наибольший срок хранения какой-то порции зерна при его расходе. В расходе может содержаться несколько порций с разными сроками.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЯ вот такую массивную формулу нарисовал для столбца E:
Код
=ЕСЛИ(C4>0;СТРОКА()-СТРОКА(B$4)-ПОИСКПОЗ(СУММ(C$3:C3);СУММЕСЛИ(СМЕЩ(B$3;;;СТРОКА(B$2:B2));"<>"));"")
Считает наибольший срок хранения какой-то порции зерна при его расходе. В расходе может содержаться несколько порций с разными сроками.

Автор - Светлый
Дата добавления - 04.09.2020 в 23:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет хранения по партиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!