Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет по двум условиям (массив) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет по двум условиям (массив) (Формулы/Formulas)
Подсчет по двум условиям (массив)
Voodoo Дата: Понедельник, 07.09.2020, 16:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Office 365
Гуру Excel, всем привет!

Существует форма, куда забиваются заказы питания, и таблица Excel, куда заказы на питания попадают.
Подскажите пожалуйста, как решить вроде бы простую задачу подсчета определенного блюда на определенный день.
Пытался решить через =суммеслимн , но проблема в том, что диапазон проверки даты будет изменяться, и он не хочет подсчитать мне по этим двум условиям на одну строку, а пытается подсчитать сразу все с переносом. Либо останавливается на первой попавшейся строке и останавливается.

То есть условно- на конкретное число он должен подсчитать количество блюд из меню и отразить это количество в сводной таблице. Подсчитать по условию одного блюда в диапазоне не проблема, но проблема просмотреть каждую строчку... по условию число.

P.s. не ругайте за такое сумбурное объяснение, я первый раз так спрашиваю.
Надеюсь на отзывчивость Гуру Excel.
К сообщению приложен файл: 0132919.xlsx(83.7 Kb)
 
Ответить
СообщениеГуру Excel, всем привет!

Существует форма, куда забиваются заказы питания, и таблица Excel, куда заказы на питания попадают.
Подскажите пожалуйста, как решить вроде бы простую задачу подсчета определенного блюда на определенный день.
Пытался решить через =суммеслимн , но проблема в том, что диапазон проверки даты будет изменяться, и он не хочет подсчитать мне по этим двум условиям на одну строку, а пытается подсчитать сразу все с переносом. Либо останавливается на первой попавшейся строке и останавливается.

То есть условно- на конкретное число он должен подсчитать количество блюд из меню и отразить это количество в сводной таблице. Подсчитать по условию одного блюда в диапазоне не проблема, но проблема просмотреть каждую строчку... по условию число.

P.s. не ругайте за такое сумбурное объяснение, я первый раз так спрашиваю.
Надеюсь на отзывчивость Гуру Excel.

Автор - Voodoo
Дата добавления - 07.09.2020 в 16:03
Pelena Дата: Понедельник, 07.09.2020, 18:43 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Поясните подробнее, где исходные данные и где нужна формула?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Поясните подробнее, где исходные данные и где нужна формула?

Автор - Pelena
Дата добавления - 07.09.2020 в 18:43
Voodoo Дата: Вторник, 08.09.2020, 00:35 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Office 365
Pelena, Спасибо за отклик. Исходные данные находятся на Листе1, сводная таблица - Лист 2. Мне бы хоть наводку по решению.
 
Ответить
СообщениеPelena, Спасибо за отклик. Исходные данные находятся на Листе1, сводная таблица - Лист 2. Мне бы хоть наводку по решению.

Автор - Voodoo
Дата добавления - 08.09.2020 в 00:35
Pelena Дата: Вторник, 08.09.2020, 08:51 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Если правильно поняла
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(--(ИНДЕКС(Таблица1[[Холодное, понедельник,8 часов смена]:[Второе, воскресенье, 11 часов смена ВТОРОЙ ПРИЕМ ПИЩИ]];ПОИСКПОЗ(C$3;Таблица1[[т.с3]:[т.с3]];0);0)=$B19));"")
К сообщению приложен файл: 9581343.xlsx(112.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли правильно поняла
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ(--(ИНДЕКС(Таблица1[[Холодное, понедельник,8 часов смена]:[Второе, воскресенье, 11 часов смена ВТОРОЙ ПРИЕМ ПИЩИ]];ПОИСКПОЗ(C$3;Таблица1[[т.с3]:[т.с3]];0);0)=$B19));"")

Автор - Pelena
Дата добавления - 08.09.2020 в 08:51
Voodoo Дата: Вторник, 08.09.2020, 11:50 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Office 365
Pelena, да практически так!! но он должен просуммировать все заказы, к примеру 17-ого числа. Там 17ое число это 2-ой и 3-ий заказ. Салат традиционный, к примеру заказали 2 человека (2-ой и 3-й заказ), в массиве салат на этих двух строчках упоминается 3 раза. А формула когда сталкивается с первой попавшейся строчкой (2-й заказ), на ней как я понял останавливается и результат показывает 1.

P.s я исправил названия технических столбцов. Ещё раз благодарю Вас за помощь! Файл прикрепляю
К сообщению приложен файл: 5925587.xlsx(102.7 Kb)


Сообщение отредактировал Voodoo - Вторник, 08.09.2020, 12:02
 
Ответить
СообщениеPelena, да практически так!! но он должен просуммировать все заказы, к примеру 17-ого числа. Там 17ое число это 2-ой и 3-ий заказ. Салат традиционный, к примеру заказали 2 человека (2-ой и 3-й заказ), в массиве салат на этих двух строчках упоминается 3 раза. А формула когда сталкивается с первой попавшейся строчкой (2-й заказ), на ней как я понял останавливается и результат показывает 1.

P.s я исправил названия технических столбцов. Ещё раз благодарю Вас за помощь! Файл прикрепляю

Автор - Voodoo
Дата добавления - 08.09.2020 в 11:50
Pelena Дата: Вторник, 08.09.2020, 13:43 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Да, это я не досмотрела. Тогда так
Код
=СУММПРОИЗВ((Таблица1[[Холодное, понедельник,8 часов смена]:[Второе, воскресенье, 11 часов смена ВТОРОЙ ПРИЕМ ПИЩИ]]=$B4)*(Таблица1[[Дата]:[Дата]]=C$3))

Заметила, что есть повторы блюд, отметила оранжевым
К сообщению приложен файл: 8798735.xlsx(105.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДа, это я не досмотрела. Тогда так
Код
=СУММПРОИЗВ((Таблица1[[Холодное, понедельник,8 часов смена]:[Второе, воскресенье, 11 часов смена ВТОРОЙ ПРИЕМ ПИЩИ]]=$B4)*(Таблица1[[Дата]:[Дата]]=C$3))

Заметила, что есть повторы блюд, отметила оранжевым

Автор - Pelena
Дата добавления - 08.09.2020 в 13:43
Voodoo Дата: Среда, 09.09.2020, 17:08 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Office 365
Pelena, Спасибо огромное! Все работает!!!
 
Ответить
СообщениеPelena, Спасибо огромное! Все работает!!!

Автор - Voodoo
Дата добавления - 09.09.2020 в 17:08
Voodoo Дата: Среда, 09.09.2020, 17:39 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Office 365
Pelena, Но странно почему то, в Вашем файле все работает, но при переносе просто формулы в мой файл выдаёт #н/д, сталкиваюсь с таким приколом также впервые. Почему так может быть?

P.s. как вы поставили просто знак "-" при не нахождении совпадений?
 
Ответить
СообщениеPelena, Но странно почему то, в Вашем файле все работает, но при переносе просто формулы в мой файл выдаёт #н/д, сталкиваюсь с таким приколом также впервые. Почему так может быть?

P.s. как вы поставили просто знак "-" при не нахождении совпадений?

Автор - Voodoo
Дата добавления - 09.09.2020 в 17:39
Pelena Дата: Среда, 09.09.2020, 18:28 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 16638
Репутация: 3597 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
выдаёт #н/д
прежде всего надо проверять полное совпадение написания сравниваемых значений (столбец С на листе 1 и столбец С на листе 3) и названий блюд на листе 1 и листе 2.

знак "-" при не нахождении совпадений
ставится с помощью формата ячейки


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
выдаёт #н/д
прежде всего надо проверять полное совпадение написания сравниваемых значений (столбец С на листе 1 и столбец С на листе 3) и названий блюд на листе 1 и листе 2.

знак "-" при не нахождении совпадений
ставится с помощью формата ячейки

Автор - Pelena
Дата добавления - 09.09.2020 в 18:28
Voodoo Дата: Четверг, 10.09.2020, 15:52 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Office 365
Pelena, Разобрался почему так было! Если в одном из проверяемых столбцов было #Н/Д , то формула отказывалась работать! Спасибо Вам!
 
Ответить
СообщениеPelena, Разобрался почему так было! Если в одном из проверяемых столбцов было #Н/Д , то формула отказывалась работать! Спасибо Вам!

Автор - Voodoo
Дата добавления - 10.09.2020 в 15:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет по двум условиям (массив) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!