Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка параметров исходя из заданного списка - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка параметров исходя из заданного списка (Формулы/Formulas)
Подстановка параметров исходя из заданного списка
Gopronotmore Дата: Пятница, 11.09.2020, 15:09 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 146
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Подскажите форумчане, а как можно сделать так, что бы при выборе выпадающего списка параметры подставлялись автоматически из заданного массива данных
К сообщению приложен файл: 7272275.xlsx(9.2 Kb)
 
Ответить
СообщениеПодскажите форумчане, а как можно сделать так, что бы при выборе выпадающего списка параметры подставлялись автоматически из заданного массива данных

Автор - Gopronotmore
Дата добавления - 11.09.2020 в 15:09
Nic70y Дата: Пятница, 11.09.2020, 15:21 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6509
Репутация: 1431 ±
Замечаний: 0% ±

ru13;10;03
вариант формулой:
Код
=ЕСЛИ(ИНДЕКС(B:B;ПОИСКПОЗ(L$1;B:B;)+СТРОКА(L1)-1)=L$1;ИНДЕКС(C:C;ПОИСКПОЗ(L$1;B:B;)+СТРОКА(L1)-1);"")
К сообщению приложен файл: 9340286.xlsx(9.6 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениевариант формулой:
Код
=ЕСЛИ(ИНДЕКС(B:B;ПОИСКПОЗ(L$1;B:B;)+СТРОКА(L1)-1)=L$1;ИНДЕКС(C:C;ПОИСКПОЗ(L$1;B:B;)+СТРОКА(L1)-1);"")

Автор - Nic70y
Дата добавления - 11.09.2020 в 15:21
прохожий2019 Дата: Пятница, 11.09.2020, 15:22 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$17=$L$1;СТРОКА($B$2:$B$17);"");СТРОКА(A1)));"")
в новой эксельке
Код
=ФИЛЬТР(C2:C17;B2:B17=L1)
К сообщению приложен файл: 2031200.xlsx(11.0 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ($B$2:$B$17=$L$1;СТРОКА($B$2:$B$17);"");СТРОКА(A1)));"")
в новой эксельке
Код
=ФИЛЬТР(C2:C17;B2:B17=L1)

Автор - прохожий2019
Дата добавления - 11.09.2020 в 15:22
Gopronotmore Дата: Понедельник, 14.09.2020, 15:51 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 146
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Спасибо большое за решения
 
Ответить
СообщениеСпасибо большое за решения

Автор - Gopronotmore
Дата добавления - 14.09.2020 в 15:51
Gopronotmore Дата: Среда, 16.09.2020, 19:15 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 146
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Подскаите а как поправить формулу, которую мне посоветовали выше....
К сообщению приложен файл: exmaple1.xlsx(17.5 Kb)
 
Ответить
СообщениеПодскаите а как поправить формулу, которую мне посоветовали выше....

Автор - Gopronotmore
Дата добавления - 16.09.2020 в 19:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка параметров исходя из заданного списка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!