Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Горизонтальный ВПР - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Горизонтальный ВПР (Формулы/Formulas)
Горизонтальный ВПР
Nikonka89 Дата: Пятница, 18.09.2020, 18:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Добрый день
Помогите, пожалуйста, с горизонтальным ВПР. Во вложении есть шаблон. Нужно на вкладке "шаблон" в столбец текущий УА подтянуть значения из вкладки "текущий УА". В зависимости от номера и Тов.иер.ур.
И на основании этой таблицы дальше уже на вкладке СВОД считаю долю списаний. Выделила желтым столбец. Я ее прописывала вручную, но по факту объём в файле будет большой, и каждый раз вручную прописывать формулу нереально. Как можно еще усовершенствовать, чтобы делилось всегда на " общий итог" по Тов.иер.ур ?
К сообщению приложен файл: 6564571.xlsx(26.6 Kb)
 
Ответить
СообщениеДобрый день
Помогите, пожалуйста, с горизонтальным ВПР. Во вложении есть шаблон. Нужно на вкладке "шаблон" в столбец текущий УА подтянуть значения из вкладки "текущий УА". В зависимости от номера и Тов.иер.ур.
И на основании этой таблицы дальше уже на вкладке СВОД считаю долю списаний. Выделила желтым столбец. Я ее прописывала вручную, но по факту объём в файле будет большой, и каждый раз вручную прописывать формулу нереально. Как можно еще усовершенствовать, чтобы делилось всегда на " общий итог" по Тов.иер.ур ?

Автор - Nikonka89
Дата добавления - 18.09.2020 в 18:51
-vp- Дата: Пятница, 18.09.2020, 20:47 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 57
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте.
каждый раз вручную прописывать формулу нереально


Вы имеете ввиду протягивание формулы
Код
=ВПР(A2;'Уа текущий'!$A$2:$D$3;ПОИСКПОЗ(ШАБЛОН!B2;'Уа текущий'!$A$1:$D$1;0);0)

с первой строчки до последней или что-то другое. Если первое, то пользуйтесь умными таблицами, они будут сами протягивать формулу.
К сообщению приложен файл: 7112430.xlsx(30.0 Kb)


Сообщение отредактировал -vp- - Пятница, 18.09.2020, 20:50
 
Ответить
СообщениеЗдравствуйте.
каждый раз вручную прописывать формулу нереально


Вы имеете ввиду протягивание формулы
Код
=ВПР(A2;'Уа текущий'!$A$2:$D$3;ПОИСКПОЗ(ШАБЛОН!B2;'Уа текущий'!$A$1:$D$1;0);0)

с первой строчки до последней или что-то другое. Если первое, то пользуйтесь умными таблицами, они будут сами протягивать формулу.

Автор - -vp-
Дата добавления - 18.09.2020 в 20:47
Gustav Дата: Пятница, 18.09.2020, 21:52 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1825
Репутация: 725 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Вариант через ИНДЕКС. Имхо хоть и более длинен, но и более прозрачен - прямоугольная таблица, в ней номер строки, номер столбца:
Код
=ИНДЕКС('Уа текущий'!$1:$100; ПОИСКПОЗ(A2;'Уа текущий'!$A:$A;); ПОИСКПОЗ(B2;'Уа текущий'!$1:$1;))


Мой tip box - яд 41001663842605
 
Ответить
СообщениеВариант через ИНДЕКС. Имхо хоть и более длинен, но и более прозрачен - прямоугольная таблица, в ней номер строки, номер столбца:
Код
=ИНДЕКС('Уа текущий'!$1:$100; ПОИСКПОЗ(A2;'Уа текущий'!$A:$A;); ПОИСКПОЗ(B2;'Уа текущий'!$1:$1;))

Автор - Gustav
Дата добавления - 18.09.2020 в 21:52
Nikonka89 Дата: Пятница, 18.09.2020, 22:27 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
-vp-, Нет, я имела ввиду про протягивание на вкладке "СВОД".
Там столбец желтым выделила. Прописала формула вручную, но ее не протянуть так просто. По крайне мере не протянуть ту формулу, которая у меня написана. Можете помочь с ней?
 
Ответить
Сообщение-vp-, Нет, я имела ввиду про протягивание на вкладке "СВОД".
Там столбец желтым выделила. Прописала формула вручную, но ее не протянуть так просто. По крайне мере не протянуть ту формулу, которая у меня написана. Можете помочь с ней?

Автор - Nikonka89
Дата добавления - 18.09.2020 в 22:27
-vp- Дата: Пятница, 18.09.2020, 22:48 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 57
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Тогда вот это протягивайте
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(СУММПРОИЗВ((ШАБЛОН!$A$2:$A$19=СВОД!A5)*(ШАБЛОН!$B$2:$B$19=СВОД!B5)*(ШАБЛОН!$L$2:$L$19=СВОД!C5)*ШАБЛОН!$E$2:$E$19)/СУММПРОИЗВ((ШАБЛОН!$A$2:$A$19=СВОД!A5)*(ШАБЛОН!$B$2:$B$19=СВОД!B5)*ШАБЛОН!$D$2:$D$19);СУММПРОИЗВ((ШАБЛОН!$A$2:$A$19=СВОД!A5)*((ШАБЛОН!$B$2:$B$19&" Итог")=СВОД!B5)*ШАБЛОН!$E$2:$E$19)/СУММПРОИЗВ((ШАБЛОН!$A$2:$A$19=СВОД!A5)*((ШАБЛОН!$B$2:$B$19&" Итог")=СВОД!B5)*ШАБЛОН!$D$2:$D$19));"")


Сообщение отредактировал -vp- - Пятница, 18.09.2020, 23:11
 
Ответить
СообщениеТогда вот это протягивайте
Код
=ЕСЛИОШИБКА(ЕСЛИОШИБКА(СУММПРОИЗВ((ШАБЛОН!$A$2:$A$19=СВОД!A5)*(ШАБЛОН!$B$2:$B$19=СВОД!B5)*(ШАБЛОН!$L$2:$L$19=СВОД!C5)*ШАБЛОН!$E$2:$E$19)/СУММПРОИЗВ((ШАБЛОН!$A$2:$A$19=СВОД!A5)*(ШАБЛОН!$B$2:$B$19=СВОД!B5)*ШАБЛОН!$D$2:$D$19);СУММПРОИЗВ((ШАБЛОН!$A$2:$A$19=СВОД!A5)*((ШАБЛОН!$B$2:$B$19&" Итог")=СВОД!B5)*ШАБЛОН!$E$2:$E$19)/СУММПРОИЗВ((ШАБЛОН!$A$2:$A$19=СВОД!A5)*((ШАБЛОН!$B$2:$B$19&" Итог")=СВОД!B5)*ШАБЛОН!$D$2:$D$19));"")

Автор - -vp-
Дата добавления - 18.09.2020 в 22:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Горизонтальный ВПР (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!