Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет складских остатков с сопоставлением по рецептам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет складских остатков с сопоставлением по рецептам (Формулы/Formulas)
Расчет складских остатков с сопоставлением по рецептам
Vasilev_MO Дата: Пятница, 25.09.2020, 11:55 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. У меня суть проблемы такая - необходимо создать небольшую считалку складских остатков с сопоставлением по рецептам (указываем название рецепта и выдает по ингредиентам + или -). Пример во вложении.
Каждый рецепт в отдельном листе.
Подскажите пожалуйста как упростить функцию?
К сообщению приложен файл: 321.xlsx(14.7 Kb)
 
Ответить
СообщениеЗдравствуйте. У меня суть проблемы такая - необходимо создать небольшую считалку складских остатков с сопоставлением по рецептам (указываем название рецепта и выдает по ингредиентам + или -). Пример во вложении.
Каждый рецепт в отдельном листе.
Подскажите пожалуйста как упростить функцию?

Автор - Vasilev_MO
Дата добавления - 25.09.2020 в 11:55
-vp- Дата: Пятница, 25.09.2020, 12:43 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 10 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте.
Так, по моему, нагляднее:
Код
=J5-СУММПРОИЗВ(($C$2=Р.1!$B$2)*(C5=Р.1!$C$4:$C$6)*(Р.1!$B$4:$B$6)+($C$2=Р.2!$B$2)*(C5=Р.2!$C$4:$C$6)*(Р.2!$B$4:$B$6)+($C$2=Р.3!$B$2)*(C5=Р.3!$C$4:$C$6)*(Р.3!$B$4:$B$6))

А если в режиме редактирования формулы после каждого плюса ещё и alt+ентер нажимать...


Сообщение отредактировал -vp- - Пятница, 25.09.2020, 13:13
 
Ответить
СообщениеЗдравствуйте.
Так, по моему, нагляднее:
Код
=J5-СУММПРОИЗВ(($C$2=Р.1!$B$2)*(C5=Р.1!$C$4:$C$6)*(Р.1!$B$4:$B$6)+($C$2=Р.2!$B$2)*(C5=Р.2!$C$4:$C$6)*(Р.2!$B$4:$B$6)+($C$2=Р.3!$B$2)*(C5=Р.3!$C$4:$C$6)*(Р.3!$B$4:$B$6))

А если в режиме редактирования формулы после каждого плюса ещё и alt+ентер нажимать...

Автор - -vp-
Дата добавления - 25.09.2020 в 12:43
Vasilev_MO Дата: Пятница, 25.09.2020, 14:24 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо. Отлично работает. Единственное - если продукта нет в рецепте (на соседних листах), то в ячейку с формулой попадает значение остатка на складе. Было бы лучше если бы цифры были только на тех продуктах которые есть в перечне в рецепте, а на других либо пусто, либо 0.
 
Ответить
СообщениеСпасибо. Отлично работает. Единственное - если продукта нет в рецепте (на соседних листах), то в ячейку с формулой попадает значение остатка на складе. Было бы лучше если бы цифры были только на тех продуктах которые есть в перечне в рецепте, а на других либо пусто, либо 0.

Автор - Vasilev_MO
Дата добавления - 25.09.2020 в 14:24
Nic70y Дата: Пятница, 25.09.2020, 15:15 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6509
Репутация: 1431 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИОШИБКА(J5-ИНДЕКС(ДВССЫЛ("Р."&C$2&"!B:B");ПОИСКПОЗ(C5;ДВССЫЛ("Р."&C$2&"!C:C");));"")


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(J5-ИНДЕКС(ДВССЫЛ("Р."&C$2&"!B:B");ПОИСКПОЗ(C5;ДВССЫЛ("Р."&C$2&"!C:C");));"")

Автор - Nic70y
Дата добавления - 25.09.2020 в 15:15
Vasilev_MO Дата: Пятница, 25.09.2020, 15:46 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Тут по названию листа идет поиск. Спасибо всем. Отлично. тему можно закрывать)
 
Ответить
СообщениеТут по названию листа идет поиск. Спасибо всем. Отлично. тему можно закрывать)

Автор - Vasilev_MO
Дата добавления - 25.09.2020 в 15:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет складских остатков с сопоставлением по рецептам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!