Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединение одинаковых значений и вычисление среднего - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение одинаковых значений и вычисление среднего (Формулы/Formulas)
Объединение одинаковых значений и вычисление среднего
Zor14 Дата: Пятница, 16.10.2020, 16:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Доброго дня!

Помогите решить задачку)
Имеем таблицу (см. вложение, по факту она значительно объемнее), необходимо:
1) Вычислить одинаковые значения в столбце С
2) Вычислить среднее значения по столбцам Е-М, с отнесением к позиции из столбца С
3) В отдельной таблице должно получиться объединение значений столбца С со средним значением

Если брать пример из таблицы, то желаемый результат:
1=6.7
2=6.1
3=5.25
К сообщению приложен файл: 3213207.xlsx(30.1 Kb)
 
Ответить
СообщениеДоброго дня!

Помогите решить задачку)
Имеем таблицу (см. вложение, по факту она значительно объемнее), необходимо:
1) Вычислить одинаковые значения в столбце С
2) Вычислить среднее значения по столбцам Е-М, с отнесением к позиции из столбца С
3) В отдельной таблице должно получиться объединение значений столбца С со средним значением

Если брать пример из таблицы, то желаемый результат:
1=6.7
2=6.1
3=5.25

Автор - Zor14
Дата добавления - 16.10.2020 в 16:26
Nic70y Дата: Пятница, 16.10.2020, 17:08 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6508
Репутация: 1431 ±
Замечаний: 0% ±

ru13;10;03
то желаемый результат
ну чего это вдруг?
6,722222222
6
5,333333333
Код
=СУММПРОИЗВ(E$2:M$7*(C$2:C$7=A9))/(СЧЁТЕСЛИ(C$2:C$7;A9)*ЧИСЛСТОЛБ(E2:M7))


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
то желаемый результат
ну чего это вдруг?
6,722222222
6
5,333333333
Код
=СУММПРОИЗВ(E$2:M$7*(C$2:C$7=A9))/(СЧЁТЕСЛИ(C$2:C$7;A9)*ЧИСЛСТОЛБ(E2:M7))

Автор - Nic70y
Дата добавления - 16.10.2020 в 17:08
Zor14 Дата: Понедельник, 19.10.2020, 09:46 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Доброго дня.

Спасибо за ответ.
Видимо я не совсем точно попросил помощи, вследствие чего результат получается не верным.
Во вложении полный файл. Это форма по опросу удовлетворенности клиентов выпускаемой продукцией. Текущий вопрос - это форма рейтинга производителей. Соответственно в полной версии файла вышеприведенная форума работает не точно, видимо вследствие того, что столбец "производитель" имеет текстовые значения.
Помогите пожалуйста "добить" вопрос.
К сообщению приложен файл: _2.xlsx(46.0 Kb)
 
Ответить
СообщениеДоброго дня.

Спасибо за ответ.
Видимо я не совсем точно попросил помощи, вследствие чего результат получается не верным.
Во вложении полный файл. Это форма по опросу удовлетворенности клиентов выпускаемой продукцией. Текущий вопрос - это форма рейтинга производителей. Соответственно в полной версии файла вышеприведенная форума работает не точно, видимо вследствие того, что столбец "производитель" имеет текстовые значения.
Помогите пожалуйста "добить" вопрос.

Автор - Zor14
Дата добавления - 19.10.2020 в 09:46
Nic70y Дата: Понедельник, 19.10.2020, 09:58 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6508
Репутация: 1431 ±
Замечаний: 0% ±

ru13;10;03
пустые ячейки "Комментарии" воспринимаются как 0
Код
=СУММПРОИЗВ(J$5:AC$10*(G$5:G$10=B17))/(СЧЁТЕСЛИ(G$5:G$10;B17)*ЧИСЛСТОЛБ(J5:AC10)/2)
так наверное


Яндекс Деньги 41001841029809
 
Ответить
Сообщениепустые ячейки "Комментарии" воспринимаются как 0
Код
=СУММПРОИЗВ(J$5:AC$10*(G$5:G$10=B17))/(СЧЁТЕСЛИ(G$5:G$10;B17)*ЧИСЛСТОЛБ(J5:AC10)/2)
так наверное

Автор - Nic70y
Дата добавления - 19.10.2020 в 09:58
Zor14 Дата: Понедельник, 19.10.2020, 10:16 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Попробовал, проверил, цифры не сходятся.
Проверяем "в ручную" рейтинг по производителю "ббб". В формуле изменил диапазон с АС на АB. Формула считает значение производителя ббб=7.11, если посчитать "руками" получаем 6. Или я не верно что-то делаю? Во вложении файл с расчетами
+был бы признателен так же за подсказку, как модернизировать формулу, чтобы ячейки B17:B20 не заполнять руками, а данные туда вставлялись автоматом при заполнении столбца "Изготовитель"

Заранее спасибо.
К сообщению приложен файл: 1275036.xlsx(46.8 Kb)
 
Ответить
СообщениеПопробовал, проверил, цифры не сходятся.
Проверяем "в ручную" рейтинг по производителю "ббб". В формуле изменил диапазон с АС на АB. Формула считает значение производителя ббб=7.11, если посчитать "руками" получаем 6. Или я не верно что-то делаю? Во вложении файл с расчетами
+был бы признателен так же за подсказку, как модернизировать формулу, чтобы ячейки B17:B20 не заполнять руками, а данные туда вставлялись автоматом при заполнении столбца "Изготовитель"

Заранее спасибо.

Автор - Zor14
Дата добавления - 19.10.2020 в 10:16
Nic70y Дата: Понедельник, 19.10.2020, 11:12 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 6508
Репутация: 1431 ±
Замечаний: 0% ±

ru13;10;03
не верно что-то делаю?
конечно

хотя формула не подойдет, т.к. в комментариях будет текст,
= см. файл 20
формула массива
Код
=СРЗНАЧ(ЕСЛИ(($J$4:$AC$4="Оценка")*(G$5:G$10=B17);J$5:AC$10))
К сообщению приложен файл: 19.xlsx(13.7 Kb) · 20.xlsx(13.8 Kb)


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 19.10.2020, 11:30
 
Ответить
Сообщение
не верно что-то делаю?
конечно

хотя формула не подойдет, т.к. в комментариях будет текст,
= см. файл 20
формула массива
Код
=СРЗНАЧ(ЕСЛИ(($J$4:$AC$4="Оценка")*(G$5:G$10=B17);J$5:AC$10))

Автор - Nic70y
Дата добавления - 19.10.2020 в 11:12
Zor14 Дата: Понедельник, 19.10.2020, 12:23 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
Большое спасибо, в Вашем файле все работает, но почему то при малейшем изменении любых данных (изменил диапазон) или что-то другое, без изменения формулы - сразу ошибка и "знач". Почему так может быть?
Если на живом примере: я просто изменяю диапазон до "вопрос 9" (столбец Z вместе AC)
 
Ответить
СообщениеБольшое спасибо, в Вашем файле все работает, но почему то при малейшем изменении любых данных (изменил диапазон) или что-то другое, без изменения формулы - сразу ошибка и "знач". Почему так может быть?
Если на живом примере: я просто изменяю диапазон до "вопрос 9" (столбец Z вместе AC)

Автор - Zor14
Дата добавления - 19.10.2020 в 12:23
Nic70y Дата: Понедельник, 19.10.2020, 12:27 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 6508
Репутация: 1431 ±
Замечаний: 0% ±

ru13;10;03
{формула массива вводится одновременным нажатием Ctrl Shift Enter}
а не просто Enter


Яндекс Деньги 41001841029809
 
Ответить
Сообщение{формула массива вводится одновременным нажатием Ctrl Shift Enter}
а не просто Enter

Автор - Nic70y
Дата добавления - 19.10.2020 в 12:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение одинаковых значений и вычисление среднего (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!