Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Excel определение пустого диапозона для хронологии - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Excel определение пустого диапозона для хронологии (Формулы/Formulas)
Excel определение пустого диапозона для хронологии
Vladislav_9Q Дата: Суббота, 17.10.2020, 00:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Итак. Я плох в описании, если что не понятно, спршивайте.
В файле, на листе "рабочая" можно увидеть рабочую хронологию (на 46 строке), которая сверяется с датами из таблицы и заполняет ячейки согласно хронологии.
Однако подобная хронология предназначена только для одной временной линии. На листе "Не рабочая" отображено 2 временные линии. Вопрос такой: можно ли улучшить формулу, которая будет определять, если диапозон для заполнения временной линии пуст, то будет происходить заполнение, если нет, переносить на 2 строки ниже?
К сообщению приложен файл: 7374302.xlsx(20.0 Kb)
 
Ответить
СообщениеИтак. Я плох в описании, если что не понятно, спршивайте.
В файле, на листе "рабочая" можно увидеть рабочую хронологию (на 46 строке), которая сверяется с датами из таблицы и заполняет ячейки согласно хронологии.
Однако подобная хронология предназначена только для одной временной линии. На листе "Не рабочая" отображено 2 временные линии. Вопрос такой: можно ли улучшить формулу, которая будет определять, если диапозон для заполнения временной линии пуст, то будет происходить заполнение, если нет, переносить на 2 строки ниже?

Автор - Vladislav_9Q
Дата добавления - 17.10.2020 в 00:34
Светлый Дата: Суббота, 17.10.2020, 23:25 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1485
Репутация: 387 ±
Замечаний: 0% ±

Excel 2010, 2013
И Вам, здравствуйте!
Не совсем по заданию. В жёлтых ячейках примерное решение. Формула массива:
Код
=ЕСЛИ(СТРОКА(G1)=1;ЕСЛИ(ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3);1;"")&ЕСЛИ(И(МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))>=МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7));МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))<=МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7)));"";ЕСЛИ(ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3);2;""));ЕСЛИ(ИЛИ(МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))<МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7));МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))>МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7)));"";ЕСЛИ(ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3);2;"")))
*Немного переделал формулу:
Код
=ЕСЛИ(И(СТРОКА(G1)=1;ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3));1;"")&ЕСЛИ(И(МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))>=МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7));МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))<=МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7)))=(СТРОКА(G1)=1);"";ЕСЛИ(ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3);2;""))
Файл перезалил.
К сообщению приложен файл: 7374302-1.xlsx(24.1 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Суббота, 17.10.2020, 23:43
 
Ответить
СообщениеИ Вам, здравствуйте!
Не совсем по заданию. В жёлтых ячейках примерное решение. Формула массива:
Код
=ЕСЛИ(СТРОКА(G1)=1;ЕСЛИ(ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3);1;"")&ЕСЛИ(И(МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))>=МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7));МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))<=МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7)));"";ЕСЛИ(ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3);2;""));ЕСЛИ(ИЛИ(МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))<МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7));МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))>МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7)));"";ЕСЛИ(ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3);2;"")))
*Немного переделал формулу:
Код
=ЕСЛИ(И(СТРОКА(G1)=1;ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3));1;"")&ЕСЛИ(И(МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))>=МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7));МИН(ЕСЛИ(--ПРАВБ($A$2:$A$7)=1;$C$2:$C$7))<=МАКС(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7)))=(СТРОКА(G1)=1);"";ЕСЛИ(ИЛИ(ТЕКСТ(ЕСЛИ(--ПРАВБ($A$2:$A$7)=2;$C$2:$C$7);"МММ ГГГГ")=G$4&" "&G$3);2;""))
Файл перезалил.

Автор - Светлый
Дата добавления - 17.10.2020 в 23:25
Vladislav_9Q Дата: Воскресенье, 18.10.2020, 14:01 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Цитата Светлый, 17.10.2020 в 23:25, в сообщении № 2 ()
Файл перезалил.

Благодарю, добрый человек.
 
Ответить
Сообщение
Цитата Светлый, 17.10.2020 в 23:25, в сообщении № 2 ()
Файл перезалил.

Благодарю, добрый человек.

Автор - Vladislav_9Q
Дата добавления - 18.10.2020 в 14:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Excel определение пустого диапозона для хронологии (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!