Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/МАКС по условию формулой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » МАКС по условию формулой (Формулы/Formulas)
МАКС по условию формулой
mkotik Дата: Вторник, 20.10.2020, 00:22 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 166
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер, Уважаемые знатоки!
Есть многострочная таблица, образец которой во вложении.
В Первый столбец заносятся значения 1-го, 2-го,... 1000-го маршрута
Во Второй столбец заносятся точки остановки.
Необходимо найти в каждом маршруте последнюю точку остановки.
Как без функции
Код
МАКСЕСЛИ()
прописать в выделенных ячейках фразу "STOP"
Под вечер голова "засорилась" совсем...
Благодарю заранее.
С уважением.
К сообщению приложен файл: Test_Excel.xlsx(12.4 Kb)
 
Ответить
СообщениеДобрый вечер, Уважаемые знатоки!
Есть многострочная таблица, образец которой во вложении.
В Первый столбец заносятся значения 1-го, 2-го,... 1000-го маршрута
Во Второй столбец заносятся точки остановки.
Необходимо найти в каждом маршруте последнюю точку остановки.
Как без функции
Код
МАКСЕСЛИ()
прописать в выделенных ячейках фразу "STOP"
Под вечер голова "засорилась" совсем...
Благодарю заранее.
С уважением.

Автор - mkotik
Дата добавления - 20.10.2020 в 00:22
Gustav Дата: Вторник, 20.10.2020, 02:52 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1828
Репутация: 726 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Ну, если у вас два первых столбца всегда отсортированы по возрастанию, то первой в голову приходит банальная формула без всяких МАКСов:
Код
=ЕСЛИ(A2<>A3; "Stop";"")

А если строки хаотично перемешаны, то можно вот такую формула массива (завершение ввода по Ctrl+Shift+Enter) попробовать:
Код
=ЕСЛИ(B2=МАКС(($A$2:$A$39=A2)*($B$2:$B$39)); "Stop";"")


Мой tip box - яд 41001663842605

Сообщение отредактировал Gustav - Вторник, 20.10.2020, 03:06
 
Ответить
СообщениеНу, если у вас два первых столбца всегда отсортированы по возрастанию, то первой в голову приходит банальная формула без всяких МАКСов:
Код
=ЕСЛИ(A2<>A3; "Stop";"")

А если строки хаотично перемешаны, то можно вот такую формула массива (завершение ввода по Ctrl+Shift+Enter) попробовать:
Код
=ЕСЛИ(B2=МАКС(($A$2:$A$39=A2)*($B$2:$B$39)); "Stop";"")

Автор - Gustav
Дата добавления - 20.10.2020 в 02:52
mkotik Дата: Вторник, 20.10.2020, 03:05 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 166
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Gustav, спасибо за отклик... Чуть не подходит...
Сделал пока так:
Код
=ЕСЛИ(ЗНАЧЕН([@[Route ID]]&[@[Path ID]])=ЗНАЧЕН([@[Route ID]]&СУММПРОИЗВ(МАКС(([Route ID]=[@[Route ID]])*[Path ID])));"Stop";"")

Хотя не очень нравится.
К сообщению приложен файл: Test_Excel-.xlsx(13.1 Kb)
 
Ответить
СообщениеGustav, спасибо за отклик... Чуть не подходит...
Сделал пока так:
Код
=ЕСЛИ(ЗНАЧЕН([@[Route ID]]&[@[Path ID]])=ЗНАЧЕН([@[Route ID]]&СУММПРОИЗВ(МАКС(([Route ID]=[@[Route ID]])*[Path ID])));"Stop";"")

Хотя не очень нравится.

Автор - mkotik
Дата добавления - 20.10.2020 в 03:05
jakim Дата: Вторник, 20.10.2020, 06:54 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 968
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Формула без массивного ввода

Код
=IF(B2<>AGGREGATE(14;6;$B$2:$B$1000/(A$2:A$1000=A2);1);"";"Stop")
 
Ответить
Сообщение
Формула без массивного ввода

Код
=IF(B2<>AGGREGATE(14;6;$B$2:$B$1000/(A$2:A$1000=A2);1);"";"Stop")

Автор - jakim
Дата добавления - 20.10.2020 в 06:54
mkotik Дата: Вторник, 20.10.2020, 14:37 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 166
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
jakim, Спасибо! Более красивое решение
 
Ответить
Сообщениеjakim, Спасибо! Более красивое решение

Автор - mkotik
Дата добавления - 20.10.2020 в 14:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » МАКС по условию формулой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!