Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести сумму используя имя листа с корректировкой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести сумму используя имя листа с корректировкой (Формулы/Formulas)
Вывести сумму используя имя листа с корректировкой
Rayone Дата: Понедельник, 02.11.2020, 11:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день,
Есть задача вывести по разным закладкам значения с одного общего листа.
В качестве параметра для поиска нужно использовать имя листа (это я нашел как реализовать), но в дате этот параметр тоже предварительно формулой скорректировать (убрать лишний текст после второго пробела). Но не пойму как мне эту корректировку (убирание лишнего текста) учесть для всех ячеек в столбце не создавая никаких доп.столбцов, а сразу учесть в формуле (сейчас я научился это делать только для какой то конкретной ячейки, но это не совсем то).
К сообщению приложен файл: 5070986.xlsx(13.4 Kb)
 
Ответить
СообщениеДобрый день,
Есть задача вывести по разным закладкам значения с одного общего листа.
В качестве параметра для поиска нужно использовать имя листа (это я нашел как реализовать), но в дате этот параметр тоже предварительно формулой скорректировать (убрать лишний текст после второго пробела). Но не пойму как мне эту корректировку (убирание лишнего текста) учесть для всех ячеек в столбце не создавая никаких доп.столбцов, а сразу учесть в формуле (сейчас я научился это делать только для какой то конкретной ячейки, но это не совсем то).

Автор - Rayone
Дата добавления - 02.11.2020 в 11:51
Nic70y Дата: Понедельник, 02.11.2020, 12:11 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6593
Репутация: 1450 ±
Замечаний: 0% ±

ru13;10;03
Код
=СУММЕСЛИМН(дата!C:C;дата!B:B;ПСТР(ЯЧЕЙКА("filename";A1);ПОИСК("]";ЯЧЕЙКА("filename";A1))+1;31)&"*";дата!A:A;A2)
так?


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=СУММЕСЛИМН(дата!C:C;дата!B:B;ПСТР(ЯЧЕЙКА("filename";A1);ПОИСК("]";ЯЧЕЙКА("filename";A1))+1;31)&"*";дата!A:A;A2)
так?

Автор - Nic70y
Дата добавления - 02.11.2020 в 12:11
Pelena Дата: Понедельник, 02.11.2020, 12:11 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16771
Репутация: 3620 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ(((ПСТР(ЯЧЕЙКА("filename";A1);ПОИСК("]";ЯЧЕЙКА("filename";A1))+1;255)=ЛЕВСИМВ(дата!$B$2:$B$7;ПОИСК("+";дата!$B$2:$B$7)-2))*(A2=дата!$A$2:$A$7)*дата!$C$2:$C$7))
К сообщению приложен файл: 0314370.xlsx(14.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ(((ПСТР(ЯЧЕЙКА("filename";A1);ПОИСК("]";ЯЧЕЙКА("filename";A1))+1;255)=ЛЕВСИМВ(дата!$B$2:$B$7;ПОИСК("+";дата!$B$2:$B$7)-2))*(A2=дата!$A$2:$A$7)*дата!$C$2:$C$7))

Автор - Pelena
Дата добавления - 02.11.2020 в 12:11
Rayone Дата: Понедельник, 02.11.2020, 12:57 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо!!!
 
Ответить
СообщениеСпасибо!!!

Автор - Rayone
Дата добавления - 02.11.2020 в 12:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести сумму используя имя листа с корректировкой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!