Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Пропуск пустых ячеек с определением посл. имени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пропуск пустых ячеек с определением посл. имени (Формулы/Formulas)
Пропуск пустых ячеек с определением посл. имени
Kommamura Дата: Среда, 04.11.2020, 02:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте,
Искал решение, но не смог найти решение.
Задача такая: на одной странице находятся имена и источники, там между именами (и источниками), имеются пропуски. Эти значения должны автоматически переноситься на другую страницу без пропусков. Вроде легко, но не могу соединить формулу так, что бы все учитывалось.
Получилось что то такое:
Код
=INDEX('Финансовый учет'!$G$2:$G$1000;ROW()-1)
. Но тут учитывает пропуски и пишет соответственно через них, а нужно что бы было подряд.
Пожалуйста помогите. Голова взрывается, не профи в екселе, но сделать нужно. :'(
К сообщению приложен файл: 6398839.xlsx(17.4 Kb)
 
Ответить
СообщениеЗдравствуйте,
Искал решение, но не смог найти решение.
Задача такая: на одной странице находятся имена и источники, там между именами (и источниками), имеются пропуски. Эти значения должны автоматически переноситься на другую страницу без пропусков. Вроде легко, но не могу соединить формулу так, что бы все учитывалось.
Получилось что то такое:
Код
=INDEX('Финансовый учет'!$G$2:$G$1000;ROW()-1)
. Но тут учитывает пропуски и пишет соответственно через них, а нужно что бы было подряд.
Пожалуйста помогите. Голова взрывается, не профи в екселе, но сделать нужно. :'(

Автор - Kommamura
Дата добавления - 04.11.2020 в 02:24
Pelena Дата: Среда, 04.11.2020, 07:46 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16780
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('Финансовый учет'!$G$2:$G$20;НАИМЕНЬШИЙ(ЕСЛИ('Финансовый учет'!$G$2:$G$20<>"";СТРОКА('Финансовый учет'!$D$2:$D$20)-1);СТРОКА(1:1)));"")

или обычная
Код
=ЕСЛИОШИБКА(ИНДЕКС('Финансовый учет'!$G$2:$G$20;АГРЕГАТ(15;6;(СТРОКА('Финансовый учет'!$D$2:$D$20)-1)/('Финансовый учет'!$G$2:$G$20<>"");СТРОКА(1:1)));"")
К сообщению приложен файл: 8827601.xlsx(18.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС('Финансовый учет'!$G$2:$G$20;НАИМЕНЬШИЙ(ЕСЛИ('Финансовый учет'!$G$2:$G$20<>"";СТРОКА('Финансовый учет'!$D$2:$D$20)-1);СТРОКА(1:1)));"")

или обычная
Код
=ЕСЛИОШИБКА(ИНДЕКС('Финансовый учет'!$G$2:$G$20;АГРЕГАТ(15;6;(СТРОКА('Финансовый учет'!$D$2:$D$20)-1)/('Финансовый учет'!$G$2:$G$20<>"");СТРОКА(1:1)));"")

Автор - Pelena
Дата добавления - 04.11.2020 в 07:46
Kommamura Дата: Четверг, 05.11.2020, 15:25 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо больше Pelena!
Все отлично работает, но нашел новую проблему. Скажем если будет точно такое же имя в финансовых отчетах, но в базу его не нужно уже вносить, можно сделать так, что бы оно не вводилось снова?


Сообщение отредактировал Kommamura - Четверг, 05.11.2020, 15:37
 
Ответить
СообщениеСпасибо больше Pelena!
Все отлично работает, но нашел новую проблему. Скажем если будет точно такое же имя в финансовых отчетах, но в базу его не нужно уже вносить, можно сделать так, что бы оно не вводилось снова?

Автор - Kommamura
Дата добавления - 05.11.2020 в 15:25
Pelena Дата: Четверг, 05.11.2020, 18:33 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16780
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Так можно
Код
=ЕСЛИОШИБКА(ИНДЕКС('Финансовый учет'!$G$2:$G$20;АГРЕГАТ(15;6;(СТРОКА('Финансовый учет'!$D$2:$D$20)-1)/('Финансовый учет'!$G$2:$G$20<>"")/ЕНД(ПОИСКПОЗ(ИНДЕКС('Финансовый учет'!$G$2:$G$20;АГРЕГАТ(15;6;(СТРОКА('Финансовый учет'!$D$2:$D$20)-1)/('Финансовый учет'!$G$2:$G$20<>"");СТРОКА(1:1)));$B$1:$B1;0));СТРОКА(1:1)));"")

или массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС('Финансовый учет'!$G$2:$G$20;НАИМЕНЬШИЙ(ЕСЛИ(('Финансовый учет'!$G$2:$G$20<>"")*ЕНД(ПОИСКПОЗ(ИНДЕКС('Финансовый учет'!$G$2:$G$20;НАИМЕНЬШИЙ(ЕСЛИ('Финансовый учет'!$G$2:$G$20<>"";СТРОКА('Финансовый учет'!$D$2:$D$20)-1);СТРОКА(1:1)));$B$1:$B1;0));СТРОКА('Финансовый учет'!$D$2:$D$20)-1);СТРОКА(1:1)));"")
К сообщению приложен файл: 6947340.xlsx(19.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак можно
Код
=ЕСЛИОШИБКА(ИНДЕКС('Финансовый учет'!$G$2:$G$20;АГРЕГАТ(15;6;(СТРОКА('Финансовый учет'!$D$2:$D$20)-1)/('Финансовый учет'!$G$2:$G$20<>"")/ЕНД(ПОИСКПОЗ(ИНДЕКС('Финансовый учет'!$G$2:$G$20;АГРЕГАТ(15;6;(СТРОКА('Финансовый учет'!$D$2:$D$20)-1)/('Финансовый учет'!$G$2:$G$20<>"");СТРОКА(1:1)));$B$1:$B1;0));СТРОКА(1:1)));"")

или массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС('Финансовый учет'!$G$2:$G$20;НАИМЕНЬШИЙ(ЕСЛИ(('Финансовый учет'!$G$2:$G$20<>"")*ЕНД(ПОИСКПОЗ(ИНДЕКС('Финансовый учет'!$G$2:$G$20;НАИМЕНЬШИЙ(ЕСЛИ('Финансовый учет'!$G$2:$G$20<>"";СТРОКА('Финансовый учет'!$D$2:$D$20)-1);СТРОКА(1:1)));$B$1:$B1;0));СТРОКА('Финансовый учет'!$D$2:$D$20)-1);СТРОКА(1:1)));"")

Автор - Pelena
Дата добавления - 05.11.2020 в 18:33
Kommamura Дата: Четверг, 05.11.2020, 23:30 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Большое спасибо! выручили!)
 
Ответить
СообщениеБольшое спасибо! выручили!)

Автор - Kommamura
Дата добавления - 05.11.2020 в 23:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пропуск пустых ячеек с определением посл. имени (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!