Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ранжирование и автоматическая сортировка данных - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранжирование и автоматическая сортировка данных (Формулы/Formulas)
Ранжирование и автоматическая сортировка данных
vitos88 Дата: Четверг, 05.11.2020, 15:06 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 5 ±
Замечаний: 0% ±

Добрый день! Подскажите, пожалуйста, как сделать формулой автоматическое построение списка в зависимости от значений соседнего столбца.
В первых двух столбцах список отсортирован по алфавитному порядку, нужно, чтобы он сортировался по значению от большего к меньшему автоматически в следующих двух столбцах.
Спасибо!
К сообщению приложен файл: 5048966.xlsx(11.7 Kb)
 
Ответить
СообщениеДобрый день! Подскажите, пожалуйста, как сделать формулой автоматическое построение списка в зависимости от значений соседнего столбца.
В первых двух столбцах список отсортирован по алфавитному порядку, нужно, чтобы он сортировался по значению от большего к меньшему автоматически в следующих двух столбцах.
Спасибо!

Автор - vitos88
Дата добавления - 05.11.2020 в 15:06
Nic70y Дата: Четверг, 05.11.2020, 15:25 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6605
Репутация: 1453 ±
Замечаний: 0% ±

ru13;10;03
Код
=ИНДЕКС(A$2:A$24;ЕСЛИ(D3=D2;ПОИСКПОЗ(D3;ИНДЕКС(B$2:B$24;ПОИСКПОЗ(C2;A$2:A$24;)+1):B$24;)+ПОИСКПОЗ(C2;A$2:A$24;);ПОИСКПОЗ(D3;B$2:B$24;)))
Код
=НАИБОЛЬШИЙ(B$3:B$24;СТРОКА(D1))
К сообщению приложен файл: 18.xlsx(12.8 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(A$2:A$24;ЕСЛИ(D3=D2;ПОИСКПОЗ(D3;ИНДЕКС(B$2:B$24;ПОИСКПОЗ(C2;A$2:A$24;)+1):B$24;)+ПОИСКПОЗ(C2;A$2:A$24;);ПОИСКПОЗ(D3;B$2:B$24;)))
Код
=НАИБОЛЬШИЙ(B$3:B$24;СТРОКА(D1))

Автор - Nic70y
Дата добавления - 05.11.2020 в 15:25
jakim Дата: Четверг, 05.11.2020, 15:36 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 968
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Если формулами, то так.
К сообщению приложен файл: 0218525.xlsx(12.6 Kb)
 
Ответить
Сообщение
Если формулами, то так.

Автор - jakim
Дата добавления - 05.11.2020 в 15:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ранжирование и автоматическая сортировка данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!