Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула поиска наименования и привязки к её значению - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула поиска наименования и привязки к её значению (Формулы/Formulas)
Формула поиска наименования и привязки к её значению
Laeda Дата: Понедельник, 09.11.2020, 08:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет.
Помогите составить формулу. Условно есть таблица, состоящая из двух типов данных: Наименование и Сумма в рублях.
Каждый месяц в эту таблицу вносят данные, но в разном порядке. Пример: 1 месяц: батон, хлеб, молоко. 2 месяц: молоко,хлеб, батон. И т.д.
Суть задачи: в столбец "Рост/падение" прописать формулу, которая будет искать искомое наименование в предыдущем месяце и при нахождение его сравнивать сумму текущего месяца с предыдущим. В случае если Сумма больше предыдущего, то "пишет" РОСТ, если меньше, то "Падение".Если же он не найдёт такое наименование в предыдущем месяце, то пишет "NEW".
Excel пример во вложении
Я прописал базовую формулу
Код
=ЕСЛИ(E3=B3;ЕСЛИ(F3>C3;"рост";"падение"))
- это на примере анализа Батона из второго месяца. Но он сравнивает только ячейку и ячейкой и совпадение наименований, но задача, чтобы он нашёл этот батон в предыдущем месяце во всём столбце, а не в отдельно взятой ячейке и сравнил их суммы в случае нахождения.
Возможно ли это? Массив данных будет порядка 100 строк ежемесячно
К сообщению приложен файл: 1900612.xlsx(9.4 Kb)


Сообщение отредактировал Laeda - Понедельник, 09.11.2020, 09:19
 
Ответить
СообщениеВсем привет.
Помогите составить формулу. Условно есть таблица, состоящая из двух типов данных: Наименование и Сумма в рублях.
Каждый месяц в эту таблицу вносят данные, но в разном порядке. Пример: 1 месяц: батон, хлеб, молоко. 2 месяц: молоко,хлеб, батон. И т.д.
Суть задачи: в столбец "Рост/падение" прописать формулу, которая будет искать искомое наименование в предыдущем месяце и при нахождение его сравнивать сумму текущего месяца с предыдущим. В случае если Сумма больше предыдущего, то "пишет" РОСТ, если меньше, то "Падение".Если же он не найдёт такое наименование в предыдущем месяце, то пишет "NEW".
Excel пример во вложении
Я прописал базовую формулу
Код
=ЕСЛИ(E3=B3;ЕСЛИ(F3>C3;"рост";"падение"))
- это на примере анализа Батона из второго месяца. Но он сравнивает только ячейку и ячейкой и совпадение наименований, но задача, чтобы он нашёл этот батон в предыдущем месяце во всём столбце, а не в отдельно взятой ячейке и сравнил их суммы в случае нахождения.
Возможно ли это? Массив данных будет порядка 100 строк ежемесячно

Автор - Laeda
Дата добавления - 09.11.2020 в 08:39
китин Дата: Понедельник, 09.11.2020, 09:06 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6319
Репутация: 970 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Laeda, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеLaeda, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 09.11.2020 в 09:06
китин Дата: Понедельник, 09.11.2020, 10:00 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6319
Репутация: 970 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
Код
=ЕСЛИ(E3<ИНДЕКС(B$3:B$6;ПОИСКПОЗ(D3;A$3:A$6;0));"падение";ЕСЛИ(E3=ИНДЕКС(B$3:B$6;ПОИСКПОЗ(D3;A$3:A$6;0));"не изменилось";"рост"))
К сообщению приложен файл: 4481235.xlsx(9.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак надо?
Код
=ЕСЛИ(E3<ИНДЕКС(B$3:B$6;ПОИСКПОЗ(D3;A$3:A$6;0));"падение";ЕСЛИ(E3=ИНДЕКС(B$3:B$6;ПОИСКПОЗ(D3;A$3:A$6;0));"не изменилось";"рост"))

Автор - китин
Дата добавления - 09.11.2020 в 10:00
Laeda Дата: Понедельник, 09.11.2020, 10:10 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Да, всё верно. Спасибо!
Но ещё остался один вопрос не закрыт.
А именно случай, когда появляется новое наименование вместо старого. Допустим в 3 месяце вместо батона появился кефир и необходимо,чтобы появлялась надпись NEW, так как это новая позиция.
Заранее вам спасибо
 
Ответить
СообщениеДа, всё верно. Спасибо!
Но ещё остался один вопрос не закрыт.
А именно случай, когда появляется новое наименование вместо старого. Допустим в 3 месяце вместо батона появился кефир и необходимо,чтобы появлялась надпись NEW, так как это новая позиция.
Заранее вам спасибо

Автор - Laeda
Дата добавления - 09.11.2020 в 10:10
китин Дата: Понедельник, 09.11.2020, 10:30 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6319
Репутация: 970 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=ЕСЛИОШИБКА(ЕСЛИ(E3<ИНДЕКС(B$3:B$6;ПОИСКПОЗ(D3;A$3:A$6;0));"падение";ЕСЛИ(E3=ИНДЕКС(B$3:B$6;ПОИСКПОЗ(D3;A$3:A$6;0));"не изменилось";"рост"));"NEW")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ЕСЛИ(E3<ИНДЕКС(B$3:B$6;ПОИСКПОЗ(D3;A$3:A$6;0));"падение";ЕСЛИ(E3=ИНДЕКС(B$3:B$6;ПОИСКПОЗ(D3;A$3:A$6;0));"не изменилось";"рост"));"NEW")

Автор - китин
Дата добавления - 09.11.2020 в 10:30
Laeda Дата: Понедельник, 09.11.2020, 11:25 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо большое. То,что нужно!! hands hands hands
 
Ответить
СообщениеСпасибо большое. То,что нужно!! hands hands hands

Автор - Laeda
Дата добавления - 09.11.2020 в 11:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула поиска наименования и привязки к её значению (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!