Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для составления графика работы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для составления графика работы (Формулы/Formulas)
Формула для составления графика работы
Artem2292 Дата: Понедельник, 09.11.2020, 15:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

2010, 2019, 365
Всем привет!
нужна Ваша помощь.
Делаю график работы сотрудников, где каждый лист это свой отдельный сотрудник. У каждого сотрудника в графике работы есть 2 критерия - работа на удаленке и работа в офисе. Пытаюсь сделать так, что если сегодня человек работает в офисе, то в ячейке офис сегодняшнего дня будет стоять 8 часов, соответственно в ячейке удаленка сегодняшнего дня будет пусто. И наоборот. Т.е. нужно простое чередование. все ломаю голову и не понимаю, какую формулу сюда прикрутить..
заранее спасибо
К сообщению приложен файл: 8933237.xlsb(17.7 Kb)
 
Ответить
СообщениеВсем привет!
нужна Ваша помощь.
Делаю график работы сотрудников, где каждый лист это свой отдельный сотрудник. У каждого сотрудника в графике работы есть 2 критерия - работа на удаленке и работа в офисе. Пытаюсь сделать так, что если сегодня человек работает в офисе, то в ячейке офис сегодняшнего дня будет стоять 8 часов, соответственно в ячейке удаленка сегодняшнего дня будет пусто. И наоборот. Т.е. нужно простое чередование. все ломаю голову и не понимаю, какую формулу сюда прикрутить..
заранее спасибо

Автор - Artem2292
Дата добавления - 09.11.2020 в 15:37
bigor Дата: Понедельник, 09.11.2020, 15:50 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Привет
Как вариант:
Для офиса
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ(ОСТАТ(ДЕНЬНЕД(C$2);2);"";"8,2"))

для удаленки
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ(ОСТАТ(ДЕНЬНЕД(C$2);2);"8,2";""))
 
Ответить
СообщениеПривет
Как вариант:
Для офиса
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ(ОСТАТ(ДЕНЬНЕД(C$2);2);"";"8,2"))

для удаленки
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ(ОСТАТ(ДЕНЬНЕД(C$2);2);"8,2";""))

Автор - bigor
Дата добавления - 09.11.2020 в 15:50
Artem2292 Дата: Понедельник, 09.11.2020, 16:22 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

2010, 2019, 365
Как вариант:

спасибо! почти то, что нужно. :)
Осталось чуть подумать над тем, чтобы выбирать вручную начало работы (с удаленки начинается месяц или с офиса)
 
Ответить
Сообщение
Как вариант:

спасибо! почти то, что нужно. :)
Осталось чуть подумать над тем, чтобы выбирать вручную начало работы (с удаленки начинается месяц или с офиса)

Автор - Artem2292
Дата добавления - 09.11.2020 в 16:22
bigor Дата: Понедельник, 09.11.2020, 17:52 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Лучше наверное по числам проверять, четность, а не по дням недели, и ячейка B1 выбора с чего начинать.
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ($B$1-ОСТАТ(C$2;2);"";"8,2"))
 
Ответить
СообщениеЛучше наверное по числам проверять, четность, а не по дням недели, и ячейка B1 выбора с чего начинать.
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ($B$1-ОСТАТ(C$2;2);"";"8,2"))

Автор - bigor
Дата добавления - 09.11.2020 в 17:52
Artem2292 Дата: Вторник, 10.11.2020, 10:47 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

2010, 2019, 365
Лучше наверное по числам проверять, четность, а не по дням недели, и ячейка B1 выбора с чего начинать.

Добрый день!
Вроде не совсем работает Ваша формула. Результат выводить, выводит, а вот ячейки в строках не чередует, т.е. если сегодня в офисе стоит 8,2ч, то и на удаленке сегодня тоже будет 8,2ч
 
Ответить
Сообщение
Лучше наверное по числам проверять, четность, а не по дням недели, и ячейка B1 выбора с чего начинать.

Добрый день!
Вроде не совсем работает Ваша формула. Результат выводить, выводит, а вот ячейки в строках не чередует, т.е. если сегодня в офисе стоит 8,2ч, то и на удаленке сегодня тоже будет 8,2ч

Автор - Artem2292
Дата добавления - 10.11.2020 в 10:47
bigor Дата: Вторник, 10.11.2020, 10:53 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Потому что должно быть 2 разных формулы для офиса и удаленки, я вторую не стал копировать, она такая же, только поменять местами "8.2" и "" по аналогии с #2
 
Ответить
СообщениеПотому что должно быть 2 разных формулы для офиса и удаленки, я вторую не стал копировать, она такая же, только поменять местами "8.2" и "" по аналогии с #2

Автор - bigor
Дата добавления - 10.11.2020 в 10:53
Artem2292 Дата: Вторник, 10.11.2020, 13:16 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

2010, 2019, 365
Потому что должно быть 2 разных формулы для офиса и удаленки, я вторую не стал копировать, она такая же, только поменять местами "8.2" и "" по аналогии с #2

блин, затупил.. вот слепой %)
и последний вопрос. Возможно ли к этой формуле прикрутить условие, чтобы каждую пятницу было не 8,2ч, а 7,2 ? независимо, дома или на работе
 
Ответить
Сообщение
Потому что должно быть 2 разных формулы для офиса и удаленки, я вторую не стал копировать, она такая же, только поменять местами "8.2" и "" по аналогии с #2

блин, затупил.. вот слепой %)
и последний вопрос. Возможно ли к этой формуле прикрутить условие, чтобы каждую пятницу было не 8,2ч, а 7,2 ? независимо, дома или на работе

Автор - Artem2292
Дата добавления - 10.11.2020 в 13:16
bigor Дата: Вторник, 10.11.2020, 13:30 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Можно, допишите еще одно условие до последнего если вместо "8.2"


Сообщение отредактировал bigor - Вторник, 10.11.2020, 13:31
 
Ответить
СообщениеМожно, допишите еще одно условие до последнего если вместо "8.2"

Автор - bigor
Дата добавления - 10.11.2020 в 13:30
Artem2292 Дата: Вторник, 10.11.2020, 17:13 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

2010, 2019, 365
Можно, допишите еще одно условие до последнего если вместо "8.2"

все же слишком тупой я .. не выходит. К этой
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ($B$1-ОСТАТ(C$2;2);"";"8,2"))

добавляю условие
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ($B$1-ОСТАТ(C$2;2);"8,2";ЕСЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=5;"7,2")))
в тоге получается, что ячейки через одну становятся 8,2 / 7,2 и естественно выходные
 
Ответить
Сообщение
Можно, допишите еще одно условие до последнего если вместо "8.2"

все же слишком тупой я .. не выходит. К этой
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ($B$1-ОСТАТ(C$2;2);"";"8,2"))

добавляю условие
Код
=ЕСЛИ(ИЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=7);"В";ЕСЛИ($B$1-ОСТАТ(C$2;2);"8,2";ЕСЛИ(ДЕНЬНЕД(C$2)=1;ДЕНЬНЕД(C$2)=5;"7,2")))
в тоге получается, что ячейки через одну становятся 8,2 / 7,2 и естественно выходные

Автор - Artem2292
Дата добавления - 10.11.2020 в 17:13
bigor Дата: Вторник, 10.11.2020, 19:24 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
Для офиса
Код
=IF(OR(WEEKDAY(C$2)=1;WEEKDAY(C$2)=7);"В";IF($B$1-MOD(C$2;2);"";IF(WEEKDAY(C$2)=6;"7,2";"8,2")))

Для удаленки
Код
=IF(OR(WEEKDAY(C$2)=1;WEEKDAY(C$2)=7);"В";IF($B$1-MOD(C$2;2);IF(WEEKDAY(C$2)=6;"7,2";"8,2");""))
 
Ответить
СообщениеДля офиса
Код
=IF(OR(WEEKDAY(C$2)=1;WEEKDAY(C$2)=7);"В";IF($B$1-MOD(C$2;2);"";IF(WEEKDAY(C$2)=6;"7,2";"8,2")))

Для удаленки
Код
=IF(OR(WEEKDAY(C$2)=1;WEEKDAY(C$2)=7);"В";IF($B$1-MOD(C$2;2);IF(WEEKDAY(C$2)=6;"7,2";"8,2");""))

Автор - bigor
Дата добавления - 10.11.2020 в 19:24
Artem2292 Дата: Четверг, 12.11.2020, 15:15 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

2010, 2019, 365
Всем привет!
Снова нужна Ваша помощь..
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(ДЕНЬНЕД(B$23)=1;ДЕНЬНЕД(B$23)=7);"В";ЕСЛИ(НЕ(ЕНД(ВПР(B$23;Праздники!$A:$A;1;0)));"П";ЕСЛИ(НЕ(ЕНД(ВПР(B$23;Праздники!$B:$B;1;0)));"7,2";ЕСЛИ($C$5-ОСТАТ(B$23;2);"";ЕСЛИ(ДЕНЬНЕД(B$23)=6;"7,2";"8,2")))));"")

добавил в формулу праздничные и предпраздничные дни. Вроде все работает корректно до момента праздничного дня - как только появляется праздничный день, то в предпраздничном дне получается, что часы стоят и в офисе и в удаленке. а нужно только или там или там. Не совсем понимаю, в какую сторону копать..


Сообщение отредактировал Artem2292 - Четверг, 12.11.2020, 15:20
 
Ответить
СообщениеВсем привет!
Снова нужна Ваша помощь..
Код
=ЕСЛИОШИБКА(ЕСЛИ(ИЛИ(ДЕНЬНЕД(B$23)=1;ДЕНЬНЕД(B$23)=7);"В";ЕСЛИ(НЕ(ЕНД(ВПР(B$23;Праздники!$A:$A;1;0)));"П";ЕСЛИ(НЕ(ЕНД(ВПР(B$23;Праздники!$B:$B;1;0)));"7,2";ЕСЛИ($C$5-ОСТАТ(B$23;2);"";ЕСЛИ(ДЕНЬНЕД(B$23)=6;"7,2";"8,2")))));"")

добавил в формулу праздничные и предпраздничные дни. Вроде все работает корректно до момента праздничного дня - как только появляется праздничный день, то в предпраздничном дне получается, что часы стоят и в офисе и в удаленке. а нужно только или там или там. Не совсем понимаю, в какую сторону копать..

Автор - Artem2292
Дата добавления - 12.11.2020 в 15:15
bigor Дата: Четверг, 12.11.2020, 16:54 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
в какую сторону копать..
файл нужен тестовый
 
Ответить
Сообщение
в какую сторону копать..
файл нужен тестовый

Автор - bigor
Дата добавления - 12.11.2020 в 16:54
Artem2292 Дата: Четверг, 12.11.2020, 17:09 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

2010, 2019, 365
файл нужен тестовый

сделал, что в ноябре условно 3 праздника - 04.11, 11.11 и 19.11. Сейчас пытаюсь сделать так, чтобы каждый предпраздничный день был на час меньше и часы были заполнены или в офисе или в удаленке.
К сообщению приложен файл: _1.xlsb(18.7 Kb)
 
Ответить
Сообщение
файл нужен тестовый

сделал, что в ноябре условно 3 праздника - 04.11, 11.11 и 19.11. Сейчас пытаюсь сделать так, чтобы каждый предпраздничный день был на час меньше и часы были заполнены или в офисе или в удаленке.

Автор - Artem2292
Дата добавления - 12.11.2020 в 17:09
bigor Дата: Четверг, 12.11.2020, 19:42 | Сообщение № 14
Группа: Проверенные
Ранг: Обитатель
Сообщений: 334
Репутация: 63 ±
Замечаний: 0% ±

Excel 2016
1:
Код
=IFERROR(IF(OR(WEEKDAY(B$2)=1;WEEKDAY(B$2)=7);"В";IF(NOT(ISNA(VLOOKUP(B$2;$Праздники.$A$1:$A$10;1;0)));"П";IF($B$1-MOD(B$2;2);"";IF(OR(WEEKDAY(B$2)=6;(NOT(ISNA(VLOOKUP(B$2;$Праздники.$B$1:$B$10;1;0)))));"7,2";"8,2"))));"")

2:
Код
=IFERROR(IF(OR(WEEKDAY(B$2)=1;WEEKDAY(B$2)=7);"В";IF(NOT(ISNA(VLOOKUP(B$2;$Праздники.$A$1:$A$10;1;0)));"П";IF($B$1-MOD(B$2;2);IF(OR(WEEKDAY(B$2)=6;(NOT(ISNA(VLOOKUP(B$2;$Праздники.$B$1:$B$10;1;0)))));"7,2";"8,2");"")));"")
 
Ответить
Сообщение1:
Код
=IFERROR(IF(OR(WEEKDAY(B$2)=1;WEEKDAY(B$2)=7);"В";IF(NOT(ISNA(VLOOKUP(B$2;$Праздники.$A$1:$A$10;1;0)));"П";IF($B$1-MOD(B$2;2);"";IF(OR(WEEKDAY(B$2)=6;(NOT(ISNA(VLOOKUP(B$2;$Праздники.$B$1:$B$10;1;0)))));"7,2";"8,2"))));"")

2:
Код
=IFERROR(IF(OR(WEEKDAY(B$2)=1;WEEKDAY(B$2)=7);"В";IF(NOT(ISNA(VLOOKUP(B$2;$Праздники.$A$1:$A$10;1;0)));"П";IF($B$1-MOD(B$2;2);IF(OR(WEEKDAY(B$2)=6;(NOT(ISNA(VLOOKUP(B$2;$Праздники.$B$1:$B$10;1;0)))));"7,2";"8,2");"")));"")

Автор - bigor
Дата добавления - 12.11.2020 в 19:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для составления графика работы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!