Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт ячеек между повторяющимися значениями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек между повторяющимися значениями (Формулы/Formulas)
Подсчёт ячеек между повторяющимися значениями
emmett_brown Дата: Четверг, 12.11.2020, 16:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Необходимо в столбцах С,D,E подсчитать количество ячеек между повторяющимися значениями в столбце B. Цветом выделены повторяющиеся значения, в столбцах G,H,I значения которые необходимо что бы считала формула.Помогите, пожалуйста, заранее спасибо.
К сообщению приложен файл: 2551871.xlsx(11.0 Kb)


Rock'N'Roll

Сообщение отредактировал emmett_brown - Четверг, 12.11.2020, 19:39
 
Ответить
СообщениеНеобходимо в столбцах С,D,E подсчитать количество ячеек между повторяющимися значениями в столбце B. Цветом выделены повторяющиеся значения, в столбцах G,H,I значения которые необходимо что бы считала формула.Помогите, пожалуйста, заранее спасибо.

Автор - emmett_brown
Дата добавления - 12.11.2020 в 16:41
Светлый Дата: Пятница, 13.11.2020, 09:30 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1508
Репутация: 392 ±
Замечаний: 0% ±

Excel 2010, 2013
И Вам, здравствуйте!
Вот такая массивная формула для третьего столбца:
Код
=СТРОКА()-МАКС(1;($B$1:$B1>3)*СТРОКА($1:1))
Для первых столбцов заменить >3 на =0 или =1
*Тема: Скорее это расстояние до ближайшего заданного значения, а не подсчёт ячеек.
К сообщению приложен файл: 2551871-1.xlsx(14.4 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 13.11.2020, 09:43
 
Ответить
СообщениеИ Вам, здравствуйте!
Вот такая массивная формула для третьего столбца:
Код
=СТРОКА()-МАКС(1;($B$1:$B1>3)*СТРОКА($1:1))
Для первых столбцов заменить >3 на =0 или =1
*Тема: Скорее это расстояние до ближайшего заданного значения, а не подсчёт ячеек.

Автор - Светлый
Дата добавления - 13.11.2020 в 09:30
emmett_brown Дата: Пятница, 13.11.2020, 12:18 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Светлый, Спасибо большое, а возможно сделать так что бы было видно только итоговое расстояние между ячеек, без промежуточных 1,2,3..., как в исходном файле???


Rock'N'Roll

Сообщение отредактировал emmett_brown - Пятница, 13.11.2020, 12:18
 
Ответить
СообщениеСветлый, Спасибо большое, а возможно сделать так что бы было видно только итоговое расстояние между ячеек, без промежуточных 1,2,3..., как в исходном файле???

Автор - emmett_brown
Дата добавления - 13.11.2020 в 12:18
Светлый Дата: Суббота, 14.11.2020, 20:28 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1508
Репутация: 392 ±
Замечаний: 0% ±

Excel 2010, 2013
Для первых двух столбцов формула массива:
Код
=ЕСЛИ($B2=C$1;СТРОКА()-МАКС(1;($B$1:$B1=C$1)*СТРОКА($1:1));"")
Для третьего:
Код
=ЕСЛИ($B2>3;СТРОКА()-МАКС(1;($B$1:$B1>3)*СТРОКА($1:1));"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДля первых двух столбцов формула массива:
Код
=ЕСЛИ($B2=C$1;СТРОКА()-МАКС(1;($B$1:$B1=C$1)*СТРОКА($1:1));"")
Для третьего:
Код
=ЕСЛИ($B2>3;СТРОКА()-МАКС(1;($B$1:$B1>3)*СТРОКА($1:1));"")

Автор - Светлый
Дата добавления - 14.11.2020 в 20:28
emmett_brown Дата: Понедельник, 16.11.2020, 11:28 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Еще раз, большое спасибо)А можно добавить что бы итоговые значения сразу подсвечивались нужным цветом?


Rock'N'Roll

Сообщение отредактировал emmett_brown - Понедельник, 16.11.2020, 12:07
 
Ответить
СообщениеЕще раз, большое спасибо)А можно добавить что бы итоговые значения сразу подсвечивались нужным цветом?

Автор - emmett_brown
Дата добавления - 16.11.2020 в 11:28
китин Дата: Понедельник, 16.11.2020, 13:50 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 6366
Репутация: 975 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
emmett_brown, - Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема
Мне бы воды попить, а то так есть хочется , что даже спать негде!!!!


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеemmett_brown, - Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема
Мне бы воды попить, а то так есть хочется , что даже спать негде!!!!

Автор - китин
Дата добавления - 16.11.2020 в 13:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт ячеек между повторяющимися значениями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!