Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/отображение чисел в таблице 4. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » отображение чисел в таблице 4. (Формулы/Formulas)
отображение чисел в таблице 4.
artastrelok Дата: Суббота, 14.11.2020, 13:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
добрый день. спасибо что помогли решить предыдущую задачу. теперь: таблица цифр слева должна распределяться в новой таблице но при этом надо что бы считалось расстояние одной цифры при её повторе. ниже пример.
К сообщению приложен файл: 6805617.xlsx(13.8 Kb)
 
Ответить
Сообщениедобрый день. спасибо что помогли решить предыдущую задачу. теперь: таблица цифр слева должна распределяться в новой таблице но при этом надо что бы считалось расстояние одной цифры при её повторе. ниже пример.

Автор - artastrelok
Дата добавления - 14.11.2020 в 13:31
bigor Дата: Суббота, 14.11.2020, 16:32 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 383
Репутация: 67 ±
Замечаний: 0% ±

Excel 2016
Добрый
Проверяйте. Массивная
Код
=IFERROR(SMALL(IF(C$2:C$18>=AW$1;ROW(A$2:A$18)-1;"");ROW(A2))-(SMALL(IF(C$2:C$18>=AW$1;ROW(A$2:A$18)-1;"");ROW(A1)));"")
 
Ответить
СообщениеДобрый
Проверяйте. Массивная
Код
=IFERROR(SMALL(IF(C$2:C$18>=AW$1;ROW(A$2:A$18)-1;"");ROW(A2))-(SMALL(IF(C$2:C$18>=AW$1;ROW(A$2:A$18)-1;"");ROW(A1)));"")

Автор - bigor
Дата добавления - 14.11.2020 в 16:32
artastrelok Дата: Суббота, 14.11.2020, 20:03 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
что-то не работает.
 
Ответить
Сообщениечто-то не работает.

Автор - artastrelok
Дата добавления - 14.11.2020 в 20:03
bigor Дата: Суббота, 14.11.2020, 21:22 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 383
Репутация: 67 ±
Замечаний: 0% ±

Excel 2016
Массивная
Вводится 3-мя кнопками Ctrl+Shift+Enter
Если не заработает, приложите файл с ошибкой.
 
Ответить
Сообщение
Массивная
Вводится 3-мя кнопками Ctrl+Shift+Enter
Если не заработает, приложите файл с ошибкой.

Автор - bigor
Дата добавления - 14.11.2020 в 21:22
прохожий2019 Дата: Суббота, 14.11.2020, 21:41 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 401
Репутация: 68 ±
Замечаний: 0% ±

365 Beta Channel
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(C2:C18;СТРОКА(C2:C18);"");СТРОКА(A2:A18))-НАИМЕНЬШИЙ(ЕСЛИ(C2:C18;СТРОКА(C2:C18);"");СТРОКА(A1:A17));"")
К сообщению приложен файл: 2031012.xlsx(19.6 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(C2:C18;СТРОКА(C2:C18);"");СТРОКА(A2:A18))-НАИМЕНЬШИЙ(ЕСЛИ(C2:C18;СТРОКА(C2:C18);"");СТРОКА(A1:A17));"")

Автор - прохожий2019
Дата добавления - 14.11.2020 в 21:41
artastrelok Дата: Воскресенье, 15.11.2020, 20:54 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
после копирования формул от прохохий2019 и попытки изменения, пишет xl "нельзя изменять часть массива"
 
Ответить
Сообщениепосле копирования формул от прохохий2019 и попытки изменения, пишет xl "нельзя изменять часть массива"

Автор - artastrelok
Дата добавления - 15.11.2020 в 20:54
bigor Дата: Воскресенье, 15.11.2020, 21:26 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 383
Репутация: 67 ±
Замечаний: 0% ±

Excel 2016
Выделите столбец таблицы и правьте
 
Ответить
СообщениеВыделите столбец таблицы и правьте

Автор - bigor
Дата добавления - 15.11.2020 в 21:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » отображение чисел в таблице 4. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!