Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отображение диапазона чисел От и До в формуле - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение диапазона чисел От и До в формуле (Формулы/Formulas)
Отображение диапазона чисел От и До в формуле
emmett_brown Дата: Понедельник, 23.11.2020, 19:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте, подскажите пожалуйста как как внести в формулу диапазон от 3 до 6, чтобы отображались значения только в данном диапазоне.
К сообщению приложен файл: 3161106.xlsx(11.8 Kb)


Rock'N'Roll
 
Ответить
СообщениеЗдравствуйте, подскажите пожалуйста как как внести в формулу диапазон от 3 до 6, чтобы отображались значения только в данном диапазоне.

Автор - emmett_brown
Дата добавления - 23.11.2020 в 19:49
bigor Дата: Понедельник, 23.11.2020, 20:04 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 399
Репутация: 71 ±
Замечаний: 0% ±

Excel 2016
Не понятны условия,укажите что должно быть в третьем столбце
 
Ответить
СообщениеНе понятны условия,укажите что должно быть в третьем столбце

Автор - bigor
Дата добавления - 23.11.2020 в 20:04
gling Дата: Понедельник, 23.11.2020, 20:17 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2228
Репутация: 556 ±
Замечаний: 0% ±

2010
Тоже не понял что надо, но может быть подойдет эта формула массива?
Код
=ЕСЛИ($B2<3;СТРОКА()-МАКС(1;($B$1:$B1<3)*($B$1:$B1>6)*СТРОКА($1:1));"")


ЯД-41001506838083
 
Ответить
СообщениеТоже не понял что надо, но может быть подойдет эта формула массива?
Код
=ЕСЛИ($B2<3;СТРОКА()-МАКС(1;($B$1:$B1<3)*($B$1:$B1>6)*СТРОКА($1:1));"")

Автор - gling
Дата добавления - 23.11.2020 в 20:17
emmett_brown Дата: Понедельник, 23.11.2020, 21:58 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Прошу прощения за неточную формулировку, в третьем столбце должно быть расстояние между значениями из диапазона, как в 4, где значение <2
К сообщению приложен файл: _3161106-1.xlsx(12.3 Kb)


Rock'N'Roll
 
Ответить
СообщениеПрошу прощения за неточную формулировку, в третьем столбце должно быть расстояние между значениями из диапазона, как в 4, где значение <2

Автор - emmett_brown
Дата добавления - 23.11.2020 в 21:58
bigor Дата: Понедельник, 23.11.2020, 22:10 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 399
Репутация: 71 ±
Замечаний: 0% ±

Excel 2016
Ну тогда добавляем условие, и вводим как массивную
Код
=IF(AND(B2<6;B2>3);ROW()-MAX(1;($B$1:$B1<6)*($B$1:$B4>3)*ROW($1:1));"")

У Вас кстати ошибки в примере.
 
Ответить
СообщениеНу тогда добавляем условие, и вводим как массивную
Код
=IF(AND(B2<6;B2>3);ROW()-MAX(1;($B$1:$B1<6)*($B$1:$B4>3)*ROW($1:1));"")

У Вас кстати ошибки в примере.

Автор - bigor
Дата добавления - 23.11.2020 в 22:10
emmett_brown Дата: Понедельник, 23.11.2020, 22:17 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
=ЕСЛИ(И(B2<6;B2>3);СТРОКА()-МАКС(1;($B$1:$B1<6)*($B$1:$B4>3)*СТРОКА($1:1));"")

Да ошибка была) Пишет недопустимое значение
К сообщению приложен файл: -3161106-1-1.xlsx(13.5 Kb)


Rock'N'Roll
 
Ответить
Сообщение
=ЕСЛИ(И(B2<6;B2>3);СТРОКА()-МАКС(1;($B$1:$B1<6)*($B$1:$B4>3)*СТРОКА($1:1));"")

Да ошибка была) Пишет недопустимое значение

Автор - emmett_brown
Дата добавления - 23.11.2020 в 22:17
bigor Дата: Понедельник, 23.11.2020, 22:25 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 399
Репутация: 71 ±
Замечаний: 0% ±

Excel 2016
Пишет недопустимое значение

В смысле не работает в excel? Я сегодня проверить не смогу/
 
Ответить
Сообщение
Пишет недопустимое значение

В смысле не работает в excel? Я сегодня проверить не смогу/

Автор - bigor
Дата добавления - 23.11.2020 в 22:25
emmett_brown Дата: Понедельник, 23.11.2020, 22:27 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Да не работает к сожалению


Rock'N'Roll
 
Ответить
СообщениеДа не работает к сожалению

Автор - emmett_brown
Дата добавления - 23.11.2020 в 22:27
bigor Дата: Понедельник, 23.11.2020, 22:37 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 399
Репутация: 71 ±
Замечаний: 0% ±

Excel 2016
Мой косяк, вот так должно быть
Код
=ЕСЛИ(И(B2<6;B2>3);СТРОКА()-МАКС(1;($B$1:$B1<6)*($B$1:$B1>3)*СТРОКА($1:1));"")
 
Ответить
СообщениеМой косяк, вот так должно быть
Код
=ЕСЛИ(И(B2<6;B2>3);СТРОКА()-МАКС(1;($B$1:$B1<6)*($B$1:$B1>3)*СТРОКА($1:1));"")

Автор - bigor
Дата добавления - 23.11.2020 в 22:37
emmett_brown Дата: Понедельник, 23.11.2020, 22:45 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Все работает) Спасибо огромное за помощь


Rock'N'Roll
 
Ответить
СообщениеВсе работает) Спасибо огромное за помощь

Автор - emmett_brown
Дата добавления - 23.11.2020 в 22:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение диапазона чисел От и До в формуле (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!