Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет уникальных значений в определенную дату - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет уникальных значений в определенную дату (Формулы/Formulas)
Подсчет уникальных значений в определенную дату
kuyann Дата: Вторник, 24.11.2020, 23:53 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Подскажите, как формулой посчитать количество уникальных заказов в определенный день?
К сообщению приложен файл: _____.xlsx(22.9 Kb)
 
Ответить
СообщениеПодскажите, как формулой посчитать количество уникальных заказов в определенный день?

Автор - kuyann
Дата добавления - 24.11.2020 в 23:53
Pelena Дата: Среда, 25.11.2020, 07:48 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17222
Репутация: 3751 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИМН(B2:B898;B2:B898)*(A2:A898=H1))

если принять, что в разные дни нет одинаковых номеров заказов
Или более универсальная формула массива
Код
=СУММ(ЕСЛИ(A2:A898=H1;1/СЧЁТЕСЛИМН(B2:B898;B2:B898;A2:A898;H1)))

В любом случае даты в первом столбце нужно сделать датами. Сейчас это текст.
Выделите первый столбец -- Данные -- Текст по столбцам -- Готово
К сообщению приложен файл: 0539118.xlsx(23.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(1/СЧЁТЕСЛИМН(B2:B898;B2:B898)*(A2:A898=H1))

если принять, что в разные дни нет одинаковых номеров заказов
Или более универсальная формула массива
Код
=СУММ(ЕСЛИ(A2:A898=H1;1/СЧЁТЕСЛИМН(B2:B898;B2:B898;A2:A898;H1)))

В любом случае даты в первом столбце нужно сделать датами. Сейчас это текст.
Выделите первый столбец -- Данные -- Текст по столбцам -- Готово

Автор - Pelena
Дата добавления - 25.11.2020 в 07:48
bmv98rus Дата: Среда, 25.11.2020, 08:05 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3412
Репутация: 590 ±
Замечаний: 0% ±

Excel 2013/2016
Быстрый и альтернативный массивный вариант
Код
=SUM(--IF(A2:A898=H1;MATCH(B2:B898;B:B;)=ROW(A2:A898)))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеБыстрый и альтернативный массивный вариант
Код
=SUM(--IF(A2:A898=H1;MATCH(B2:B898;B:B;)=ROW(A2:A898)))

Автор - bmv98rus
Дата добавления - 25.11.2020 в 08:05
kuyann Дата: Четверг, 26.11.2020, 14:06 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем большое спасибо) все работает))
 
Ответить
СообщениеВсем большое спасибо) все работает))

Автор - kuyann
Дата добавления - 26.11.2020 в 14:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет уникальных значений в определенную дату (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!