Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для многолетнего графика проверки оборудования - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для многолетнего графика проверки оборудования (Формулы/Formulas)
Формула для многолетнего графика проверки оборудования
Vitaliy23 Дата: Пятница, 04.12.2020, 19:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
как создать формулу в Excel
для многолетнего графика периодической проверки оборудования.
Задача стоит такая: Есть перечень оборудования в нем по годам забиты даты проверки колонка "план"
когда подходит срок проверки ставим дату в колонке "Факт",
необходимо что бы срок следующей проверки обозначился в колонке "план" в том году,
когда прийдет время - через заданную периодичность.


С уважением Виталий

Сообщение отредактировал Vitaliy23 - Пятница, 04.12.2020, 20:29
 
Ответить
Сообщениекак создать формулу в Excel
для многолетнего графика периодической проверки оборудования.
Задача стоит такая: Есть перечень оборудования в нем по годам забиты даты проверки колонка "план"
когда подходит срок проверки ставим дату в колонке "Факт",
необходимо что бы срок следующей проверки обозначился в колонке "план" в том году,
когда прийдет время - через заданную периодичность.

Автор - Vitaliy23
Дата добавления - 04.12.2020 в 19:47
tatianaTP Дата: Пятница, 04.12.2020, 20:07 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 6 ±
Замечаний: 0% ±

Excel 2013
непонятно какая формула нужна
 
Ответить
Сообщениенепонятно какая формула нужна

Автор - tatianaTP
Дата добавления - 04.12.2020 в 20:07
Vitaliy23 Дата: Пятница, 04.12.2020, 20:27 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
tatianaTP,
К сообщению приложен файл: 8535958.xlsx(10.1 Kb)


С уважением Виталий
 
Ответить
СообщениеtatianaTP,

Автор - Vitaliy23
Дата добавления - 04.12.2020 в 20:27
NikitaDvorets Дата: Понедельник, 07.12.2020, 12:45 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 104
Репутация: 179 ±
Замечаний: 0% ±

Excel 2019
Добрый день.
Эта задача - проект для экспертов по макросам с применением методов управления событиями.
 
Ответить
СообщениеДобрый день.
Эта задача - проект для экспертов по макросам с применением методов управления событиями.

Автор - NikitaDvorets
Дата добавления - 07.12.2020 в 12:45
alexa1965 Дата: Понедельник, 07.12.2020, 13:34 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 16 ±
Замечаний: 0% ±

2003> 2010> 2016
Код
=ЕСЛИ(G$1=ГОД($D3+ДАТА($C3;1;0));$D3+ДАТА($C3;1;0);"")
Для ячейки план, сделано для столбца G


Главное не быть балабастиком
 
Ответить
Сообщение
Код
=ЕСЛИ(G$1=ГОД($D3+ДАТА($C3;1;0));$D3+ДАТА($C3;1;0);"")
Для ячейки план, сделано для столбца G

Автор - alexa1965
Дата добавления - 07.12.2020 в 13:34
alexa1965 Дата: Понедельник, 07.12.2020, 14:00 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 16 ±
Замечаний: 0% ±

2003> 2010> 2016
Код
=ЕСЛИ(G3="";ЕСЛИ(I$1=ГОД($D3+ДАТА($C3;1;0));$D3+ДАТА($C3;1;0);"");ЕСЛИ(I$1=ГОД(G3+ДАТА($C3;1;0));G3+ДАТА($C3;1;0);""))
Для других столбцов с ячейками план... Не сразу заметил ежегодное повторение


Главное не быть балабастиком
 
Ответить
Сообщение
Код
=ЕСЛИ(G3="";ЕСЛИ(I$1=ГОД($D3+ДАТА($C3;1;0));$D3+ДАТА($C3;1;0);"");ЕСЛИ(I$1=ГОД(G3+ДАТА($C3;1;0));G3+ДАТА($C3;1;0);""))
Для других столбцов с ячейками план... Не сразу заметил ежегодное повторение

Автор - alexa1965
Дата добавления - 07.12.2020 в 14:00
Vitaliy23 Дата: Понедельник, 07.12.2020, 19:58 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
=ЕСЛИ(G3="";ЕСЛИ(I$1=ГОД($D3+ДАТА($C3;1;0));$D3+ДАТА($C3;1;0);"");ЕСЛИ(I$1=ГОД(G3+ДАТА($C3;1;0));G3+ДАТА($C3;1;0);""))
Для других столбцов с ячейками план... Не сразу заметил ежегодное повторение
Внес формулы или что то я не так делаю или что то не то. Первую формулу скопировал и вставил в ячейку G3 и протянул в низ до конца таблицы. Вторую формулу скопировал и вставил в другие ячейки с планом. При внесении в ячейку факт - ни чего не происходит. Вот. Прикрепляю фаил с чистым графиком.
К сообщению приложен файл: ___.xlsx(10.5 Kb)


С уважением Виталий

Сообщение отредактировал Vitaliy23 - Понедельник, 07.12.2020, 23:21
 
Ответить
Сообщение
=ЕСЛИ(G3="";ЕСЛИ(I$1=ГОД($D3+ДАТА($C3;1;0));$D3+ДАТА($C3;1;0);"");ЕСЛИ(I$1=ГОД(G3+ДАТА($C3;1;0));G3+ДАТА($C3;1;0);""))
Для других столбцов с ячейками план... Не сразу заметил ежегодное повторение
Внес формулы или что то я не так делаю или что то не то. Первую формулу скопировал и вставил в ячейку G3 и протянул в низ до конца таблицы. Вторую формулу скопировал и вставил в другие ячейки с планом. При внесении в ячейку факт - ни чего не происходит. Вот. Прикрепляю фаил с чистым графиком.

Автор - Vitaliy23
Дата добавления - 07.12.2020 в 19:58
alexa1965 Дата: Вторник, 08.12.2020, 08:02 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 226
Репутация: 16 ±
Замечаний: 0% ±

2003> 2010> 2016
Утро доброе! Вы изменили исходные данные и тогда так: для столбца Е
Код
=ЕСЛИ(E$1=ГОД($D3+ДАТА($C3;1;0));$D3+ДАТА($C3;1;0);"")
, для других
Код
=ЕСЛИ(E3="";ЕСЛИ(G$1=ГОД($E3+ДАТА($C3;1;0));$E3+ДАТА($C3;1;0);"");ЕСЛИ(G$1=ГОД(E3+ДАТА($C3;1;0));E3+ДАТА($C3;1;0);""))

удачи!
К сообщению приложен файл: -1-.xlsx(11.1 Kb)


Главное не быть балабастиком
 
Ответить
СообщениеУтро доброе! Вы изменили исходные данные и тогда так: для столбца Е
Код
=ЕСЛИ(E$1=ГОД($D3+ДАТА($C3;1;0));$D3+ДАТА($C3;1;0);"")
, для других
Код
=ЕСЛИ(E3="";ЕСЛИ(G$1=ГОД($E3+ДАТА($C3;1;0));$E3+ДАТА($C3;1;0);"");ЕСЛИ(G$1=ГОД(E3+ДАТА($C3;1;0));E3+ДАТА($C3;1;0);""))

удачи!

Автор - alexa1965
Дата добавления - 08.12.2020 в 08:02
Vitaliy23 Дата: Вторник, 08.12.2020, 18:54 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
alexa1965, Огромное человеческое спасибо.


С уважением Виталий
 
Ответить
Сообщениеalexa1965, Огромное человеческое спасибо.

Автор - Vitaliy23
Дата добавления - 08.12.2020 в 18:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для многолетнего графика проверки оборудования (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!