Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка значений в ячейки подряд - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений в ячейки подряд (Формулы/Formulas)
Подстановка значений в ячейки подряд
malish606 Дата: Суббота, 12.12.2020, 02:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем привет, еще раз!
Последний бросок и файл будет готов)
Необходимо в листе "Заявка" заполнять ячейки подряд, начиная с первой ячейки (А7),данные сотрудников, на против которых установлены даты в листе "Персонал"
Отображение только выбранных сотрудников я настроил, спасибо bmv98rus !

Заранее спасибо
К сообщению приложен файл: _2.xlsm(52.2 Kb)
 
Ответить
СообщениеВсем привет, еще раз!
Последний бросок и файл будет готов)
Необходимо в листе "Заявка" заполнять ячейки подряд, начиная с первой ячейки (А7),данные сотрудников, на против которых установлены даты в листе "Персонал"
Отображение только выбранных сотрудников я настроил, спасибо bmv98rus !

Заранее спасибо

Автор - malish606
Дата добавления - 12.12.2020 в 02:30
bmv98rus Дата: Суббота, 12.12.2020, 09:20 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3392
Репутация: 585 ±
Замечаний: 0% ±

Excel 2013/2016
ну это просто.Единственное что для 2007 это только массивная и так как там объединенные ячейки а туда массивную ек ввести , то сначала вводим в a7, потом объединяем, и форматируем, после можно протянуть вниз.
Код
=IFERROR(INDEX(Формулы!A:A;SMALL(IF((Формулы!$E$2:$E$25<>0)*(Формулы!$G$2:$G$25<>0);ROW(Формулы!$A$2:$A$25));ROWS($A$7:A7)));"")

По большому счету это можно было использовать и для предыдущего вопроса, но смысла не много.
К сообщению приложен файл: example1992.xlsm(52.5 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Суббота, 12.12.2020, 09:39
 
Ответить
Сообщениену это просто.Единственное что для 2007 это только массивная и так как там объединенные ячейки а туда массивную ек ввести , то сначала вводим в a7, потом объединяем, и форматируем, после можно протянуть вниз.
Код
=IFERROR(INDEX(Формулы!A:A;SMALL(IF((Формулы!$E$2:$E$25<>0)*(Формулы!$G$2:$G$25<>0);ROW(Формулы!$A$2:$A$25));ROWS($A$7:A7)));"")

По большому счету это можно было использовать и для предыдущего вопроса, но смысла не много.

Автор - bmv98rus
Дата добавления - 12.12.2020 в 09:20
Nic70y Дата: Суббота, 12.12.2020, 10:49 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6651
Репутация: 1471 ±
Замечаний: 0% ±

ru13;10;03
а чё зря столбу эйч в "формулах" пустовать
Код
=ЕСЛИ(G2<>0;H1+1;H1)
ну и соот.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Формулы!A:A;ПОИСКПОЗ(E7;Формулы!H:H;));"")
К сообщению приложен файл: 96-2.xlsm(53.3 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениеа чё зря столбу эйч в "формулах" пустовать
Код
=ЕСЛИ(G2<>0;H1+1;H1)
ну и соот.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Формулы!A:A;ПОИСКПОЗ(E7;Формулы!H:H;));"")

Автор - Nic70y
Дата добавления - 12.12.2020 в 10:49
malish606 Дата: Понедельник, 14.12.2020, 01:05 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
bmv98rus, Nic70y, ребята, спасибо! Оба варианта работаю - потестирую оба!!!
 
Ответить
Сообщениеbmv98rus, Nic70y, ребята, спасибо! Оба варианта работаю - потестирую оба!!!

Автор - malish606
Дата добавления - 14.12.2020 в 01:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений в ячейки подряд (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!