Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проблемы с расчетом ранга - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проблемы с расчетом ранга (Формулы/Formulas)
Проблемы с расчетом ранга
locko21rok Дата: Воскресенье, 20.12.2020, 07:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Приветствую!

При расчете ранга, расставляет у повторяющихся числе другие значения или присваивает одинаковый ранг сразу нескольким разным значениям.

Необходимо чтобы получился такой ответ (прикрепляю фото).

Также были проблемы с подсчетами - суммы в баллах-

Изначально вся таблица состояла из формулы:
Код
=ЕСЛИ(L3=T30;"1";ЕСЛИ(L3<T30;"2";ЕСЛИ(L3>T30;"0")))

в таком случае при наборе формул для подсчета суммы, мне всегда высвечивался 0, и только когда изменила формулу по всей таблице на
Код
=СУММ(ЕСЛИ(L3=T30;"1";ЕСЛИ(L3<T30;"2";ЕСЛИ(L3>T30;"0"))))

то стал "видеть" эти числа и смог посчитать мне сумму в баллах для последнего столбика(в последнем столбике стала работать обычная формула СУММ). Объясните почему так может быть, почему подсчет по формуле
Код
=СУММ(B3:U3)

которая была указана в столбике - суммы в баллах-
стал работать только после того как по всей таблице подставила "сумм" перед основной формулой с "если"
К сообщению приложен файл: 8434011.xlsx(25.4 Kb) · 7552137.png(14.2 Kb)
 
Ответить
СообщениеПриветствую!

При расчете ранга, расставляет у повторяющихся числе другие значения или присваивает одинаковый ранг сразу нескольким разным значениям.

Необходимо чтобы получился такой ответ (прикрепляю фото).

Также были проблемы с подсчетами - суммы в баллах-

Изначально вся таблица состояла из формулы:
Код
=ЕСЛИ(L3=T30;"1";ЕСЛИ(L3<T30;"2";ЕСЛИ(L3>T30;"0")))

в таком случае при наборе формул для подсчета суммы, мне всегда высвечивался 0, и только когда изменила формулу по всей таблице на
Код
=СУММ(ЕСЛИ(L3=T30;"1";ЕСЛИ(L3<T30;"2";ЕСЛИ(L3>T30;"0"))))

то стал "видеть" эти числа и смог посчитать мне сумму в баллах для последнего столбика(в последнем столбике стала работать обычная формула СУММ). Объясните почему так может быть, почему подсчет по формуле
Код
=СУММ(B3:U3)

которая была указана в столбике - суммы в баллах-
стал работать только после того как по всей таблице подставила "сумм" перед основной формулой с "если"

Автор - locko21rok
Дата добавления - 20.12.2020 в 07:26
Pelena Дата: Воскресенье, 20.12.2020, 08:44 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17260
Репутация: 3812 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Не надо числа в кавычки заключать, иначе они превращаются в текст
Код
=ЕСЛИ(Лист2!C3=Лист2!K30;1;ЕСЛИ(Лист2!C3<Лист2!K30;2;ЕСЛИ(Лист2!C3>Лист2!K30;0)))

и да, эту формулу можно записать немного короче
Код
=ЗНАК(Лист2!K30-Лист2!C3)+1
К сообщению приложен файл: 8434011_1.xlsx(25.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Не надо числа в кавычки заключать, иначе они превращаются в текст
Код
=ЕСЛИ(Лист2!C3=Лист2!K30;1;ЕСЛИ(Лист2!C3<Лист2!K30;2;ЕСЛИ(Лист2!C3>Лист2!K30;0)))

и да, эту формулу можно записать немного короче
Код
=ЗНАК(Лист2!K30-Лист2!C3)+1

Автор - Pelena
Дата добавления - 20.12.2020 в 08:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проблемы с расчетом ранга (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!