Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление времени стоянки авто.. из даты и времени стоянок. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление времени стоянки авто.. из даты и времени стоянок. (Формулы/Formulas)
Вычисление времени стоянки авто.. из даты и времени стоянок.
fantom2771 Дата: Понедельник, 21.12.2020, 18:49 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток, нужна помощь, необходимо создать формулу для вычисления времени стоянки автомобиля за период в рабочее время с 8:00 по 17:00, но часто автомобиль ночует там же, приезжает и уезжает.
Столбик (1 дата и время), показывает:

1) Начало время стоянки в случае если напротив (ячейки) в столбике (2 Стоянка) отображается время самой стоянки.
2) Начало движения автомобиля в случае если напротив (ячейки) в столбике (2 Стоянка) не отображается время.

Остальные столбики не нужны но может чем пригодятся.

Спасибо.

[p.s.]Буду очень благодарен, мучаюсь уже неделю.
[/p.s.]
К сообщению приложен файл: 01-09_1093_.xls(42.0 Kb)


Сообщение отредактировал fantom2771 - Понедельник, 21.12.2020, 18:50
 
Ответить
СообщениеДоброго времени суток, нужна помощь, необходимо создать формулу для вычисления времени стоянки автомобиля за период в рабочее время с 8:00 по 17:00, но часто автомобиль ночует там же, приезжает и уезжает.
Столбик (1 дата и время), показывает:

1) Начало время стоянки в случае если напротив (ячейки) в столбике (2 Стоянка) отображается время самой стоянки.
2) Начало движения автомобиля в случае если напротив (ячейки) в столбике (2 Стоянка) не отображается время.

Остальные столбики не нужны но может чем пригодятся.

Спасибо.

[p.s.]Буду очень благодарен, мучаюсь уже неделю.
[/p.s.]

Автор - fantom2771
Дата добавления - 21.12.2020 в 18:49
Pelena Дата: Понедельник, 21.12.2020, 19:46 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17231
Репутация: 3762 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Нарисуйте вручную для первых двух дней, в каком виде должен быть результат


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Нарисуйте вручную для первых двух дней, в каком виде должен быть результат

Автор - Pelena
Дата добавления - 21.12.2020 в 19:46
fantom2771 Дата: Понедельник, 21.12.2020, 20:08 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.
Нарисуйте вручную для первых двух дней, в каком виде должен быть результат


Примерно так.
К сообщению приложен файл: 01-09_1093_V2.xls(35.0 Kb)
 
Ответить
Сообщение
Здравствуйте.
Нарисуйте вручную для первых двух дней, в каком виде должен быть результат


Примерно так.

Автор - fantom2771
Дата добавления - 21.12.2020 в 20:08
Pelena Дата: Понедельник, 21.12.2020, 21:52 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17231
Репутация: 3762 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Посмотрите такой вариант
Код
=ЕСЛИ(C12="";"";МАКС("17:00"-МАКС(B12;"8:00");)+МИН(МАКС(B13+(A12<>A13)-"8:00";)-"9:00";))
К сообщению приложен файл: 0742659.xls(35.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПосмотрите такой вариант
Код
=ЕСЛИ(C12="";"";МАКС("17:00"-МАКС(B12;"8:00");)+МИН(МАКС(B13+(A12<>A13)-"8:00";)-"9:00";))

Автор - Pelena
Дата добавления - 21.12.2020 в 21:52
fantom2771 Дата: Вторник, 22.12.2020, 07:53 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Сегодня на работе буду пробовать, не знаю что получится но огромное спасибо.
 
Ответить
СообщениеСегодня на работе буду пробовать, не знаю что получится но огромное спасибо.

Автор - fantom2771
Дата добавления - 22.12.2020 в 07:53
fantom2771 Дата: Вторник, 22.12.2020, 09:32 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Pelena вы гений, супер. Я потратил целую неделю. Спасибо.
 
Ответить
СообщениеPelena вы гений, супер. Я потратил целую неделю. Спасибо.

Автор - fantom2771
Дата добавления - 22.12.2020 в 09:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление времени стоянки авто.. из даты и времени стоянок. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!