Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вытащить данные из массива - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вытащить данные из массива (Формулы/Formulas)
вытащить данные из массива
tov-stalyn Дата: Вторник, 22.12.2020, 17:30 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Имеем большой массив с исходными данными. В одном столбце исходника имеем, например ФИО (пример в файле слева), каждому ФИО может соответствовать любой продукт, закономерности по соответствию нет, абсолютный рандом.
Пишу бюджет, для этого мне надо в отдельном месте вывести все встречающиеся в исходном массиве сочетания фамилий и продуктов, т.е. если в массиве не было "Иванов - рис", то и в сводной таблице такого сочетания не должно быть. Как это можно сделать? Буду признателен за помощь!
К сообщению приложен файл: 9377209.xlsx(9.1 Kb)


Сообщение отредактировал tov-stalyn - Вторник, 22.12.2020, 17:30
 
Ответить
СообщениеДобрый день.
Имеем большой массив с исходными данными. В одном столбце исходника имеем, например ФИО (пример в файле слева), каждому ФИО может соответствовать любой продукт, закономерности по соответствию нет, абсолютный рандом.
Пишу бюджет, для этого мне надо в отдельном месте вывести все встречающиеся в исходном массиве сочетания фамилий и продуктов, т.е. если в массиве не было "Иванов - рис", то и в сводной таблице такого сочетания не должно быть. Как это можно сделать? Буду признателен за помощь!

Автор - tov-stalyn
Дата добавления - 22.12.2020 в 17:30
NikitaDvorets Дата: Вторник, 22.12.2020, 17:57 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 13 ±
Замечаний: 0% ±

Excel 2019
Добрый день.
Как вариант - сводная таблица с настройкой "табличная форма" в конструкторе.
См. лист "Свод" прилагаемого файла.
К сообщению приложен файл: 9377209-solutio.xlsx(13.9 Kb)
 
Ответить
СообщениеДобрый день.
Как вариант - сводная таблица с настройкой "табличная форма" в конструкторе.
См. лист "Свод" прилагаемого файла.

Автор - NikitaDvorets
Дата добавления - 22.12.2020 в 17:57
tov-stalyn Дата: Пятница, 25.12.2020, 10:09 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Цитата NikitaDvorets, 22.12.2020 в 17:57, в сообщении № 2 ()
Как вариант - сводная таблица с настройкой "табличная форма" в конструкторе.
См. лист "Свод" прилагаемого файла.

Добрый день! Спасибо! Хотя, хотелось обойтись без сводных таблиц, т.к. дальше эти поля будут фигурировать в других формулах.
 
Ответить
Сообщение
Цитата NikitaDvorets, 22.12.2020 в 17:57, в сообщении № 2 ()
Как вариант - сводная таблица с настройкой "табличная форма" в конструкторе.
См. лист "Свод" прилагаемого файла.

Добрый день! Спасибо! Хотя, хотелось обойтись без сводных таблиц, т.к. дальше эти поля будут фигурировать в других формулах.

Автор - tov-stalyn
Дата добавления - 25.12.2020 в 10:09
NikitaDvorets Дата: Пятница, 25.12.2020, 13:34 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 13 ±
Замечаний: 0% ±

Excel 2019
Лист сводной таблицы тоже можно использовать для дальнейших вычислений, например: ячейка
Код
B12

Код
=ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ("продукт";$A$3;"исходник";"Иванов";"продукт";"колбаса")+4

т.е. при составлении формулы в ячейке вне сводной таблицы указать на нужную ячейку внутри сводной таблицы.
 
Ответить
СообщениеЛист сводной таблицы тоже можно использовать для дальнейших вычислений, например: ячейка
Код
B12

Код
=ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ("продукт";$A$3;"исходник";"Иванов";"продукт";"колбаса")+4

т.е. при составлении формулы в ячейке вне сводной таблицы указать на нужную ячейку внутри сводной таблицы.

Автор - NikitaDvorets
Дата добавления - 25.12.2020 в 13:34
китин Дата: Пятница, 25.12.2020, 13:38 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6399
Репутация: 984 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
И вам Доброго!!!
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$2:B$20;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($B$2:$B$20&$C$2:$C$20;$B$2:$B$20&$C$2:$C$20;0)=СТРОКА($B$2:$B$20)-1;СТРОКА($B$2:$B$20)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 4031978.xlsx(10.0 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеИ вам Доброго!!!
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$2:B$20;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($B$2:$B$20&$C$2:$C$20;$B$2:$B$20&$C$2:$C$20;0)=СТРОКА($B$2:$B$20)-1;СТРОКА($B$2:$B$20)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 25.12.2020 в 13:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вытащить данные из массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!