Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Просуммировать несколько значений в B, в зависимости от А - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Просуммировать несколько значений в B, в зависимости от А (Формулы/Formulas)
Просуммировать несколько значений в B, в зависимости от А
SergeySE Дата: Четверг, 24.12.2020, 14:21 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Подскажите, пожалуйста, можно ли сосчитать формулами эксель или необходимо придумывать макрос?

Нужно сосчитать 3 лучших значения из столбца B для каждого из параметров в столбце A
Если значений меньше трех, то не считаем. Если больше, то берем только первые три. Значения столбцов меняются, но B всегда отсортирован по лучшему результату.

Есть:
Столбец А Столбец B
Параметр1 250
Параметр1 240
Параметр2 230
Параметр3 220
Параметр2 210
Параметр4 200
Параметр1 190
Параметр3 180
Параметр1 170
Параметр2 160
Параметр3 150
Параметр2 140
Параметр4 130
Параметр2 120
Параметр1 110
Параметр3 100
Параметр3 90

Надо:
Параметр1 680
Параметр2 600
Параметр3 550
К сообщению приложен файл: 4965610.xlsx(10.3 Kb)
 
Ответить
СообщениеПодскажите, пожалуйста, можно ли сосчитать формулами эксель или необходимо придумывать макрос?

Нужно сосчитать 3 лучших значения из столбца B для каждого из параметров в столбце A
Если значений меньше трех, то не считаем. Если больше, то берем только первые три. Значения столбцов меняются, но B всегда отсортирован по лучшему результату.

Есть:
Столбец А Столбец B
Параметр1 250
Параметр1 240
Параметр2 230
Параметр3 220
Параметр2 210
Параметр4 200
Параметр1 190
Параметр3 180
Параметр1 170
Параметр2 160
Параметр3 150
Параметр2 140
Параметр4 130
Параметр2 120
Параметр1 110
Параметр3 100
Параметр3 90

Надо:
Параметр1 680
Параметр2 600
Параметр3 550

Автор - SergeySE
Дата добавления - 24.12.2020 в 14:21
Kostya_Ye Дата: Четверг, 24.12.2020, 14:31 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 95 ±
Замечаний: 0% ±

Excel 2016
SergeySE, добрый день,
формула массива, вводится нажатием CTRL-SHIFT-ENTER
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ(ЕСЛИ($A$2:$A$18=D2;$B$2:$B$18;0);{1:2:3}))
 
Ответить
СообщениеSergeySE, добрый день,
формула массива, вводится нажатием CTRL-SHIFT-ENTER
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ(ЕСЛИ($A$2:$A$18=D2;$B$2:$B$18;0);{1:2:3}))

Автор - Kostya_Ye
Дата добавления - 24.12.2020 в 14:31
SergeySE Дата: Четверг, 24.12.2020, 15:49 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

=СУММПРОИЗВ(НАИБОЛЬШИЙ(ЕСЛИ($A$2:$A$18=D2;$B$2:$B$18;0);{1:2:3}))


Спасибо огромное. Получилось. hands А как в эту формулу добавить проверку, что значений должно быть не меньше 3х? А то она считает и "Параметр 4", а не должна, т.к. их всего 2
 
Ответить
Сообщение
=СУММПРОИЗВ(НАИБОЛЬШИЙ(ЕСЛИ($A$2:$A$18=D2;$B$2:$B$18;0);{1:2:3}))


Спасибо огромное. Получилось. hands А как в эту формулу добавить проверку, что значений должно быть не меньше 3х? А то она считает и "Параметр 4", а не должна, т.к. их всего 2

Автор - SergeySE
Дата добавления - 24.12.2020 в 15:49
Kostya_Ye Дата: Четверг, 24.12.2020, 16:24 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 218
Репутация: 95 ±
Замечаний: 0% ±

Excel 2016
SergeySE,
делал по вашему примеру в файле.
новая формула, если правильно понял.
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ((СЧЁТЕСЛИ($A$2:$A$19;D2)>2)*ЕСЛИ($A$2:$A$19=D2;$B$2:$B$19;0);{1:2:3}))

 
Ответить
СообщениеSergeySE,
делал по вашему примеру в файле.
новая формула, если правильно понял.
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ((СЧЁТЕСЛИ($A$2:$A$19;D2)>2)*ЕСЛИ($A$2:$A$19=D2;$B$2:$B$19;0);{1:2:3}))


Автор - Kostya_Ye
Дата добавления - 24.12.2020 в 16:24
SergeySE Дата: Четверг, 24.12.2020, 20:18 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Спасибо
 
Ответить
СообщениеСпасибо

Автор - SergeySE
Дата добавления - 24.12.2020 в 20:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Просуммировать несколько значений в B, в зависимости от А (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!