Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить совпадения в столбце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить совпадения в столбце (Формулы/Formulas)
Определить совпадения в столбце
Chelovekov Дата: Суббота, 26.12.2020, 05:49 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 192
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте, Гуры Екселя. Прошу, Вас помочь, решить следующую задачу. Есть некий столбец, с некой последовательностью данных. Нужно узнать
1. Какие были серии и сколько раз.
2.Определить, были ли совпадения, что после прерывания определенной серии ,она повторялась.
То есть, если была серия WWW потом прервалась и опять была серия WWW.
Пример прилагаю.
Заранее благодарю.
К сообщению приложен файл: 1905315.xlsx(9.0 Kb)
 
Ответить
СообщениеЗдравствуйте, Гуры Екселя. Прошу, Вас помочь, решить следующую задачу. Есть некий столбец, с некой последовательностью данных. Нужно узнать
1. Какие были серии и сколько раз.
2.Определить, были ли совпадения, что после прерывания определенной серии ,она повторялась.
То есть, если была серия WWW потом прервалась и опять была серия WWW.
Пример прилагаю.
Заранее благодарю.

Автор - Chelovekov
Дата добавления - 26.12.2020 в 05:49
Pelena Дата: Суббота, 26.12.2020, 09:49 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17242
Репутация: 3767 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
по сериям формула массива
Код
=СУММ(--(ЧАСТОТА(СТРОКА($A$2:$A$22);ЕСЛИ($A$2:$A$22<>E$4;СТРОКА($A$2:$A$22)))-1=$D5))

по прерываниям не уверена, т.к. не совпало с Вашими результатами
К сообщению приложен файл: 8335287.xlsx(9.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
по сериям формула массива
Код
=СУММ(--(ЧАСТОТА(СТРОКА($A$2:$A$22);ЕСЛИ($A$2:$A$22<>E$4;СТРОКА($A$2:$A$22)))-1=$D5))

по прерываниям не уверена, т.к. не совпало с Вашими результатами

Автор - Pelena
Дата добавления - 26.12.2020 в 09:49
Chelovekov Дата: Суббота, 26.12.2020, 13:40 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 192
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Огромное спасибо, первая часть задания выполнена.
Вторая часть, нет. Смотрите. допустим если была серия. WWLXWWXX, значит "Да" условия выполнено, потому что серия после прерывания повторилась именно WW. а не WWW. А вот допустим серия WWWLWWL, то "Нет", потому что условие не выполнено, так как за серией WWW после прерывания была серия WW. Надеюсь так понятно. Конечно не знаю можно ли это определить при помощи формул.
Спасибо.
 
Ответить
СообщениеОгромное спасибо, первая часть задания выполнена.
Вторая часть, нет. Смотрите. допустим если была серия. WWLXWWXX, значит "Да" условия выполнено, потому что серия после прерывания повторилась именно WW. а не WWW. А вот допустим серия WWWLWWL, то "Нет", потому что условие не выполнено, так как за серией WWW после прерывания была серия WW. Надеюсь так понятно. Конечно не знаю можно ли это определить при помощи формул.
Спасибо.

Автор - Chelovekov
Дата добавления - 26.12.2020 в 13:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить совпадения в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!