Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Результат по нескольким критериям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Результат по нескольким критериям (Формулы/Formulas)
Результат по нескольким критериям
Fokey Дата: Суббота, 26.12.2020, 18:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер!
Прошу знатоков помочь.
--------------
Нужна формула, которая автоматически, в зависимости от основного критерия (группа), производит легкие математические расчеты и выделяет процент на основании выборки сумм определенных данных из массива по другим нескольким критериям группы (купля/продажа).

Думал использовать что-то из разряда ВПР, ИНДЕКС, ПОИСКПОЗ, но закипела голова на составлении формулы при наличии нескольких критериев.

Прикрепил файл, в котором конкретно расписал словами формулу, какую выборку необходимо получить и посчитать.
Дополнительно прикрепляю в спойлере схему формулы (залил на радикал), чтобы сориентироваться без скачивания файла.

Благодарю!
К сообщению приложен файл: 1395181.xls(34.0 Kb)
 
Ответить
СообщениеДобрый вечер!
Прошу знатоков помочь.
--------------
Нужна формула, которая автоматически, в зависимости от основного критерия (группа), производит легкие математические расчеты и выделяет процент на основании выборки сумм определенных данных из массива по другим нескольким критериям группы (купля/продажа).

Думал использовать что-то из разряда ВПР, ИНДЕКС, ПОИСКПОЗ, но закипела голова на составлении формулы при наличии нескольких критериев.

Прикрепил файл, в котором конкретно расписал словами формулу, какую выборку необходимо получить и посчитать.
Дополнительно прикрепляю в спойлере схему формулы (залил на радикал), чтобы сориентироваться без скачивания файла.

Благодарю!

Автор - Fokey
Дата добавления - 26.12.2020 в 18:37
Che79 Дата: Суббота, 26.12.2020, 19:20 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1648
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Добрый вечер!
Впишите нужные результаты вручную в файле в выделенные синим ячейки. Есть вариант, но не уверен, что правильно понял задачу


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Суббота, 26.12.2020, 19:20
 
Ответить
СообщениеДобрый вечер!
Впишите нужные результаты вручную в файле в выделенные синим ячейки. Есть вариант, но не уверен, что правильно понял задачу

Автор - Che79
Дата добавления - 26.12.2020 в 19:20
Fokey Дата: Суббота, 26.12.2020, 19:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Che79, прикрепляю файл с ручным расчетом.

Т.е. необходимо избавиться от постоянного ввода вручную данной формулы, чтобы происходил расчет просто на основании группы и к ней относящихся колонок продажа/купля
К сообщению приложен файл: 7876583.xls(34.0 Kb)


Сообщение отредактировал Fokey - Суббота, 26.12.2020, 20:04
 
Ответить
СообщениеChe79, прикрепляю файл с ручным расчетом.

Т.е. необходимо избавиться от постоянного ввода вручную данной формулы, чтобы происходил расчет просто на основании группы и к ней относящихся колонок продажа/купля

Автор - Fokey
Дата добавления - 26.12.2020 в 19:58
Che79 Дата: Суббота, 26.12.2020, 22:48 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1648
Репутация: 306 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Fokey, посмотрите, как вариант, формулы в зеленых ячейках.
Для руб.
Код
=СУММПРОИЗВ((K3:K11*(G3:G11="Продажа")-K3:K11*(G3:G11="Купля"))*(U3:U11=1))
Для % эта формула делится на кусок, связанный с Куплей по группе операций 1
К сообщению приложен файл: 7876583-1.xls(34.5 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеFokey, посмотрите, как вариант, формулы в зеленых ячейках.
Для руб.
Код
=СУММПРОИЗВ((K3:K11*(G3:G11="Продажа")-K3:K11*(G3:G11="Купля"))*(U3:U11=1))
Для % эта формула делится на кусок, связанный с Куплей по группе операций 1

Автор - Che79
Дата добавления - 26.12.2020 в 22:48
gling Дата: Воскресенье, 27.12.2020, 00:23 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2230
Репутация: 556 ±
Замечаний: 0% ±

2010
Еще вариант.
Код
=СУММЕСЛИМН($K$1:$K$14;$G$1:$G$14;"Продажа";$U$1:$U$14;B22)-СУММЕСЛИМН($K$1:$K$14;$G$1:$G$14;"Купля";$U$1:$U$14;B22)-СУММЕСЛИ($U$1:$U$14;B22;$Q$1:$Q$14)-СУММЕСЛИ($U$1:$U$14;B22;$O$1:$O$14)
Код

=D25/СУММЕСЛИМН($K$1:$K$14;$G$1:$G$14;"Купля";$U$1:$U$14;B25)*100
К сообщению приложен файл: 8219279.xls(35.0 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЕще вариант.
Код
=СУММЕСЛИМН($K$1:$K$14;$G$1:$G$14;"Продажа";$U$1:$U$14;B22)-СУММЕСЛИМН($K$1:$K$14;$G$1:$G$14;"Купля";$U$1:$U$14;B22)-СУММЕСЛИ($U$1:$U$14;B22;$Q$1:$Q$14)-СУММЕСЛИ($U$1:$U$14;B22;$O$1:$O$14)
Код

=D25/СУММЕСЛИМН($K$1:$K$14;$G$1:$G$14;"Купля";$U$1:$U$14;B25)*100

Автор - gling
Дата добавления - 27.12.2020 в 00:23
Fokey Дата: Воскресенье, 27.12.2020, 02:00 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Che79, gling, признателен! Оба способа рабочие. hands
 
Ответить
СообщениеChe79, gling, признателен! Оба способа рабочие. hands

Автор - Fokey
Дата добавления - 27.12.2020 в 02:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Результат по нескольким критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!