Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод значения из A по B на другой лист - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значения из A по B на другой лист (Формулы/Formulas)
Вывод значения из A по B на другой лист
SergeySE Дата: Понедельник, 04.01.2021, 13:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.

Есть файлик.
'Лист 1':
1 В
2 Б
3 А
4
..

Надо вывести на 'Лист 2' по значению из столбца "B" значения из столбца "A" из 'Лист 1'. Без лишнего столбца (иначе бы подошла формула с ВПР). Пустота должна игнорироваться.
А 3
Б 2
В 1

Работает такая формула:
Код
{=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$1:$A$10;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$B$1:$B$10=A1;СТРОКА($A$1:$A$10);"");СЧЁТЕСЛИ($A$1:A1;A1)));"")}


Можно придумать что-то попроще? Спасибо.
К сообщению приложен файл: 0492779.xlsx(11.2 Kb)


Сообщение отредактировал SergeySE - Понедельник, 04.01.2021, 13:32
 
Ответить
СообщениеДобрый день.

Есть файлик.
'Лист 1':
1 В
2 Б
3 А
4
..

Надо вывести на 'Лист 2' по значению из столбца "B" значения из столбца "A" из 'Лист 1'. Без лишнего столбца (иначе бы подошла формула с ВПР). Пустота должна игнорироваться.
А 3
Б 2
В 1

Работает такая формула:
Код
{=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$1:$A$10;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$B$1:$B$10=A1;СТРОКА($A$1:$A$10);"");СЧЁТЕСЛИ($A$1:A1;A1)));"")}


Можно придумать что-то попроще? Спасибо.

Автор - SergeySE
Дата добавления - 04.01.2021 в 13:01
Pelena Дата: Понедельник, 04.01.2021, 13:27 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17511
Репутация: 3890 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Не понятно, что именно надо суммировать?
И оформите формулу тегами с помощью кнопки fx в режиме правки поста


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНе понятно, что именно надо суммировать?
И оформите формулу тегами с помощью кнопки fx в режиме правки поста

Автор - Pelena
Дата добавления - 04.01.2021 в 13:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значения из A по B на другой лист (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!