Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет с несколькими условиями - Страница 2 - Мир MS Excel

Старая форма входа
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет с несколькими условиями (Формулы/Formulas)
Расчет с несколькими условиями
DOOM-NEW Дата: Среда, 06.01.2021, 17:40 | Сообщение № 21
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер! С Вашей помощью постепенно моя работа движется к завершению. Прошу помочь еще в двух ситуациях.
Сейчас на базе моего примера имеется три таблицы - визуально они одинаковые, но таблица 1 суммирует данные из таблицы 2 и 3.
Мне нужно, чтобы в столбцах С и D первой таблицы сумма пустых ячеек отображалась также как пустая ячейка, а не ноль. Экспериментировала с функциями СЧЕТЕСЛИ и СУММЕСЛИ, но не получилось...
К сообщению приложен файл: GDR6.xls(34.5 Kb)
 
Ответить
СообщениеДобрый вечер! С Вашей помощью постепенно моя работа движется к завершению. Прошу помочь еще в двух ситуациях.
Сейчас на базе моего примера имеется три таблицы - визуально они одинаковые, но таблица 1 суммирует данные из таблицы 2 и 3.
Мне нужно, чтобы в столбцах С и D первой таблицы сумма пустых ячеек отображалась также как пустая ячейка, а не ноль. Экспериментировала с функциями СЧЕТЕСЛИ и СУММЕСЛИ, но не получилось...

Автор - DOOM-NEW
Дата добавления - 06.01.2021 в 17:40
MikeVol Дата: Среда, 06.01.2021, 18:45 | Сообщение № 22
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 164
Репутация: 16 ±
Замечаний: 0% ±

Excel 2019
DOOM-NEW, Доброго времени суток. Как вариант Выделите ячейки, содержащие нулевые значения (0), которые требуется скрыть, Формат > Формат ячеек, В поле Тип введите выражение 0;-0;;@ и нажмите кнопку ОК.
Взято вот отсюда: Как скрыть нулевые значения


Ученик - Наблюдатель. Учиться Никогда не поздно.
 
Ответить
СообщениеDOOM-NEW, Доброго времени суток. Как вариант Выделите ячейки, содержащие нулевые значения (0), которые требуется скрыть, Формат > Формат ячеек, В поле Тип введите выражение 0;-0;;@ и нажмите кнопку ОК.
Взято вот отсюда: Как скрыть нулевые значения

Автор - MikeVol
Дата добавления - 06.01.2021 в 18:45
DOOM-NEW Дата: Среда, 06.01.2021, 20:50 | Сообщение № 23
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

DOOM-NEW, Доброго времени суток. Как вариант Выделите ячейки, содержащие нулевые значения (0), которые требуется скрыть, Формат > Формат ячеек, В поле Тип введите выражение 0;-0;;@ и нажмите кнопку ОК.
Взято вот отсюда: Как скрыть нулевые значения


Мне кажется предложенный Вами вариант не подходит или я не так поняла материал, изложенный по ссылке
 
Ответить
Сообщение
DOOM-NEW, Доброго времени суток. Как вариант Выделите ячейки, содержащие нулевые значения (0), которые требуется скрыть, Формат > Формат ячеек, В поле Тип введите выражение 0;-0;;@ и нажмите кнопку ОК.
Взято вот отсюда: Как скрыть нулевые значения


Мне кажется предложенный Вами вариант не подходит или я не так поняла материал, изложенный по ссылке

Автор - DOOM-NEW
Дата добавления - 06.01.2021 в 20:50
Pelena Дата: Среда, 06.01.2021, 21:01 | Сообщение № 24
Группа: Админы
Ранг: Местный житель
Сообщений: 18561
Репутация: 4204 ±
Замечаний: ±

Excel 2016 & Mac Excel
вариант не подходит
абсолютно подходит

Причём, Вам уже второй раз пытаются предложить использовать Пользовательский формат для скрытия нулей, а Вы упорно сопротивляетесь :D
Возможно, статья Пользовательский формат Вам поможет разобраться


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
вариант не подходит
абсолютно подходит

Причём, Вам уже второй раз пытаются предложить использовать Пользовательский формат для скрытия нулей, а Вы упорно сопротивляетесь :D
Возможно, статья Пользовательский формат Вам поможет разобраться

Автор - Pelena
Дата добавления - 06.01.2021 в 21:01
Kostya_Ye Дата: Среда, 06.01.2021, 21:12 | Сообщение № 25
Группа: Проверенные
Ранг: Обитатель
Сообщений: 271
Репутация: 228 ±
Замечаний: 0% ±

Excel 2016
DOOM-NEW,
ну можно и формулой задачу решить.
Код
=ЕСЛИ(D21+D36;D21+D36;"")
, только придется и дальше по цепочке формулу править
Код
=ЕСЛИ(C5=Ч(D5);"";ЕСЛИ(C5=0;1;(Ч(D5)-C5)*100/C5))
 
Ответить
СообщениеDOOM-NEW,
ну можно и формулой задачу решить.
Код
=ЕСЛИ(D21+D36;D21+D36;"")
, только придется и дальше по цепочке формулу править
Код
=ЕСЛИ(C5=Ч(D5);"";ЕСЛИ(C5=0;1;(Ч(D5)-C5)*100/C5))

Автор - Kostya_Ye
Дата добавления - 06.01.2021 в 21:12
MikeVol Дата: Четверг, 07.01.2021, 00:48 | Сообщение № 26
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 164
Репутация: 16 ±
Замечаний: 0% ±

Excel 2019
DOOM-NEW,
Мне кажется предложенный Вами вариант не подходит

Ну хозяин Барин, ну нет так нет.


Ученик - Наблюдатель. Учиться Никогда не поздно.
 
Ответить
СообщениеDOOM-NEW,
Мне кажется предложенный Вами вариант не подходит

Ну хозяин Барин, ну нет так нет.

Автор - MikeVol
Дата добавления - 07.01.2021 в 00:48
DOOM-NEW Дата: Четверг, 07.01.2021, 10:43 | Сообщение № 27
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Ну хозяин Барин, ну нет так нет.


не обижайтесь пожалуйста. ну ни как я не могу разобраться с "пользовательским форматом". ранее самостоятельно пыталась с его помощью решить проблему отображения в ячейках 17-ти значных чисел...
 
Ответить
Сообщение
Ну хозяин Барин, ну нет так нет.


не обижайтесь пожалуйста. ну ни как я не могу разобраться с "пользовательским форматом". ранее самостоятельно пыталась с его помощью решить проблему отображения в ячейках 17-ти значных чисел...

Автор - DOOM-NEW
Дата добавления - 07.01.2021 в 10:43
DOOM-NEW Дата: Четверг, 07.01.2021, 10:56 | Сообщение № 28
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

, только придется и дальше по цепочке формулу править

=ЕСЛИ(C5=Ч(D5);"";ЕСЛИ(C5=0;100;(Ч(D5)-C5)*100/C5))


тестирую, но так как я поменяла формат с процентного на числовой, то заменила ЕСЛИ(C5=0;1 на ЕСЛИ(C5=0;100


Сообщение отредактировал DOOM-NEW - Четверг, 07.01.2021, 11:50
 
Ответить
Сообщение
, только придется и дальше по цепочке формулу править

=ЕСЛИ(C5=Ч(D5);"";ЕСЛИ(C5=0;100;(Ч(D5)-C5)*100/C5))


тестирую, но так как я поменяла формат с процентного на числовой, то заменила ЕСЛИ(C5=0;1 на ЕСЛИ(C5=0;100

Автор - DOOM-NEW
Дата добавления - 07.01.2021 в 10:56
Kostya_Ye Дата: Четверг, 07.01.2021, 11:41 | Сообщение № 29
Группа: Проверенные
Ранг: Обитатель
Сообщений: 271
Репутация: 228 ±
Замечаний: 0% ±

Excel 2016
DOOM-NEW, добрый день.
значение "Ч" в данной формуле
переводит пустую строку в число.
 
Ответить
СообщениеDOOM-NEW, добрый день.
значение "Ч" в данной формуле
переводит пустую строку в число.

Автор - Kostya_Ye
Дата добавления - 07.01.2021 в 11:41
DOOM-NEW Дата: Четверг, 07.01.2021, 11:51 | Сообщение № 30
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

спасибо
 
Ответить
Сообщениеспасибо

Автор - DOOM-NEW
Дата добавления - 07.01.2021 в 11:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет с несколькими условиями (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!