Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка на числовое значение - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка на числовое значение (Формулы/Formulas)
Проверка на числовое значение
SergeySE Дата: Четверг, 28.01.2021, 10:56 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.

Нужно вывести на Лист2 с Лист1 значение столбца B, если в столбце A число больше 0.
Помогите, пожалуйста добавить проверку в эту формулу:
Код
=НАИМЕНЬШИЙ((ЕСЛИ(Лист1!$A$1:$A$10>0;Лист1!$B$1:$B$10;""));{6})


Вот такой вариант не работает:
Код
=НАИМЕНЬШИЙ((ЕСЛИ(ЕЧИСЛО(Лист1!$A$1:$A$10)>0;Лист1!$B$1:$B$10;""));{6})


В файлике с примером это первые 5 значений и 3 нерабочих варианта формулы.
К сообщению приложен файл: 100.xlsx(12.1 Kb)
 
Ответить
СообщениеДобрый день.

Нужно вывести на Лист2 с Лист1 значение столбца B, если в столбце A число больше 0.
Помогите, пожалуйста добавить проверку в эту формулу:
Код
=НАИМЕНЬШИЙ((ЕСЛИ(Лист1!$A$1:$A$10>0;Лист1!$B$1:$B$10;""));{6})


Вот такой вариант не работает:
Код
=НАИМЕНЬШИЙ((ЕСЛИ(ЕЧИСЛО(Лист1!$A$1:$A$10)>0;Лист1!$B$1:$B$10;""));{6})


В файлике с примером это первые 5 значений и 3 нерабочих варианта формулы.

Автор - SergeySE
Дата добавления - 28.01.2021 в 10:56
Nic70y Дата: Четверг, 28.01.2021, 11:04 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6761
Репутация: 1561 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(--Лист1!$A$1:$A$10>0;);Лист1!$B$1:$B$10);СТРОКА(A1));"")
массива конечно


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(--Лист1!$A$1:$A$10>0;);Лист1!$B$1:$B$10);СТРОКА(A1));"")
массива конечно

Автор - Nic70y
Дата добавления - 28.01.2021 в 11:04
Serge_007 Дата: Четверг, 28.01.2021, 11:07 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13730
Репутация: 2304 ±
Замечаний: ±

Excel 2010
Здравствуйте

добавить проверку в эту формулу:
Код
=НАИМЕНЬШИЙ((ЕСЛИ(Лист1!$A$1:$A$10>0;Лист1!$B$1:$B$10;""));{6})
Проверку на что?

Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(Лист1!A$1:A$10>0;Лист1!B$1:B$10);СТРОКА());"")


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

добавить проверку в эту формулу:
Код
=НАИМЕНЬШИЙ((ЕСЛИ(Лист1!$A$1:$A$10>0;Лист1!$B$1:$B$10;""));{6})
Проверку на что?

Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(Лист1!A$1:A$10>0;Лист1!B$1:B$10);СТРОКА());"")

Автор - Serge_007
Дата добавления - 28.01.2021 в 11:07
SergeySE Дата: Четверг, 28.01.2021, 12:03 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Проверку на что?

Что столбец А на Листе1 содержит число больше нуля и только тогда вывод значения. В файле примера в А6 буквы ААА. Значение B6 должно игнорироваться.

Вот так понятнее?

Лист 1:
А1:А100 Числа, буквы, пусто
В1:В100 Числа, пусто

На лист 2:
необходимо вывести все числовые значения листа 1 из В, если в смежной ячейке А число

*числа целые положительные


Сообщение отредактировал SergeySE - Четверг, 28.01.2021, 12:56
 
Ответить
Сообщение
Проверку на что?

Что столбец А на Листе1 содержит число больше нуля и только тогда вывод значения. В файле примера в А6 буквы ААА. Значение B6 должно игнорироваться.

Вот так понятнее?

Лист 1:
А1:А100 Числа, буквы, пусто
В1:В100 Числа, пусто

На лист 2:
необходимо вывести все числовые значения листа 1 из В, если в смежной ячейке А число

*числа целые положительные

Автор - SergeySE
Дата добавления - 28.01.2021 в 12:03
Serge_007 Дата: Четверг, 28.01.2021, 13:08 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13730
Репутация: 2304 ±
Замечаний: ±

Excel 2010
столбец А на Листе1 содержит число больше нуля ... в А6 буквы ААА. Значение B6 должно игнорироваться
Текстовое значение в Excel всегда больше числового, так что Вы неправильно условие ">" задаете. Тут 2 проверки нужны:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((Лист1!A$1:A$10>0)*ЕЧИСЛО(Лист1!A$1:A$10);Лист1!B$1:B$10);СТРОКА());"")


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
столбец А на Листе1 содержит число больше нуля ... в А6 буквы ААА. Значение B6 должно игнорироваться
Текстовое значение в Excel всегда больше числового, так что Вы неправильно условие ">" задаете. Тут 2 проверки нужны:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((Лист1!A$1:A$10>0)*ЕЧИСЛО(Лист1!A$1:A$10);Лист1!B$1:B$10);СТРОКА());"")

Автор - Serge_007
Дата добавления - 28.01.2021 в 13:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка на числовое значение (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!