Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти в массиве все позиции и перемножить - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в массиве все позиции и перемножить (Формулы/Formulas)
Найти в массиве все позиции и перемножить
negodyaj Дата: Четверг, 04.02.2021, 14:47 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет!
Помогите, пожалуйста, решить такую задачку:

Нужно найти везде где есть "Резерв 1" из влкадки состав перемножить с тем сколько ср.в день и суммировать. Тем самым получив расход этой комплектающей по всем товарам. Т.е. в данном случае Состав!C2*Состав!B2+Состав!D2*Состав!B2+Состав!C3*Состав!B3 . 2 раза по 3 и 1 раз по 4, итого должно быть число 10, и т д
К сообщению приложен файл: 7729387.xlsx(11.2 Kb)
 
Ответить
СообщениеВсем привет!
Помогите, пожалуйста, решить такую задачку:

Нужно найти везде где есть "Резерв 1" из влкадки состав перемножить с тем сколько ср.в день и суммировать. Тем самым получив расход этой комплектающей по всем товарам. Т.е. в данном случае Состав!C2*Состав!B2+Состав!D2*Состав!B2+Состав!C3*Состав!B3 . 2 раза по 3 и 1 раз по 4, итого должно быть число 10, и т д

Автор - negodyaj
Дата добавления - 04.02.2021 в 14:47
Pelena Дата: Четверг, 04.02.2021, 14:51 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17631
Репутация: 3926 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ((Состав!$C$2:$E$4=$A2)*Состав!$B$2:$B$4)
К сообщению приложен файл: 3128180.xlsx(11.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ((Состав!$C$2:$E$4=$A2)*Состав!$B$2:$B$4)

Автор - Pelena
Дата добавления - 04.02.2021 в 14:51
negodyaj Дата: Четверг, 04.02.2021, 15:03 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Гениально!
 
Ответить
СообщениеГениально!

Автор - negodyaj
Дата добавления - 04.02.2021 в 15:03
negodyaj Дата: Четверг, 04.02.2021, 15:59 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А как можно посчитать в сколких строках есть данная комплектующая?
т.е. если в стрчоке есть хотя бы 1 упоминание, общая сумма сколько встречается не нужно
 
Ответить
СообщениеА как можно посчитать в сколких строках есть данная комплектующая?
т.е. если в стрчоке есть хотя бы 1 упоминание, общая сумма сколько встречается не нужно

Автор - negodyaj
Дата добавления - 04.02.2021 в 15:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в массиве все позиции и перемножить (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!