Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать сколько раз повторяется в строках - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сколько раз повторяется в строках (Формулы/Formulas)
Посчитать сколько раз повторяется в строках
negodyaj Дата: Четверг, 04.02.2021, 17:13 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Как найти из массива в скольких строках встречается данная позиция если может быть в разных столбцах.
Т.е. Впримере она 2 раза в 1 строке и 1 раз во второй, а вывести число нужно 2. 2 строки.
К сообщению приложен файл: 8830946.xlsx(11.1 Kb)
 
Ответить
СообщениеКак найти из массива в скольких строках встречается данная позиция если может быть в разных столбцах.
Т.е. Впримере она 2 раза в 1 строке и 1 раз во второй, а вывести число нужно 2. 2 строки.

Автор - negodyaj
Дата добавления - 04.02.2021 в 17:13
Светлый Дата: Четверг, 04.02.2021, 20:58 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1522
Репутация: 398 ±
Замечаний: 0% ±

Excel 2010, 2013
И Вам, здравствуйте!
Формула массива:
Код
=СУММ(Ч(МУМНОЖ(Ч(A2=Состав!A$2:L$30);ТРАНСП(СТОЛБЕЦ(A:L)))>0))
*Название лучше исправить: В скольки строках встречается значение.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Четверг, 04.02.2021, 21:12
 
Ответить
СообщениеИ Вам, здравствуйте!
Формула массива:
Код
=СУММ(Ч(МУМНОЖ(Ч(A2=Состав!A$2:L$30);ТРАНСП(СТОЛБЕЦ(A:L)))>0))
*Название лучше исправить: В скольки строках встречается значение.

Автор - Светлый
Дата добавления - 04.02.2021 в 20:58
Serge_007 Дата: Пятница, 05.02.2021, 09:27 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13708
Репутация: 2301 ±
Замечаний: ±

Excel 2010
Сергей, а зачем транспонировать массив, если можно "в лоб"?
Код
=СУММПРОИЗВ(Ч(МУМНОЖ(Ч(A2=Состав!A$2:L$30);СТРОКА($1:$12))>0))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеСергей, а зачем транспонировать массив, если можно "в лоб"?
Код
=СУММПРОИЗВ(Ч(МУМНОЖ(Ч(A2=Состав!A$2:L$30);СТРОКА($1:$12))>0))

Автор - Serge_007
Дата добавления - 05.02.2021 в 09:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сколько раз повторяется в строках (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!