Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение значений ячеек и столбцов. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение значений ячеек и столбцов. (Нужно упростить формулу в ячейке C3)
Сравнение значений ячеек и столбцов.
d543500-570 Дата: Пятница, 05.02.2021, 11:45 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Прошу помощи в решении. Нужно упростить формулу в ячейке C3 , которая проверяет находится ли C1 между диапазонами A3:A536 и B3:B536. При протяжке вправо проверяется D1 и т.д.
К сообщению приложен файл: 7353638.xlsx(29.9 Kb)
 
Ответить
СообщениеПрошу помощи в решении. Нужно упростить формулу в ячейке C3 , которая проверяет находится ли C1 между диапазонами A3:A536 и B3:B536. При протяжке вправо проверяется D1 и т.д.

Автор - d543500-570
Дата добавления - 05.02.2021 в 11:45
Serge_007 Дата: Пятница, 05.02.2021, 12:38 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13723
Репутация: 2302 ±
Замечаний: ±

Excel 2010
Здравствуйте

Там особо нечего упрощать...
Код
=СУММ((C$1>=$A$3:$A$28)*(C$1<$B$3:$B$28))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Там особо нечего упрощать...
Код
=СУММ((C$1>=$A$3:$A$28)*(C$1<$B$3:$B$28))

Автор - Serge_007
Дата добавления - 05.02.2021 в 12:38
d543500-570 Дата: Пятница, 05.02.2021, 21:12 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Хотелось бы,чтоб вся формула умещалась в одной строке номер 3. В данном примере чтоб единички были в строке 3 и не тянуть все это вниз.
 
Ответить
СообщениеХотелось бы,чтоб вся формула умещалась в одной строке номер 3. В данном примере чтоб единички были в строке 3 и не тянуть все это вниз.

Автор - d543500-570
Дата добавления - 05.02.2021 в 21:12
Pelena Дата: Пятница, 05.02.2021, 21:21 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17258
Репутация: 3809 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вышеприведенная формула так и работает, только надо ввести как формулу массива Ctrl+Shift+Enter

Варианты
Код
=СУММПРОИЗВ((C$1>=$A$3:$A$28)*(C$1<$B$3:$B$28))

Код
=СЧЁТЕСЛИМН($A$3:$A$28;"<="&C$1;$B$3:$B$28;">"&C$1)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВышеприведенная формула так и работает, только надо ввести как формулу массива Ctrl+Shift+Enter

Варианты
Код
=СУММПРОИЗВ((C$1>=$A$3:$A$28)*(C$1<$B$3:$B$28))

Код
=СЧЁТЕСЛИМН($A$3:$A$28;"<="&C$1;$B$3:$B$28;">"&C$1)

Автор - Pelena
Дата добавления - 05.02.2021 в 21:21
d543500-570 Дата: Суббота, 06.02.2021, 08:32 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Большое спасибо. Открыли глаза. По крайней мере один глаз.
 
Ответить
СообщениеБольшое спасибо. Открыли глаза. По крайней мере один глаз.

Автор - d543500-570
Дата добавления - 06.02.2021 в 08:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение значений ячеек и столбцов. (Нужно упростить формулу в ячейке C3)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!