Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск и перенос данных когда значении одинаковые - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск и перенос данных когда значении одинаковые (Формулы/Formulas)
поиск и перенос данных когда значении одинаковые
nikaluka1 Дата: Суббота, 06.02.2021, 12:20 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 67
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
Добрый день!
Есть такое задача : надо найти в указанном столбце дату и переносит данные строки в другом листе, ВПР (VLOOKUP) не пригоден: много одинаковые значений
Как сделать, чтобы из листа 1 переносит в лист 2 данные конкретного даты
К сообщению приложен файл: 22.xlsx(11.6 Kb)
 
Ответить
СообщениеДобрый день!
Есть такое задача : надо найти в указанном столбце дату и переносит данные строки в другом листе, ВПР (VLOOKUP) не пригоден: много одинаковые значений
Как сделать, чтобы из листа 1 переносит в лист 2 данные конкретного даты

Автор - nikaluka1
Дата добавления - 06.02.2021 в 12:20
Nic70y Дата: Суббота, 06.02.2021, 12:27 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6751
Репутация: 1543 ±
Замечаний: 0% ±

Excel 2010
столбец эй
Код
=ЕСЛИ(ИНДЕКС('1'!A:A;ПОИСКПОЗ(P$1;'1'!A:A;)+СТРОКА(A1)-1)=P$1;P$1;"")
столбцы начиная с би
Код
=ЕСЛИ($A2="";"";ИНДЕКС('1'!B:B;ПОИСКПОЗ($A2;'1'!$A:$A;)+СТРОКА(B1)-1))
К сообщению приложен файл: 99.xlsx(13.1 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениестолбец эй
Код
=ЕСЛИ(ИНДЕКС('1'!A:A;ПОИСКПОЗ(P$1;'1'!A:A;)+СТРОКА(A1)-1)=P$1;P$1;"")
столбцы начиная с би
Код
=ЕСЛИ($A2="";"";ИНДЕКС('1'!B:B;ПОИСКПОЗ($A2;'1'!$A:$A;)+СТРОКА(B1)-1))

Автор - Nic70y
Дата добавления - 06.02.2021 в 12:27
Egyptian Дата: Суббота, 06.02.2021, 13:15 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 70
Репутация: 37 ±
Замечаний: 0% ±

Excel 2013/2016
Еще вариант.
Код
=IFERROR(INDEX('1'!A$1:A$200,AGGREGATE(15,6,ROW($A$1:$A$200)/('1'!$A$1:$A$200=$P$1),ROW(A1))),"")
К сообщению приложен файл: 2920737.xlsx(12.8 Kb)
 
Ответить
СообщениеЕще вариант.
Код
=IFERROR(INDEX('1'!A$1:A$200,AGGREGATE(15,6,ROW($A$1:$A$200)/('1'!$A$1:$A$200=$P$1),ROW(A1))),"")

Автор - Egyptian
Дата добавления - 06.02.2021 в 13:15
nikaluka1 Дата: Суббота, 06.02.2021, 13:56 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 67
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007, 2010
Большое спасибо, оба вариант хороший !!!
 
Ответить
СообщениеБольшое спасибо, оба вариант хороший !!!

Автор - nikaluka1
Дата добавления - 06.02.2021 в 13:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск и перенос данных когда значении одинаковые (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!