Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если в строке таблицы одни 0 , поиск строчки со значениями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в строке таблицы одни 0 , поиск строчки со значениями (Формулы/Formulas)
Если в строке таблицы одни 0 , поиск строчки со значениями
Predator92 Дата: Понедельник, 08.02.2021, 23:15 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Добрый вечер! Помогите кто нибудь решить данную задачу!

Даны 22 таблицы по горизонтали, каждые данные у каждой таблицы свои, данные постоянно самостоятельно меняются,

в строчках таблиц образуется нули , нужно чтобы строчки с нулями пропускались и данные записывались по очередности в таблицу ниже

Пример прилагается как в итоге должны выглядеть таблицы

Прошу помочь и решив данную задачу как можно проще , чтобы я смог Ctrl+C , Ctrl+V , сделать остальные таблицы сам!

Спасибо за понимание!
К сообщению приложен файл: 202222222222221.xlsx(224.5 Kb)


Сообщение отредактировал Predator92 - Понедельник, 08.02.2021, 23:20
 
Ответить
СообщениеДобрый вечер! Помогите кто нибудь решить данную задачу!

Даны 22 таблицы по горизонтали, каждые данные у каждой таблицы свои, данные постоянно самостоятельно меняются,

в строчках таблиц образуется нули , нужно чтобы строчки с нулями пропускались и данные записывались по очередности в таблицу ниже

Пример прилагается как в итоге должны выглядеть таблицы

Прошу помочь и решив данную задачу как можно проще , чтобы я смог Ctrl+C , Ctrl+V , сделать остальные таблицы сам!

Спасибо за понимание!

Автор - Predator92
Дата добавления - 08.02.2021 в 23:15
Egyptian Дата: Вторник, 09.02.2021, 00:26 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 72
Репутация: 37 ±
Замечаний: 0% ±

Excel 2013/2016
Predator92, Смотрите, мое решение практически не отличается от предложенного Вам в прежней теме.
Вставляете, тянете вправо и вниз. Выбираете заполнять без форматирования или как там в русской версии.
Кроме примера заполнил на Листе1 пару столбцов для наглядности.
Код
=IFERROR(INDEX(D$6:D$65,AGGREGATE(15,6,ROW($A$1:$A$60)/(D$6:D$65<>0),ROWS($A$67:$A67))),"")
К сообщению приложен файл: 7930229.xlsx(254.2 Kb)
 
Ответить
СообщениеPredator92, Смотрите, мое решение практически не отличается от предложенного Вам в прежней теме.
Вставляете, тянете вправо и вниз. Выбираете заполнять без форматирования или как там в русской версии.
Кроме примера заполнил на Листе1 пару столбцов для наглядности.
Код
=IFERROR(INDEX(D$6:D$65,AGGREGATE(15,6,ROW($A$1:$A$60)/(D$6:D$65<>0),ROWS($A$67:$A67))),"")

Автор - Egyptian
Дата добавления - 09.02.2021 в 00:26
Pelena Дата: Вторник, 09.02.2021, 08:58 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 17271
Репутация: 3823 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Predator92, я правильно понимаю, что мы убираем строку, только если она полностью заполнена нулями? Тогда, может, так подойдёт? Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$6:B$65;АГРЕГАТ(15;6;СТРОКА($A$1:$A$65)/(МУМНОЖ(--($B$6:$R$65<>0);ТРАНСП(СТОЛБЕЦ($B$6:$R$65))^0)<>0);ЧСТРОК($A$68:$A68)));"")
К сообщению приложен файл: 4854934.xlsx(235.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеPredator92, я правильно понимаю, что мы убираем строку, только если она полностью заполнена нулями? Тогда, может, так подойдёт? Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(B$6:B$65;АГРЕГАТ(15;6;СТРОКА($A$1:$A$65)/(МУМНОЖ(--($B$6:$R$65<>0);ТРАНСП(СТОЛБЕЦ($B$6:$R$65))^0)<>0);ЧСТРОК($A$68:$A68)));"")

Автор - Pelena
Дата добавления - 09.02.2021 в 08:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в строке таблицы одни 0 , поиск строчки со значениями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!