Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос значений для присутствующего,отсутствующего столбца - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос значений для присутствующего,отсутствующего столбца (Формулы/Formulas)
Перенос значений для присутствующего,отсутствующего столбца
GGR Дата: Среда, 10.02.2021, 10:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день. Прошу помощи, пожалуйста. При переносе значений из одной таблицы в другую (много вкладок) все прекрасно работает, но формула работает некорректно (ссылка не на ту ячейку) , т.е. в свЕ6 нет столбца маски многоразовые. Возможен ли вариант написания универсальной формулы для присутствующего и отсутствующего столбца. (Изменения будут только по маскам многоразовым). Очень надеюсь, что мне мне помогут умные и добрые профессионалы.
К сообщению приложен файл: __.xlsx(23.1 Kb)
 
Ответить
СообщениеДобрый день. Прошу помощи, пожалуйста. При переносе значений из одной таблицы в другую (много вкладок) все прекрасно работает, но формула работает некорректно (ссылка не на ту ячейку) , т.е. в свЕ6 нет столбца маски многоразовые. Возможен ли вариант написания универсальной формулы для присутствующего и отсутствующего столбца. (Изменения будут только по маскам многоразовым). Очень надеюсь, что мне мне помогут умные и добрые профессионалы.

Автор - GGR
Дата добавления - 10.02.2021 в 10:54
Pelena Дата: Среда, 10.02.2021, 12:04 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17242
Репутация: 3767 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
напишите названия столбцов одинаково, тогда можно будет так
Код
=ЕСЛИОШИБКА(ИНДЕКС(свЕ6!$E$5:$G$13;НАИМЕНЬШИЙ(ЕСЛИ($C12=свЕ6!$A$5:$A$13;СТРОКА(свЕ6!$A$5:$A$13)-4);СЧЁТЕСЛИ($C$12:$C12;$C12));ПОИСКПОЗ(J$10;свЕ6!$E$4:$G$4;0));"")

а если порядок строк на обоих листах совпадает, то немного короче
Код
=ЕСЛИОШИБКА(ИНДЕКС(свЕ6!$E5:$G5;ПОИСКПОЗ(N$10;свЕ6!$E$4:$G$4;0));"")

универсальная формула на четыре столбца с учётом деления на 100 для антисептика
Код
=ЕСЛИОШИБКА(ИНДЕКС(свЕ6!$E5:$G5;ПОИСКПОЗ(N$10;свЕ6!$E$4:$G$4;0))/(1+99*ЕЧИСЛО(ПОИСК("антисептик";N$10)));"")
К сообщению приложен файл: -4-.xlsx(26.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
напишите названия столбцов одинаково, тогда можно будет так
Код
=ЕСЛИОШИБКА(ИНДЕКС(свЕ6!$E$5:$G$13;НАИМЕНЬШИЙ(ЕСЛИ($C12=свЕ6!$A$5:$A$13;СТРОКА(свЕ6!$A$5:$A$13)-4);СЧЁТЕСЛИ($C$12:$C12;$C12));ПОИСКПОЗ(J$10;свЕ6!$E$4:$G$4;0));"")

а если порядок строк на обоих листах совпадает, то немного короче
Код
=ЕСЛИОШИБКА(ИНДЕКС(свЕ6!$E5:$G5;ПОИСКПОЗ(N$10;свЕ6!$E$4:$G$4;0));"")

универсальная формула на четыре столбца с учётом деления на 100 для антисептика
Код
=ЕСЛИОШИБКА(ИНДЕКС(свЕ6!$E5:$G5;ПОИСКПОЗ(N$10;свЕ6!$E$4:$G$4;0))/(1+99*ЕЧИСЛО(ПОИСК("антисептик";N$10)));"")

Автор - Pelena
Дата добавления - 10.02.2021 в 12:04
Serge_007 Дата: Среда, 10.02.2021, 12:12 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13709
Репутация: 2301 ±
Замечаний: ±

Excel 2010
Здравствуйте

Формула массива:
Код
=ЕСНД(ИНДЕКС(свЕ6!$E$5:$G$14;ПОИСКПОЗ($D12&$E12;свЕ6!$C$5:$C$13&свЕ6!$D$5:$D$13;);ПОИСКПОЗ(F$10;свЕ6!$E$4:$G$4;));0)


С уважением,
глупый и злой любитель)
К сообщению приложен файл: 20210210_GGR.xls(65.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Формула массива:
Код
=ЕСНД(ИНДЕКС(свЕ6!$E$5:$G$14;ПОИСКПОЗ($D12&$E12;свЕ6!$C$5:$C$13&свЕ6!$D$5:$D$13;);ПОИСКПОЗ(F$10;свЕ6!$E$4:$G$4;));0)


С уважением,
глупый и злой любитель)

Автор - Serge_007
Дата добавления - 10.02.2021 в 12:12
GGR Дата: Среда, 10.02.2021, 12:45 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Pelena, спасибо большое,очень помогли. Первый вариант лучше всех подходит.Вы лучшие!!!
 
Ответить
СообщениеPelena, спасибо большое,очень помогли. Первый вариант лучше всех подходит.Вы лучшие!!!

Автор - GGR
Дата добавления - 10.02.2021 в 12:45
GGR Дата: Среда, 10.02.2021, 12:50 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Serge_007, спасибо за ответ. У меня офис 2007, поэтому формула не работает. Очень жаль.Но я ее в копилку записала.
 
Ответить
СообщениеSerge_007, спасибо за ответ. У меня офис 2007, поэтому формула не работает. Очень жаль.Но я ее в копилку записала.

Автор - GGR
Дата добавления - 10.02.2021 в 12:50
Serge_007 Дата: Среда, 10.02.2021, 13:22 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13709
Репутация: 2301 ±
Замечаний: ±

Excel 2010
У меня офис 2007
Замените ЕСНД() на ЕСЛИОШИБКА() , разницы никакой)

Код
=ЕСЛИОШИБКА(ИНДЕКС(свЕ6!$E$5:$G$14;ПОИСКПОЗ($D12&$E12;свЕ6!$C$5:$C$13&свЕ6!$D$5:$D$13;);ПОИСКПОЗ(F$10;свЕ6!$E$4:$G$4;));0)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
У меня офис 2007
Замените ЕСНД() на ЕСЛИОШИБКА() , разницы никакой)

Код
=ЕСЛИОШИБКА(ИНДЕКС(свЕ6!$E$5:$G$14;ПОИСКПОЗ($D12&$E12;свЕ6!$C$5:$C$13&свЕ6!$D$5:$D$13;);ПОИСКПОЗ(F$10;свЕ6!$E$4:$G$4;));0)

Автор - Serge_007
Дата добавления - 10.02.2021 в 13:22
GGR Дата: Среда, 10.02.2021, 15:29 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Serge_007, Pelena спасибо за отличное решение задачи. Протестировала все предложенные варианты.Все четко работают.Одним словом профессионалы.
 
Ответить
СообщениеSerge_007, Pelena спасибо за отличное решение задачи. Протестировала все предложенные варианты.Все четко работают.Одним словом профессионалы.

Автор - GGR
Дата добавления - 10.02.2021 в 15:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос значений для присутствующего,отсутствующего столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!