Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Возвращение значений из диапазона с учетом исключений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возвращение значений из диапазона с учетом исключений (Формулы/Formulas)
Возвращение значений из диапазона с учетом исключений
Egyptian Дата: Среда, 10.02.2021, 23:25 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 24 ±
Замечаний: 0% ±

Excel 2013/2016
Доброго всем времени суток. Стоит передо мной задачка, которую никак не удается решить.
На одном листе (№1) есть диапазон, который надо вернуть на лист (№2) с учетом исключений, указанных в качестве условий.
Вот такая вот конструкция (с последовательным указанием исключений) - работает:
Код
=LOOKUP(2,1/(SEARCH('1'!$B$2:$F$2,B$2)/(B$2<>$G$2)/(B$2<>$F$2)),'1'!$B$2:$F$2)

А когда я запихиваю исключения в список
Код
LOOKUP(2,1/((SEARCH('1'!$B$2:$F$2,B$2)/(ISNA(MATCH('1'!$B$2:$F$2,$F$2:$G$2,))))),'1'!$B$2:$F$2)
то конструкция не работает должным образом.
В чем ошибка?
К сообщению приложен файл: 111.xlsx(10.2 Kb)


Сообщение отредактировал Egyptian - Среда, 10.02.2021, 23:29
 
Ответить
СообщениеДоброго всем времени суток. Стоит передо мной задачка, которую никак не удается решить.
На одном листе (№1) есть диапазон, который надо вернуть на лист (№2) с учетом исключений, указанных в качестве условий.
Вот такая вот конструкция (с последовательным указанием исключений) - работает:
Код
=LOOKUP(2,1/(SEARCH('1'!$B$2:$F$2,B$2)/(B$2<>$G$2)/(B$2<>$F$2)),'1'!$B$2:$F$2)

А когда я запихиваю исключения в список
Код
LOOKUP(2,1/((SEARCH('1'!$B$2:$F$2,B$2)/(ISNA(MATCH('1'!$B$2:$F$2,$F$2:$G$2,))))),'1'!$B$2:$F$2)
то конструкция не работает должным образом.
В чем ошибка?

Автор - Egyptian
Дата добавления - 10.02.2021 в 23:25
Egyptian Дата: Четверг, 11.02.2021, 00:32 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 24 ±
Замечаний: 0% ±

Excel 2013/2016
Вопрос снят. Кажется, постиг истину)). Вот решение,может кому понадобится.
Код
=LOOKUP(2,1/((ISNA(MATCH(B$2,$F$2:$G$2,)))/(SEARCH('1'!$B$2:$F$2,B$2))),'1'!$B$2:$F$2)
 
Ответить
СообщениеВопрос снят. Кажется, постиг истину)). Вот решение,может кому понадобится.
Код
=LOOKUP(2,1/((ISNA(MATCH(B$2,$F$2:$G$2,)))/(SEARCH('1'!$B$2:$F$2,B$2))),'1'!$B$2:$F$2)

Автор - Egyptian
Дата добавления - 11.02.2021 в 00:32
Pelena Дата: Четверг, 11.02.2021, 08:55 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 17218
Репутация: 3737 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
По Вашему примеру можно так попробовать
Код
=ЕСЛИ(ИЛИ(B2='1'!$B$2:$F$2);B2;"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПо Вашему примеру можно так попробовать
Код
=ЕСЛИ(ИЛИ(B2='1'!$B$2:$F$2);B2;"")

Автор - Pelena
Дата добавления - 11.02.2021 в 08:55
Egyptian Дата: Четверг, 11.02.2021, 12:41 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 24 ±
Замечаний: 0% ±

Excel 2013/2016
Добрый день Елена,
Спасибо, но Ваш вариант не подойдет. Идея заключалась в том, чтобы указать исключения в условиях.
Но я уже разобрался с ПРОСМОТР-ом. :)
К сообщению приложен файл: 6251091.xlsx(10.1 Kb)
 
Ответить
СообщениеДобрый день Елена,
Спасибо, но Ваш вариант не подойдет. Идея заключалась в том, чтобы указать исключения в условиях.
Но я уже разобрался с ПРОСМОТР-ом. :)

Автор - Egyptian
Дата добавления - 11.02.2021 в 12:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возвращение значений из диапазона с учетом исключений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!