Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование деструктурированной таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование деструктурированной таблицы (Формулы/Formulas)
Суммирование деструктурированной таблицы
Anis625 Дата: Понедельник, 15.02.2021, 08:39 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 480
Репутация: 45 ±
Замечаний: 0% ±

Excel 2013
Добрый день, всем участникам форума!!!

Не новичок по формулам Excel, но и не хватает своих знаний решить одну задачку.
Средствами PQ удалось собрать около 100 файлов и к сожалению они по структуре не идентичны (над этим работаем сейчас, чтобы упорядочить). Но названия показателей вроде совпадают.
Пытаюсь собрать информацию по годам. Пока получилось не самое изящное решение через ИНДЕКС выделяя каждый диапазон отдельно и таблицы соответствия на полях.
Буду признателен за совет как можно по другому переписать одну формулу для всего массива данных.
К сообщению приложен файл: 6778182.xlsx(11.7 Kb)
 
Ответить
СообщениеДобрый день, всем участникам форума!!!

Не новичок по формулам Excel, но и не хватает своих знаний решить одну задачку.
Средствами PQ удалось собрать около 100 файлов и к сожалению они по структуре не идентичны (над этим работаем сейчас, чтобы упорядочить). Но названия показателей вроде совпадают.
Пытаюсь собрать информацию по годам. Пока получилось не самое изящное решение через ИНДЕКС выделяя каждый диапазон отдельно и таблицы соответствия на полях.
Буду признателен за совет как можно по другому переписать одну формулу для всего массива данных.

Автор - Anis625
Дата добавления - 15.02.2021 в 08:39
Nic70y Дата: Понедельник, 15.02.2021, 11:18 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6751
Репутация: 1543 ±
Замечаний: 0% ±

Excel 2010
формулу
думаю это не лучший вариант - использовать формулу.
массивная
Код
=СУММ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ($B$3;ЕСЛИ($B17=$B$3:$B$13;СТРОКА($B$3:$B$13)-3);СУММЕСЛИ($Q$3:$Q$4;ЕСЛИ($B17=$B$3:$B$13;$A$3:$A$13);R$3:R$4);;)))
вдруг правильно
К сообщению приложен файл: 91.xlsx(11.0 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
формулу
думаю это не лучший вариант - использовать формулу.
массивная
Код
=СУММ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ($B$3;ЕСЛИ($B17=$B$3:$B$13;СТРОКА($B$3:$B$13)-3);СУММЕСЛИ($Q$3:$Q$4;ЕСЛИ($B17=$B$3:$B$13;$A$3:$A$13);R$3:R$4);;)))
вдруг правильно

Автор - Nic70y
Дата добавления - 15.02.2021 в 11:18
Anis625 Дата: Понедельник, 15.02.2021, 14:29 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 480
Репутация: 45 ±
Замечаний: 0% ±

Excel 2013
Nic70y,
Как раз то что доктор прописал =) Спасибо огромное за решение задачки. Формула в копилку своих знаний. Буду изучать, т.к. сходу не понял ее.
 
Ответить
СообщениеNic70y,
Как раз то что доктор прописал =) Спасибо огромное за решение задачки. Формула в копилку своих знаний. Буду изучать, т.к. сходу не понял ее.

Автор - Anis625
Дата добавления - 15.02.2021 в 14:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование деструктурированной таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!