Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сформировать список по наибольшему значению - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сформировать список по наибольшему значению (Формулы/Formulas)
Сформировать список по наибольшему значению
Ocharovashka666 Дата: Среда, 17.02.2021, 10:21 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 85
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Подскажите пожалуйста формулу. Нашла наибольшие значения и к ним надо подтянуть данные. не получается там, где дублируются значения... данные подтягиваются не верно... Пример во вложении
Заранее спасибо
К сообщению приложен файл: 1420884.xlsx(9.4 Kb)


Рада нашему знакомству
 
Ответить
СообщениеДобрый день. Подскажите пожалуйста формулу. Нашла наибольшие значения и к ним надо подтянуть данные. не получается там, где дублируются значения... данные подтягиваются не верно... Пример во вложении
Заранее спасибо

Автор - Ocharovashka666
Дата добавления - 17.02.2021 в 10:21
Serge_007 Дата: Среда, 17.02.2021, 10:30 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13925
Репутация: 2318 ±
Замечаний: ±

Excel 2010
Здравствуйте

Формула массива:
Код
=ИНДЕКС(B$2:B$8;НАИМЕНЬШИЙ(ЕСЛИ(L2=D$2:D$8;СТРОКА($1:$7));СЧЁТЕСЛИ(L2:L$2;L2)))
К сообщению приложен файл: 20210217_Ocharo.xls(30.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Формула массива:
Код
=ИНДЕКС(B$2:B$8;НАИМЕНЬШИЙ(ЕСЛИ(L2=D$2:D$8;СТРОКА($1:$7));СЧЁТЕСЛИ(L2:L$2;L2)))

Автор - Serge_007
Дата добавления - 17.02.2021 в 10:30
Nic70y Дата: Среда, 17.02.2021, 10:31 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6842
Репутация: 1571 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ($G2<$G1;ИНДЕКС(B$2:B$8;ПОИСКПОЗ($G2;$D$2:$D$8;));ИНДЕКС(B$2:B$8;ПОИСКПОЗ($G2;ИНДЕКС($D$2:$D$8;ПОИСКПОЗ($H1;$B$2:$B$8;)+1):$D$8;)+ПОИСКПОЗ($H1;$B$2:$B$8;)))
будет работать при условии, что фамилии уникальны,
иначе нужна формула массива (наверное)
К сообщению приложен файл: 514.xlsx(9.8 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ($G2<$G1;ИНДЕКС(B$2:B$8;ПОИСКПОЗ($G2;$D$2:$D$8;));ИНДЕКС(B$2:B$8;ПОИСКПОЗ($G2;ИНДЕКС($D$2:$D$8;ПОИСКПОЗ($H1;$B$2:$B$8;)+1):$D$8;)+ПОИСКПОЗ($H1;$B$2:$B$8;)))
будет работать при условии, что фамилии уникальны,
иначе нужна формула массива (наверное)

Автор - Nic70y
Дата добавления - 17.02.2021 в 10:31
Pelena Дата: Среда, 17.02.2021, 10:38 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17511
Репутация: 3890 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ещё вариант до кучи
Код
=ИНДЕКС($B$2:$B$8;АГРЕГАТ(15;6;(СТРОКА($D$2:$D$8)-1)/($D$2:$D$8=G2);СЧЁТЕСЛИ($G$2:$G2;G2)))
К сообщению приложен файл: 2672395.xlsx(10.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант до кучи
Код
=ИНДЕКС($B$2:$B$8;АГРЕГАТ(15;6;(СТРОКА($D$2:$D$8)-1)/($D$2:$D$8=G2);СЧЁТЕСЛИ($G$2:$G2;G2)))

Автор - Pelena
Дата добавления - 17.02.2021 в 10:38
Ocharovashka666 Дата: Среда, 17.02.2021, 11:07 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 85
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо Вам огромное. Все сработало, отчет доделала))) Вы очень меня выручили. Вечером после работы буду изучать подробно их)))) С приближающимися праздниками Вас)))


Рада нашему знакомству
 
Ответить
СообщениеСпасибо Вам огромное. Все сработало, отчет доделала))) Вы очень меня выручили. Вечером после работы буду изучать подробно их)))) С приближающимися праздниками Вас)))

Автор - Ocharovashka666
Дата добавления - 17.02.2021 в 11:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сформировать список по наибольшему значению (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!