Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и вывод строк по значения в соседней ячейке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и вывод строк по значения в соседней ячейке (Формулы/Formulas)
Поиск и вывод строк по значения в соседней ячейке
Chetvertkoff Дата: Четверг, 18.02.2021, 09:48 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем привет, у меня такая задача.... Из общего списка (редактируемого, точнее дополняемого) разделить по категориям на другой лист и на третьем листе создать блок с помощью выпадающего списка ( сам список это и есть выборка по категориям на втором листе.
схема:
Лист1 - "Блок" - тут будет те же категории как и на других листах только в виде вып. списка
Лист2 - "Разделение" - это разделение на категории из общего списка Лист3 для создания выпадающего списка для Листа1
Лист3 - "сырье" - списко всего сырья, в первой колонке как раз те самые категории по которым надо разбить списки в Листе2
Если что не дописал, прошу прощения, исправлю.
К сообщению приложен файл: 3244310.xlsm(41.6 Kb)
 
Ответить
СообщениеВсем привет, у меня такая задача.... Из общего списка (редактируемого, точнее дополняемого) разделить по категориям на другой лист и на третьем листе создать блок с помощью выпадающего списка ( сам список это и есть выборка по категориям на втором листе.
схема:
Лист1 - "Блок" - тут будет те же категории как и на других листах только в виде вып. списка
Лист2 - "Разделение" - это разделение на категории из общего списка Лист3 для создания выпадающего списка для Листа1
Лист3 - "сырье" - списко всего сырья, в первой колонке как раз те самые категории по которым надо разбить списки в Листе2
Если что не дописал, прошу прощения, исправлю.

Автор - Chetvertkoff
Дата добавления - 18.02.2021 в 09:48
Nic70y Дата: Четверг, 18.02.2021, 10:30 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6747
Репутация: 1523 ±
Замечаний: 0% ±

Excel 2010
как-то так наверное,
вдруг правильно
К сообщению приложен файл: 5744987.xlsm(45.8 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениекак-то так наверное,
вдруг правильно

Автор - Nic70y
Дата добавления - 18.02.2021 в 10:30
Chetvertkoff Дата: Четверг, 18.02.2021, 11:12 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да вроди все отлично работает, у меня пара вопросов
1) если можно рассказать что делает формула а точнее почему поиск значения "ПНД" происходит через такие сложности ( я понимаю что так эксель сделан) - (A1<>0;A1;"") почему так? И почему значение после выполнения формулы равно "4"
Код
=ПОИСКПОЗ(ЕСЛИ(B1<>0;B1;"我");сырье!$B:$B;B1=0)
( что за иероглиф?) я понимаю что его можно на что угодно заменить, но вдруг он к чему то? или это подпись? "Моё"? =)
2) тоже самое и тут - не понимаю почему формула смотрит на пару ячеек выше?
Код
=ЕСЛИ(СТРОКА(B6)<C$2-B$2+1;ИНДЕКС(сырье!$C:$C;B$2+СТРОКА(B6)-1);"")


а тут вообще темный лес)
Код
=ИНДЕКС(Таблица1173[вид сырья];НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(Таблица1173[вид сырья];Таблица1173[вид сырья];)=СТРОКА(Таблица1173[вид сырья])-3;СТРОКА(Таблица1173[вид сырья])-3);СТОЛБЕЦ()))


Сообщение отредактировал Chetvertkoff - Четверг, 18.02.2021, 11:14
 
Ответить
СообщениеДа вроди все отлично работает, у меня пара вопросов
1) если можно рассказать что делает формула а точнее почему поиск значения "ПНД" происходит через такие сложности ( я понимаю что так эксель сделан) - (A1<>0;A1;"") почему так? И почему значение после выполнения формулы равно "4"
Код
=ПОИСКПОЗ(ЕСЛИ(B1<>0;B1;"我");сырье!$B:$B;B1=0)
( что за иероглиф?) я понимаю что его можно на что угодно заменить, но вдруг он к чему то? или это подпись? "Моё"? =)
2) тоже самое и тут - не понимаю почему формула смотрит на пару ячеек выше?
Код
=ЕСЛИ(СТРОКА(B6)<C$2-B$2+1;ИНДЕКС(сырье!$C:$C;B$2+СТРОКА(B6)-1);"")


а тут вообще темный лес)
Код
=ИНДЕКС(Таблица1173[вид сырья];НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(Таблица1173[вид сырья];Таблица1173[вид сырья];)=СТРОКА(Таблица1173[вид сырья])-3;СТРОКА(Таблица1173[вид сырья])-3);СТОЛБЕЦ()))

Автор - Chetvertkoff
Дата добавления - 18.02.2021 в 11:12
Nic70y Дата: Четверг, 18.02.2021, 11:29 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6747
Репутация: 1523 ±
Замечаний: 0% ±

Excel 2010
а тут вообще темный лес)
тут я забыл докопипастить на самом деле
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица1173[вид сырья];НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(Таблица1173[вид сырья];Таблица1173[вид сырья];)=СТРОКА(Таблица1173[вид сырья])-3;СТРОКА(Таблица1173[вид сырья])-3);СТОЛБЕЦ()));0)
в файле она в 2х правых ячейках,
эта формула извлекает уникальные* значения.
=ПОИСКПОЗ(ЕСЛИ(B1<>0;B1;"我");сырье!$B:$B;B1=0)
если ячейка не равна 0, т.е. это уникальное* значение,
мы ищем его,
иначе уникальные значения закончились и нам нужно найти последнюю, заполненную текстом строку,
(для ограничения списка)
для этого поиск должен быть неточным (ИСТИНА)
B1=0
и искать нужно большой* текст,
в данном случае иероглиф
я понимаю что его можно на что угодно заменить
ну не на что угодно, а на большой текст, например "яя"
"Моё"?
типа того


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
а тут вообще темный лес)
тут я забыл докопипастить на самом деле
Код
=ЕСЛИОШИБКА(ИНДЕКС(Таблица1173[вид сырья];НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(Таблица1173[вид сырья];Таблица1173[вид сырья];)=СТРОКА(Таблица1173[вид сырья])-3;СТРОКА(Таблица1173[вид сырья])-3);СТОЛБЕЦ()));0)
в файле она в 2х правых ячейках,
эта формула извлекает уникальные* значения.
=ПОИСКПОЗ(ЕСЛИ(B1<>0;B1;"我");сырье!$B:$B;B1=0)
если ячейка не равна 0, т.е. это уникальное* значение,
мы ищем его,
иначе уникальные значения закончились и нам нужно найти последнюю, заполненную текстом строку,
(для ограничения списка)
для этого поиск должен быть неточным (ИСТИНА)
B1=0
и искать нужно большой* текст,
в данном случае иероглиф
я понимаю что его можно на что угодно заменить
ну не на что угодно, а на большой текст, например "яя"
"Моё"?
типа того

Автор - Nic70y
Дата добавления - 18.02.2021 в 11:29
Chetvertkoff Дата: Четверг, 18.02.2021, 11:45 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
я понял, спасибо большое за подробности
 
Ответить
Сообщениея понял, спасибо большое за подробности

Автор - Chetvertkoff
Дата добавления - 18.02.2021 в 11:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и вывод строк по значения в соседней ячейке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!