Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разбиение на подстроки с опред. форматом - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбиение на подстроки с опред. форматом (Формулы/Formulas)
Разбиение на подстроки с опред. форматом
FirstTime Дата: Четверг, 18.02.2021, 15:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

День добрый, подскажите по след. вопросу:



Есть исходные данные из которых, пользуясь формулой (на скрине видно), вытаскиваю чать строки после 2-го разделителя "!".
Как получившиеся данные, можно привезти к ввиду XXXXX. Т.е. если в исходники содержится только 3 числа, мы добавили доп "00" в начало
К сообщению приложен файл: 9628644.xlsx(9.8 Kb)
 
Ответить
СообщениеДень добрый, подскажите по след. вопросу:



Есть исходные данные из которых, пользуясь формулой (на скрине видно), вытаскиваю чать строки после 2-го разделителя "!".
Как получившиеся данные, можно привезти к ввиду XXXXX. Т.е. если в исходники содержится только 3 числа, мы добавили доп "00" в начало

Автор - FirstTime
Дата добавления - 18.02.2021 в 15:08
ShAM Дата: Четверг, 18.02.2021, 15:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1304
Репутация: 225 ±
Замечаний: 0% ±

Excel 2010
Можно так, используя Вашу же формулу;
Код
=ПОВТОР(0;5-ДЛСТР(ПРАВСИМВ(A2;ДЛСТР(A2)-ПОИСК("!";A2;ПОИСК("!";A2)+1))))&ПРАВСИМВ(A2;ДЛСТР(A2)-ПОИСК("!";A2;ПОИСК("!";A2)+1))
К сообщению приложен файл: FirstTime.xlsx(15.3 Kb)
 
Ответить
СообщениеМожно так, используя Вашу же формулу;
Код
=ПОВТОР(0;5-ДЛСТР(ПРАВСИМВ(A2;ДЛСТР(A2)-ПОИСК("!";A2;ПОИСК("!";A2)+1))))&ПРАВСИМВ(A2;ДЛСТР(A2)-ПОИСК("!";A2;ПОИСК("!";A2)+1))

Автор - ShAM
Дата добавления - 18.02.2021 в 15:22
ShAM Дата: Четверг, 18.02.2021, 15:27 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1304
Репутация: 225 ±
Замечаний: 0% ±

Excel 2010
Если это только визуально нужно, то можно использовать пользовательский формат: 00000
И еще вспомнил Сашу (Boroda):
Код
=ТЕКСТ(ПРАВСИМВ(A2;ДЛСТР(A2)-ПОИСК("!";A2;ПОИСК("!";A2)+1));"00000")


Сообщение отредактировал ShAM - Четверг, 18.02.2021, 15:30
 
Ответить
СообщениеЕсли это только визуально нужно, то можно использовать пользовательский формат: 00000
И еще вспомнил Сашу (Boroda):
Код
=ТЕКСТ(ПРАВСИМВ(A2;ДЛСТР(A2)-ПОИСК("!";A2;ПОИСК("!";A2)+1));"00000")

Автор - ShAM
Дата добавления - 18.02.2021 в 15:27
FirstTime Дата: Четверг, 18.02.2021, 15:32 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

ShAM, шикарно, спасибо
 
Ответить
СообщениеShAM, шикарно, спасибо

Автор - FirstTime
Дата добавления - 18.02.2021 в 15:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбиение на подстроки с опред. форматом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!