Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Исправление даты на число - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Исправление даты на число (Формулы/Formulas)
Исправление даты на число
bikerlf Дата: Четверг, 18.02.2021, 16:05 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Добрый день !

Есть таблицы в которых числа заменены датой. Например :
04.авг
июл.14
06.окт

На самом деле должно быть так:
4-8
7-14
6-10
Т.е. число - (знак минус) число, эксель автоматом меняет на дату

Как исправить с помощью макроса, формулы или стандартных средств ?
 
Ответить
СообщениеДобрый день !

Есть таблицы в которых числа заменены датой. Например :
04.авг
июл.14
06.окт

На самом деле должно быть так:
4-8
7-14
6-10
Т.е. число - (знак минус) число, эксель автоматом меняет на дату

Как исправить с помощью макроса, формулы или стандартных средств ?

Автор - bikerlf
Дата добавления - 18.02.2021 в 16:05
Serge_007 Дата: Четверг, 18.02.2021, 17:46 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13925
Репутация: 2318 ±
Замечаний: ±

Excel 2010
Здравствуйте

числа заменены датой
Что это значит?
Даты в Excel - это числа

Как исправить
Что исправить?
Файл-то Вы не приложили


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

числа заменены датой
Что это значит?
Даты в Excel - это числа

Как исправить
Что исправить?
Файл-то Вы не приложили

Автор - Serge_007
Дата добавления - 18.02.2021 в 17:46
Anis625 Дата: Пятница, 19.02.2021, 01:18 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 527
Репутация: 28 ±
Замечаний: 0% ±

Excel 2013
bikerlf,
Так? С примером было бы полегче. Во второй строке "июл.14" - это июль 2014 года? или опечатка и должно быть "14.июл"?
К сообщению приложен файл: 5298120.xlsx(9.1 Kb)
 
Ответить
Сообщениеbikerlf,
Так? С примером было бы полегче. Во второй строке "июл.14" - это июль 2014 года? или опечатка и должно быть "14.июл"?

Автор - Anis625
Дата добавления - 19.02.2021 в 01:18
bikerlf Дата: Пятница, 19.02.2021, 15:38 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

К сообщению приложен файл: 5298120.xlsx(9.1 Kb)


Вот так у меня, решение подходит. Если кто напишет макрос, будет еще проще.
 
Ответить
Сообщение
К сообщению приложен файл: 5298120.xlsx(9.1 Kb)


Вот так у меня, решение подходит. Если кто напишет макрос, будет еще проще.

Автор - bikerlf
Дата добавления - 19.02.2021 в 15:38
bikerlf Дата: Пятница, 02.04.2021, 20:10 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Подскажите как исправить дату на число, файл приложил. Задача отличается от предыдущей поэтому та формула не подходит.
В чем причина такого поведения эксель, есть ли решение задачи с помощью стандартных средств и простыми словами почему так происходит.
К сообщению приложен файл: 2042.xlsx(8.4 Kb)


Сообщение отредактировал bikerlf - Пятница, 02.04.2021, 20:10
 
Ответить
СообщениеПодскажите как исправить дату на число, файл приложил. Задача отличается от предыдущей поэтому та формула не подходит.
В чем причина такого поведения эксель, есть ли решение задачи с помощью стандартных средств и простыми словами почему так происходит.

Автор - bikerlf
Дата добавления - 02.04.2021 в 20:10
Pelena Дата: Пятница, 02.04.2021, 21:38 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 17501
Репутация: 3888 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
В чем причина такого поведения эксель
обычно так происходит, когда текстовый файл импортируется в Excel. Если это действительно импорт, то открывайте файл через Мастер импорта текста. Там есть настройки, позволяющие воспринимать точку как десятичный разделитель и игнорировать преобразование дат (если я не ошибаюсь)
Также можно сделать везде текстовый формат ячеек.

А формулу можно так записать. Скорей всего не 100% исправит, но большинство
Код
=ЕСЛИОШИБКА(ЕСЛИ(ГОД(A1)=ГОД(СЕГОДНЯ());ДЕНЬ(A1)&"-"&МЕСЯЦ(A1);МЕСЯЦ(A1)&"-"&ГОД(A1));A1)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
В чем причина такого поведения эксель
обычно так происходит, когда текстовый файл импортируется в Excel. Если это действительно импорт, то открывайте файл через Мастер импорта текста. Там есть настройки, позволяющие воспринимать точку как десятичный разделитель и игнорировать преобразование дат (если я не ошибаюсь)
Также можно сделать везде текстовый формат ячеек.

А формулу можно так записать. Скорей всего не 100% исправит, но большинство
Код
=ЕСЛИОШИБКА(ЕСЛИ(ГОД(A1)=ГОД(СЕГОДНЯ());ДЕНЬ(A1)&"-"&МЕСЯЦ(A1);МЕСЯЦ(A1)&"-"&ГОД(A1));A1)

Автор - Pelena
Дата добавления - 02.04.2021 в 21:38
gling Дата: Пятница, 02.04.2021, 22:21 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2254
Репутация: 584 ±
Замечаний: 0% ±

2010
Не понял что надо, но может эта подойдёт?
Код
=ТЕКСТ(A1;"ММ-ГГГГ")


ЯД-41001506838083

Сообщение отредактировал gling - Пятница, 02.04.2021, 22:22
 
Ответить
СообщениеНе понял что надо, но может эта подойдёт?
Код
=ТЕКСТ(A1;"ММ-ГГГГ")

Автор - gling
Дата добавления - 02.04.2021 в 22:21
bikerlf Дата: Суббота, 03.04.2021, 10:31 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Palena, формула подходит частично (не хватает 0 в самом начале)
В исходнике отображается вот так: сен.05
Правильный вариант - артикул вида: 09-2205
Т.е. нужна формула которая которая из сен.05 Сделает - 09-2205
К сообщению приложен файл: 1448354.xlsx(9.1 Kb)


Сообщение отредактировал bikerlf - Суббота, 03.04.2021, 10:53
 
Ответить
СообщениеPalena, формула подходит частично (не хватает 0 в самом начале)
В исходнике отображается вот так: сен.05
Правильный вариант - артикул вида: 09-2205
Т.е. нужна формула которая которая из сен.05 Сделает - 09-2205

Автор - bikerlf
Дата добавления - 03.04.2021 в 10:31
Pelena Дата: Суббота, 03.04.2021, 10:39 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 17501
Репутация: 3888 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ну, если подходит, тогда можно по примеру gling попробовать её немного сократить
Код
=ЕСЛИОШИБКА(ЕСЛИ(ГОД(A1)=ГОД(СЕГОДНЯ());ТЕКСТ(A1;"Д-М");ТЕКСТ(A1;"М-ГГГГ"));A1)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНу, если подходит, тогда можно по примеру gling попробовать её немного сократить
Код
=ЕСЛИОШИБКА(ЕСЛИ(ГОД(A1)=ГОД(СЕГОДНЯ());ТЕКСТ(A1;"Д-М");ТЕКСТ(A1;"М-ГГГГ"));A1)

Автор - Pelena
Дата добавления - 03.04.2021 в 10:39
bikerlf Дата: Понедельник, 05.04.2021, 16:17 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

gling, Изначально пропустил. Сегодня попробовал - работает. Спасибо !
 
Ответить
Сообщениеgling, Изначально пропустил. Сегодня попробовал - работает. Спасибо !

Автор - bikerlf
Дата добавления - 05.04.2021 в 16:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Исправление даты на число (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!