Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск предыдущей даты использования вагона - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск предыдущей даты использования вагона (Формулы/Formulas)
Поиск предыдущей даты использования вагона
Helena0597 Дата: Среда, 24.02.2021, 11:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Необходимо найти количество дней, которое ушло на рейс. Я думаю сначала найти дату предыдущего рейса, а затем вычитанием найти это самое количество дней. Но возникла проблема: не могу правильно составить формулу, чтобы искалась эта самая дата предыдущего рейса %) . Табличку прилагаю.
Заранее благодарю!
К сообщению приложен файл: 1883878.xlsx(26.6 Kb)
 
Ответить
СообщениеДобрый день!
Необходимо найти количество дней, которое ушло на рейс. Я думаю сначала найти дату предыдущего рейса, а затем вычитанием найти это самое количество дней. Но возникла проблема: не могу правильно составить формулу, чтобы искалась эта самая дата предыдущего рейса %) . Табличку прилагаю.
Заранее благодарю!

Автор - Helena0597
Дата добавления - 24.02.2021 в 11:18
Nic70y Дата: Среда, 24.02.2021, 11:34 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(МАКС((D$3:D3=D4)*C$3:C3))
вдруг правильно
К сообщению приложен файл: 4645171.xlsx(36.6 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(МАКС((D$3:D3=D4)*C$3:C3))
вдруг правильно

Автор - Nic70y
Дата добавления - 24.02.2021 в 11:34
китин Дата: Среда, 24.02.2021, 11:44 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6417
Репутация: 984 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как то так не?
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$3:$C$531;ПОИСКПОЗ(1;(($C3>$C$3:$C$531)*($D3=$D$3:$D$531));0));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
не, неправильно не смотрите :'(
К сообщению приложен файл: 4881789.xlsx(37.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениекак то так не?
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$3:$C$531;ПОИСКПОЗ(1;(($C3>$C$3:$C$531)*($D3=$D$3:$D$531));0));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
не, неправильно не смотрите :'(

Автор - китин
Дата добавления - 24.02.2021 в 11:44
Helena0597 Дата: Среда, 24.02.2021, 12:13 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, спасибо за оперативность. Пробую! Цифры похожи на правду))
 
Ответить
СообщениеNic70y, спасибо за оперативность. Пробую! Цифры похожи на правду))

Автор - Helena0597
Дата добавления - 24.02.2021 в 12:13
Helena0597 Дата: Среда, 24.02.2021, 12:14 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

китин, спасибо за оперативность! Цифры действительно не совсем похожи на правду
 
Ответить
Сообщениекитин, спасибо за оперативность! Цифры действительно не совсем похожи на правду

Автор - Helena0597
Дата добавления - 24.02.2021 в 12:14
китин Дата: Среда, 24.02.2021, 12:16 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 6417
Репутация: 984 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
не совсем похожи на правду

точнее совсем непохожи :p
вот правильно
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$3:$C$531;НАИМЕНЬШИЙ(ЕСЛИ($D3=$D$3:$D$531;СТРОКА($D$3:$D$531)-2);СЧЁТЕСЛИ($D$3:D3;D3)-1));0)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 9062868.xlsx(39.4 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
не совсем похожи на правду

точнее совсем непохожи :p
вот правильно
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$3:$C$531;НАИМЕНЬШИЙ(ЕСЛИ($D3=$D$3:$D$531;СТРОКА($D$3:$D$531)-2);СЧЁТЕСЛИ($D$3:D3;D3)-1));0)

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 24.02.2021 в 12:16
Helena0597 Дата: Среда, 24.02.2021, 12:49 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, в большинстве случаев считает верно hands , но в некоторых система дает сбой %)
Спасибо
 
Ответить
СообщениеNic70y, в большинстве случаев считает верно hands , но в некоторых система дает сбой %)
Спасибо

Автор - Helena0597
Дата добавления - 24.02.2021 в 12:49
Helena0597 Дата: Среда, 24.02.2021, 12:53 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

китин, да, здесь цифры более достоверные :) , но у меня дата через в большинстве случаев 00.01.1900 выдает %)
Спасибо, что помогаете! :)
 
Ответить
Сообщениекитин, да, здесь цифры более достоверные :) , но у меня дата через в большинстве случаев 00.01.1900 выдает %)
Спасибо, что помогаете! :)

Автор - Helena0597
Дата добавления - 24.02.2021 в 12:53
Nic70y Дата: Среда, 24.02.2021, 13:11 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
00.01.1900 выдает
это значит, что предыдущей даты нет


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
00.01.1900 выдает
это значит, что предыдущей даты нет

Автор - Nic70y
Дата добавления - 24.02.2021 в 13:11
Helena0597 Дата: Четверг, 25.02.2021, 09:51 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, добрый день! Но она есть по факту в таблице
 
Ответить
СообщениеNic70y, добрый день! Но она есть по факту в таблице

Автор - Helena0597
Дата добавления - 25.02.2021 в 09:51
Nic70y Дата: Четверг, 25.02.2021, 10:32 | Сообщение № 11
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
нужно видеть файл,
так сложно что-то сказать


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениенужно видеть файл,
так сложно что-то сказать

Автор - Nic70y
Дата добавления - 25.02.2021 в 10:32
Helena0597 Дата: Четверг, 25.02.2021, 10:56 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Спасибо всем за помощь! У меня, кажется, наконец получается автоматически высчитать все! (сейчас проверяю всё в деле :up: )
Вы - лучшие! respect
 
Ответить
СообщениеСпасибо всем за помощь! У меня, кажется, наконец получается автоматически высчитать все! (сейчас проверяю всё в деле :up: )
Вы - лучшие! respect

Автор - Helena0597
Дата добавления - 25.02.2021 в 10:56
jakim Дата: Четверг, 25.02.2021, 16:34 | Сообщение № 13
Группа: Друзья
Ранг: Ветеран
Сообщений: 999
Репутация: 272 ±
Замечаний: 0% ±

Excel 2010
Формула для даты

Код
=IFERROR(AGGREGATE(14;6;C$3:C$1000/(C3>C$3:C$1000)/(D3=D$3:D$1000);1);"")

Для количества дней

Код
=IFERROR(DATEDIF(E3;C3;"d");"")
К сообщению приложен файл: 8172021.xlsx(31.4 Kb)
 
Ответить
Сообщение
Формула для даты

Код
=IFERROR(AGGREGATE(14;6;C$3:C$1000/(C3>C$3:C$1000)/(D3=D$3:D$1000);1);"")

Для количества дней

Код
=IFERROR(DATEDIF(E3;C3;"d");"")

Автор - jakim
Дата добавления - 25.02.2021 в 16:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск предыдущей даты использования вагона (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!