Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расписать уникальные числа по принадлежности к номеру блока. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расписать уникальные числа по принадлежности к номеру блока. (Формулы/Formulas)
Расписать уникальные числа по принадлежности к номеру блока.
russcand Дата: Среда, 24.02.2021, 18:11 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Помогите , кто-чем может....

Есть ряд уникальных чисел ( ПОЛЕ ЧИСЕЛ ) 1-99 ( Т_1 ).
Расписаны по БЛОКАМ 10-1 ( левый крайний столбец ).
Задача.
В Т_2 присвоить каждому числу его номер блока. Можно расположить как столбцом ( как у меня ) , так и строкой ( как удобно для формулы ).
К сообщению приложен файл: _Microsoft_Exce.xlsx(16.1 Kb)
 
Ответить
СообщениеПомогите , кто-чем может....

Есть ряд уникальных чисел ( ПОЛЕ ЧИСЕЛ ) 1-99 ( Т_1 ).
Расписаны по БЛОКАМ 10-1 ( левый крайний столбец ).
Задача.
В Т_2 присвоить каждому числу его номер блока. Можно расположить как столбцом ( как у меня ) , так и строкой ( как удобно для формулы ).

Автор - russcand
Дата добавления - 24.02.2021 в 18:11
Pelena Дата: Среда, 24.02.2021, 19:05 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17499
Репутация: 3886 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ИНДЕКС($B$9:$B$44;СУММПРОИЗВ((AF9=$D$9:$AD$44)*(СТРОКА($B$9:$B$44)-СТРОКА($D$9)+1)))

или
Код
=ИНДЕКС($B$9:$B$44;ПОИСКПОЗ(1;МУМНОЖ(--(AF9=$D$9:$AD$44);ТРАНСП(СТОЛБЕЦ($D$9:$AD$44))^0);0))
К сообщению приложен файл: 5759909.xlsx(19.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ИНДЕКС($B$9:$B$44;СУММПРОИЗВ((AF9=$D$9:$AD$44)*(СТРОКА($B$9:$B$44)-СТРОКА($D$9)+1)))

или
Код
=ИНДЕКС($B$9:$B$44;ПОИСКПОЗ(1;МУМНОЖ(--(AF9=$D$9:$AD$44);ТРАНСП(СТОЛБЕЦ($D$9:$AD$44))^0);0))

Автор - Pelena
Дата добавления - 24.02.2021 в 19:05
russcand Дата: Среда, 24.02.2021, 20:51 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 110
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо , все получилось.
 
Ответить
СообщениеСпасибо , все получилось.

Автор - russcand
Дата добавления - 24.02.2021 в 20:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расписать уникальные числа по принадлежности к номеру блока. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!