Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Соединить столбцы по идентификационному номеру UID - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соединить столбцы по идентификационному номеру UID (Формулы/Formulas)
Соединить столбцы по идентификационному номеру UID
shepenindima Дата: Четверг, 25.02.2021, 17:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Соединить столбцы из второй вкладки со столбцами из первой вкладки по идентификационному номеру (UID).
Итог: данные для каждого UID с январь по ноябрь

Спасибо :)
К сообщению приложен файл: 1687269.xlsx(12.7 Kb)
 
Ответить
СообщениеСоединить столбцы из второй вкладки со столбцами из первой вкладки по идентификационному номеру (UID).
Итог: данные для каждого UID с январь по ноябрь

Спасибо :)

Автор - shepenindima
Дата добавления - 25.02.2021 в 17:57
_Igor_61 Дата: Четверг, 25.02.2021, 19:34 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 380
Репутация: 78 ±
Замечаний: 0% ±

Excel 2007
Спасибо

Всегда пожалуйста! :)
данные для каждого UID с январь по ноябрь

Помесячно, или сумма, где и как это должно отобразиться? На первом листе до августа, на втором с сентября по ноябрь... Что с чем соединять? Или соединить столбцы как текст? Или посчитать сумму с января по ноябрь? Что значит "соединить"?
 
Ответить
Сообщение
Спасибо

Всегда пожалуйста! :)
данные для каждого UID с январь по ноябрь

Помесячно, или сумма, где и как это должно отобразиться? На первом листе до августа, на втором с сентября по ноябрь... Что с чем соединять? Или соединить столбцы как текст? Или посчитать сумму с января по ноябрь? Что значит "соединить"?

Автор - _Igor_61
Дата добавления - 25.02.2021 в 19:34
bigor Дата: Четверг, 25.02.2021, 20:01 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 418
Репутация: 76 ±
Замечаний: 0% ±

нет
Как понял.
В I2
Код

=SUM(B2:I2;VLOOKUP(A2;'Table 2'.$A$2:$D$20;{2;3;4};0))

и протянуть вниз
 
Ответить
СообщениеКак понял.
В I2
Код

=SUM(B2:I2;VLOOKUP(A2;'Table 2'.$A$2:$D$20;{2;3;4};0))

и протянуть вниз

Автор - bigor
Дата добавления - 25.02.2021 в 20:01
gling Дата: Четверг, 25.02.2021, 23:27 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2243
Репутация: 581 ±
Замечаний: 0% ±

2010
Есть несколько вариантов решения
1. Сортируете обе таблицы одинаково по номеру UID и соедтиняете
столбцы из второй вкладки со столбцами из первой вкладки

2. ВПР() по номеру UID первой вкладки, подтягиваете данные второй вкладки.
3. СУММЕСЛИ() по номеру UID результат берется из нужного месяца.


ЯД-41001506838083
 
Ответить
СообщениеЕсть несколько вариантов решения
1. Сортируете обе таблицы одинаково по номеру UID и соедтиняете
столбцы из второй вкладки со столбцами из первой вкладки

2. ВПР() по номеру UID первой вкладки, подтягиваете данные второй вкладки.
3. СУММЕСЛИ() по номеру UID результат берется из нужного месяца.

Автор - gling
Дата добавления - 25.02.2021 в 23:27
shepenindima Дата: Пятница, 26.02.2021, 07:59 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

_Igor_61, на вкладке "Table 1" для определенных UID отображены цены с январь по август. На вкладке "Table 2" для этих же UID отображены цены с сентября по ноябрь. Необходимо присоединить цены из второй вкладке к таблице из первой вкладки, так, чтобы для каждого UID в "Table 1" отображались помесячные цены с января по ноябрь. Есть ли универсальная формула, которую можно постороить на вкладке "Table 1" в ячейке J2 так, чтобы можно было протянуть вправо и вниз и все данные подтянулись бы? Складывать не надо. Спасибо.
 
Ответить
Сообщение_Igor_61, на вкладке "Table 1" для определенных UID отображены цены с январь по август. На вкладке "Table 2" для этих же UID отображены цены с сентября по ноябрь. Необходимо присоединить цены из второй вкладке к таблице из первой вкладки, так, чтобы для каждого UID в "Table 1" отображались помесячные цены с января по ноябрь. Есть ли универсальная формула, которую можно постороить на вкладке "Table 1" в ячейке J2 так, чтобы можно было протянуть вправо и вниз и все данные подтянулись бы? Складывать не надо. Спасибо.

Автор - shepenindima
Дата добавления - 26.02.2021 в 07:59
Pelena Дата: Пятница, 26.02.2021, 08:25 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 17439
Репутация: 3873 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ВПР($A2;table2;ПОИСКПОЗ(J$1;'Table 2'!$A$1:$D$1;0);0)
К сообщению приложен файл: 1008411.xlsx(14.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ВПР($A2;table2;ПОИСКПОЗ(J$1;'Table 2'!$A$1:$D$1;0);0)

Автор - Pelena
Дата добавления - 26.02.2021 в 08:25
shepenindima Дата: Пятница, 26.02.2021, 08:33 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Pelena, спасибо :)
 
Ответить
СообщениеPelena, спасибо :)

Автор - shepenindima
Дата добавления - 26.02.2021 в 08:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Соединить столбцы по идентификационному номеру UID (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!