Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск ближайшего числа в массиве по приближенным условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ближайшего числа в массиве по приближенным условиям (Формулы/Formulas)
Поиск ближайшего числа в массиве по приближенным условиям
kvgubenkov Дата: Понедельник, 01.03.2021, 19:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер!

Прошу помочь с формулами массивов.

Имеется таблица (шапка, правая и левая колонки, тело).
В левой колонке указан один параметр, в шапке - другой, в теле таблицы находятся числовые данные. В правой колонке - цель.

Необходимо
на основании заданных для левой колонки, шапки и тела таблицы параметров,
определить цель, т.е. данные в правой колонке.

Проблема в том, что точно можно задать только параметр для левой колонки таблицы. Для шапки и тела таблицы задаются приближенные значения, причем для шапки ищется ближайшее максимальное значение, а в теле таблицы - ближайшее минимальное. Для ближайших максимальных решение имеется. С минимальным - не могу понять, как действовать
К сообщению приложен файл: 6455167.xlsx(12.1 Kb)
 
Ответить
СообщениеДобрый вечер!

Прошу помочь с формулами массивов.

Имеется таблица (шапка, правая и левая колонки, тело).
В левой колонке указан один параметр, в шапке - другой, в теле таблицы находятся числовые данные. В правой колонке - цель.

Необходимо
на основании заданных для левой колонки, шапки и тела таблицы параметров,
определить цель, т.е. данные в правой колонке.

Проблема в том, что точно можно задать только параметр для левой колонки таблицы. Для шапки и тела таблицы задаются приближенные значения, причем для шапки ищется ближайшее максимальное значение, а в теле таблицы - ближайшее минимальное. Для ближайших максимальных решение имеется. С минимальным - не могу понять, как действовать

Автор - kvgubenkov
Дата добавления - 01.03.2021 в 19:18
прохожий2019 Дата: Понедельник, 01.03.2021, 20:38 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 531
Репутация: 129 ±
Замечаний: 0% ±

365 Beta Channel
чем ответы тут не устроили?
 
Ответить
Сообщениечем ответы тут не устроили?

Автор - прохожий2019
Дата добавления - 01.03.2021 в 20:38
kvgubenkov Дата: Понедельник, 01.03.2021, 20:55 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Решена задача с ближайшим максимумом, и за это специалистам огромнейшая благодарность. Ближайший минимум пытался отыскать самостоятельно, ничего не получилось.
 
Ответить
СообщениеРешена задача с ближайшим максимумом, и за это специалистам огромнейшая благодарность. Ближайший минимум пытался отыскать самостоятельно, ничего не получилось.

Автор - kvgubenkov
Дата добавления - 01.03.2021 в 20:55
gling Дата: Понедельник, 01.03.2021, 21:36 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2243
Репутация: 581 ±
Замечаний: 0% ±

2010
Здравствуйте.
С формулами в диспетчере имен.
Код
=ИНДЕКС(Свинец;ПОИСКПОЗ($Q11;Толщина;1))
Пустые ячейки таблицы лучше заполнить данными снизу.
К сообщению приложен файл: 7176675.xlsx(12.2 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Понедельник, 01.03.2021, 21:38
 
Ответить
СообщениеЗдравствуйте.
С формулами в диспетчере имен.
Код
=ИНДЕКС(Свинец;ПОИСКПОЗ($Q11;Толщина;1))
Пустые ячейки таблицы лучше заполнить данными снизу.

Автор - gling
Дата добавления - 01.03.2021 в 21:36
kvgubenkov Дата: Понедельник, 01.03.2021, 22:01 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное!
Пустые ячейки таблицы лучше заполнить данными снизу.
Там табличные значения, и пустых мест порядка 50-60%, разрывы в данных велики
 
Ответить
СообщениеСпасибо огромное!
Пустые ячейки таблицы лучше заполнить данными снизу.
Там табличные значения, и пустых мест порядка 50-60%, разрывы в данных велики

Автор - kvgubenkov
Дата добавления - 01.03.2021 в 22:01
jakim Дата: Вторник, 02.03.2021, 16:47 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 999
Репутация: 272 ±
Замечаний: 0% ±

Excel 2010
формула

Код
=AGGREGATE(15;6;H4:H23/(B4:H23=AGGREGATE(14;6;INDEX(B4:H23;;MATCH(AGGREGATE(15;6;B1:G1/(B1:G1>=Q9);1);B1:G1;0))/(B4:H23<=Q11)/(A4:A23=Q10);1))/(A4:A23=Q10);1)

Результат в ячейке Z11.
К сообщению приложен файл: 4743366.xlsx(11.8 Kb)
 
Ответить
Сообщение
формула

Код
=AGGREGATE(15;6;H4:H23/(B4:H23=AGGREGATE(14;6;INDEX(B4:H23;;MATCH(AGGREGATE(15;6;B1:G1/(B1:G1>=Q9);1);B1:G1;0))/(B4:H23<=Q11)/(A4:A23=Q10);1))/(A4:A23=Q10);1)

Результат в ячейке Z11.

Автор - jakim
Дата добавления - 02.03.2021 в 16:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ближайшего числа в массиве по приближенным условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!