Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сводная с нескольких листов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сводная с нескольких листов (Формулы/Formulas)
Сводная с нескольких листов
ewgen1307 Дата: Понедельник, 15.03.2021, 19:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Простите меня админы!!!
Но вопрос срочный, не требующит отлагательств и рысканья по веткам форума!
Если есть подобная ветка то можете меня просто туда послать и я готов все понять и простить!
Суть вопроса такова:
Одна книга - несколько страниц. Нужно собрать на сводный лист данные по условию.
Буду очень признателе скроейшему решению вопроса.
Файл прилогается. Подробные описания в файле на листе "Сводная"
К сообщению приложен файл: 0440774.png(116.3 Kb) · 3420712.xlsx(14.9 Kb)
 
Ответить
СообщениеПростите меня админы!!!
Но вопрос срочный, не требующит отлагательств и рысканья по веткам форума!
Если есть подобная ветка то можете меня просто туда послать и я готов все понять и простить!
Суть вопроса такова:
Одна книга - несколько страниц. Нужно собрать на сводный лист данные по условию.
Буду очень признателе скроейшему решению вопроса.
Файл прилогается. Подробные описания в файле на листе "Сводная"

Автор - ewgen1307
Дата добавления - 15.03.2021 в 19:54
прохожий2019 Дата: Понедельник, 15.03.2021, 20:28 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 531
Репутация: 129 ±
Замечаний: 0% ±

365 Beta Channel
а если значения повторяются, тогда как? см. файл
[vba]
Код
let
    from = Excel.CurrentWorkbook(){[Name="base"]}[Content],
    adr=Excel.Workbook(File.Contents(Excel.CurrentWorkbook(){[Name="adres"]}[Content]{0}[Column1])),
    filtr = Table.SelectRows(adr, each ([Kind] = "Sheet" and [Name]<>"Сводная"))[Data],
    tbl=Table.Combine(List.Transform(filtr, (x)=>Table.PromoteHeaders(x))),
    join=Table.Join(from,"Значения",tbl,"значения",JoinKind.LeftOuter)[[Значения],[Данные]],
    to = Table.Sort(join,{{"Значения", Order.Ascending}})
in
    to
[/vba]
К сообщению приложен файл: 0308574.xlsx(25.7 Kb)
 
Ответить
Сообщениеа если значения повторяются, тогда как? см. файл
[vba]
Код
let
    from = Excel.CurrentWorkbook(){[Name="base"]}[Content],
    adr=Excel.Workbook(File.Contents(Excel.CurrentWorkbook(){[Name="adres"]}[Content]{0}[Column1])),
    filtr = Table.SelectRows(adr, each ([Kind] = "Sheet" and [Name]<>"Сводная"))[Data],
    tbl=Table.Combine(List.Transform(filtr, (x)=>Table.PromoteHeaders(x))),
    join=Table.Join(from,"Значения",tbl,"значения",JoinKind.LeftOuter)[[Значения],[Данные]],
    to = Table.Sort(join,{{"Значения", Order.Ascending}})
in
    to
[/vba]

Автор - прохожий2019
Дата добавления - 15.03.2021 в 20:28
anvg Дата: Понедельник, 15.03.2021, 21:35 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 580
Репутация: 271 ±
Замечаний: 0% ±

2016, 365
И вам тоже, здравствуйте.
Если есть подобная ветка

Всегда была
 
Ответить
СообщениеИ вам тоже, здравствуйте.
Если есть подобная ветка

Всегда была

Автор - anvg
Дата добавления - 15.03.2021 в 21:35
ewgen1307 Дата: Вторник, 16.03.2021, 08:01 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Мактросом то можно, не спорю!
Нужно только с помощью ФОРМУЛЫ!!!
Книга позже будет расшарена и макросы работать не будут!
Уже опробовали. ((((
 
Ответить
СообщениеМактросом то можно, не спорю!
Нужно только с помощью ФОРМУЛЫ!!!
Книга позже будет расшарена и макросы работать не будут!
Уже опробовали. ((((

Автор - ewgen1307
Дата добавления - 16.03.2021 в 08:01
прохожий2019 Дата: Вторник, 16.03.2021, 09:38 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 531
Репутация: 129 ±
Замечаний: 0% ±

365 Beta Channel
Книга позже будет расшарена и макросы работать не будут!
где вы макросы увидели? и вы так и не ответили
Цитата прохожий2019, 15.03.2021 в 20:28, в сообщении № 2 ()
а если значения повторяются, тогда как?
 
Ответить
Сообщение
Книга позже будет расшарена и макросы работать не будут!
где вы макросы увидели? и вы так и не ответили
Цитата прохожий2019, 15.03.2021 в 20:28, в сообщении № 2 ()
а если значения повторяются, тогда как?

Автор - прохожий2019
Дата добавления - 16.03.2021 в 09:38
ewgen1307 Дата: Вторник, 16.03.2021, 11:10 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Цитата прохожий2019, 16.03.2021 в 09:38, в сообщении № 5 ()
а если значения повторяются, тогда как?

Все было верно до 70 строки!
А про значения повторяющиеся, то можно просто допустим слово "повтор"
К сообщению приложен файл: 1115420.png(8.0 Kb)
 
Ответить
Сообщение
Цитата прохожий2019, 16.03.2021 в 09:38, в сообщении № 5 ()
а если значения повторяются, тогда как?

Все было верно до 70 строки!
А про значения повторяющиеся, то можно просто допустим слово "повтор"

Автор - ewgen1307
Дата добавления - 16.03.2021 в 11:10
ewgen1307 Дата: Вторник, 16.03.2021, 11:11 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Все было верно до 70 строки!

Именно строки а не ячейки с значением 70!
 
Ответить
Сообщение
Все было верно до 70 строки!

Именно строки а не ячейки с значением 70!

Автор - ewgen1307
Дата добавления - 16.03.2021 в 11:11
Светлый Дата: Вторник, 16.03.2021, 13:09 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1569
Репутация: 409 ±
Замечаний: 0% ±

Excel 2010, 2013
Нужно только с помощью ФОРМУЛЫ!!!
По первой прикидке массивная формула:
Код
=ЕСЛИОШИБКА(ВПР(B2;ЕСЛИ({1;0};ДВССЫЛ("Лист"&МИН(ЕСЛИ(ВЫБОР({1;2;3;4;5};Лист1!B$2:B$32;Лист2!B$2:B$32;Лист3!B$2:B$32;Лист4!B$2:B$32;Лист5!B$2:B$32)=B2;{1;2;3;4;5}))&"!B2:B32");ДВССЫЛ("Лист"&МИН(ЕСЛИ(ВЫБОР({1;2;3;4;5};Лист1!B$2:B$32;Лист2!B$2:B$32;Лист3!B$2:B$32;Лист4!B$2:B$32;Лист5!B$2:B$32)=B2;{1;2;3;4;5}))&"!a2:a32"));2;);"")
Можно сократить, но пока лень.
*Ещё массивный вариант:
Код
=ЕСЛИОШИБКА(ДВССЫЛ("Лист"&ПОДСТАВИТЬ(ТЕКСТ(МИН(ЕСЛИ(ВЫБОР({1;2;3;4;5};Лист1!B$2:B$32;Лист2!B$2:B$32;Лист3!B$2:B$32;Лист4!B$2:B$32;Лист5!B$2:B$32)=B2;{1;2;3;4;5}+СТРОКА($2:$32)%));"0,00");",";"!A"));"")
**Можно МИН заменить на МАКС или на несколько столбцов растянуть формулу:
Код
=ЕСЛИОШИБКА(ДВССЫЛ("Лист"&ПОДСТАВИТЬ(ТЕКСТ(НАИМЕНЬШИЙ(ЕСЛИ(ВЫБОР({1;2;3;4;5};Лист1!$B$2:$B$32;Лист2!$B$2:$B$32;Лист3!$B$2:$B$32;Лист4!$B$2:$B$32;Лист5!$B$2:$B$32)=$B2;{1;2;3;4;5}+СТРОКА($2:$32)%);СТОЛБЕЦ(A2));"0,00");",";"!A"));"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 16.03.2021, 14:23
 
Ответить
Сообщение
Нужно только с помощью ФОРМУЛЫ!!!
По первой прикидке массивная формула:
Код
=ЕСЛИОШИБКА(ВПР(B2;ЕСЛИ({1;0};ДВССЫЛ("Лист"&МИН(ЕСЛИ(ВЫБОР({1;2;3;4;5};Лист1!B$2:B$32;Лист2!B$2:B$32;Лист3!B$2:B$32;Лист4!B$2:B$32;Лист5!B$2:B$32)=B2;{1;2;3;4;5}))&"!B2:B32");ДВССЫЛ("Лист"&МИН(ЕСЛИ(ВЫБОР({1;2;3;4;5};Лист1!B$2:B$32;Лист2!B$2:B$32;Лист3!B$2:B$32;Лист4!B$2:B$32;Лист5!B$2:B$32)=B2;{1;2;3;4;5}))&"!a2:a32"));2;);"")
Можно сократить, но пока лень.
*Ещё массивный вариант:
Код
=ЕСЛИОШИБКА(ДВССЫЛ("Лист"&ПОДСТАВИТЬ(ТЕКСТ(МИН(ЕСЛИ(ВЫБОР({1;2;3;4;5};Лист1!B$2:B$32;Лист2!B$2:B$32;Лист3!B$2:B$32;Лист4!B$2:B$32;Лист5!B$2:B$32)=B2;{1;2;3;4;5}+СТРОКА($2:$32)%));"0,00");",";"!A"));"")
**Можно МИН заменить на МАКС или на несколько столбцов растянуть формулу:
Код
=ЕСЛИОШИБКА(ДВССЫЛ("Лист"&ПОДСТАВИТЬ(ТЕКСТ(НАИМЕНЬШИЙ(ЕСЛИ(ВЫБОР({1;2;3;4;5};Лист1!$B$2:$B$32;Лист2!$B$2:$B$32;Лист3!$B$2:$B$32;Лист4!$B$2:$B$32;Лист5!$B$2:$B$32)=$B2;{1;2;3;4;5}+СТРОКА($2:$32)%);СТОЛБЕЦ(A2));"0,00");",";"!A"));"")

Автор - Светлый
Дата добавления - 16.03.2021 в 13:09
ewgen1307 Дата: Вторник, 16.03.2021, 14:37 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Если сбор данных идет с одного а не с нескольких листов то я использовал
Код
=ЕСЛИОШИБКА(ВПР(B2;лист!A$1:B$500;2;0);"")
(Только там таблица немного видоизмененная).
Поэтому попрошу Вас при возможности сделайте точную формулу! Я на нее обопрусь )) и сделаю что мне нужно!
Заранее спасибо!


Сообщение отредактировал Serge_007 - Вторник, 16.03.2021, 14:44
 
Ответить
СообщениеЕсли сбор данных идет с одного а не с нескольких листов то я использовал
Код
=ЕСЛИОШИБКА(ВПР(B2;лист!A$1:B$500;2;0);"")
(Только там таблица немного видоизмененная).
Поэтому попрошу Вас при возможности сделайте точную формулу! Я на нее обопрусь )) и сделаю что мне нужно!
Заранее спасибо!

Автор - ewgen1307
Дата добавления - 16.03.2021 в 14:37
ewgen1307 Дата: Вторник, 16.03.2021, 14:50 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Цитата прохожий2019, 15.03.2021 в 20:28, в сообщении № 2 ()
а если значения повторяются, тогда как? см. файл


Вот такой я спец что вижу макросы! )))
 
Ответить
Сообщение
Цитата прохожий2019, 15.03.2021 в 20:28, в сообщении № 2 ()
а если значения повторяются, тогда как? см. файл


Вот такой я спец что вижу макросы! )))

Автор - ewgen1307
Дата добавления - 16.03.2021 в 14:50
ewgen1307 Дата: Вторник, 16.03.2021, 18:03 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Наконецто добрался до оригинального файла!
Прошу помочь в формуле на оригинале)!
Первые 4 листа данные вносятся вручную (при дулбировании выделяются условным форматированием во избежания повторений значений, но только на конкретном листе!)
Остальные листы (5-13) должны собирать значения с первых 4-х по значению в столбцах "С"
Если произошло дублирование значения на нескольких листах (первые 4-е) то желательно что бы формула выдала ответ "Дубль"
К сообщению приложен файл: 7195391.xlsx(212.8 Kb)
 
Ответить
СообщениеНаконецто добрался до оригинального файла!
Прошу помочь в формуле на оригинале)!
Первые 4 листа данные вносятся вручную (при дулбировании выделяются условным форматированием во избежания повторений значений, но только на конкретном листе!)
Остальные листы (5-13) должны собирать значения с первых 4-х по значению в столбцах "С"
Если произошло дублирование значения на нескольких листах (первые 4-е) то желательно что бы формула выдала ответ "Дубль"

Автор - ewgen1307
Дата добавления - 16.03.2021 в 18:03
Светлый Дата: Вторник, 16.03.2021, 19:33 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 1569
Репутация: 409 ±
Замечаний: 0% ±

Excel 2010, 2013
Простая формула:
Код
=ЕСЛИ(СУММПРОИЗВ(Ч(ВЫБОР({1;2;3;4};Пользователи!B$1:B$500;'Сервера и прочее'!B$1:B$500;'МФУ и принтера'!B$1:B$500;'Камеры и прочее'!B$1:B$500)=C2))>1;"Дубль";ЕСЛИ(СЧЁТЕСЛИ(Пользователи!B:B;C2);ВПР(C2;Пользователи!B:D;2;);ЕСЛИ(СЧЁТЕСЛИ('Сервера и прочее'!B:B;C2);ВПР(C2;'Сервера и прочее'!B:D;2;);ЕСЛИ(СЧЁТЕСЛИ('МФУ и принтера'!B:B;C2);ВПР(C2;'МФУ и принтера'!B:D;2;);ЕСЛИ(СЧЁТЕСЛИ('Камеры и прочее'!B:B;C2);ВПР(C2;'Камеры и прочее'!B:D;2;);"Нет")))))&""


Программировать проще, чем писать стихи.
 
Ответить
СообщениеПростая формула:
Код
=ЕСЛИ(СУММПРОИЗВ(Ч(ВЫБОР({1;2;3;4};Пользователи!B$1:B$500;'Сервера и прочее'!B$1:B$500;'МФУ и принтера'!B$1:B$500;'Камеры и прочее'!B$1:B$500)=C2))>1;"Дубль";ЕСЛИ(СЧЁТЕСЛИ(Пользователи!B:B;C2);ВПР(C2;Пользователи!B:D;2;);ЕСЛИ(СЧЁТЕСЛИ('Сервера и прочее'!B:B;C2);ВПР(C2;'Сервера и прочее'!B:D;2;);ЕСЛИ(СЧЁТЕСЛИ('МФУ и принтера'!B:B;C2);ВПР(C2;'МФУ и принтера'!B:D;2;);ЕСЛИ(СЧЁТЕСЛИ('Камеры и прочее'!B:B;C2);ВПР(C2;'Камеры и прочее'!B:D;2;);"Нет")))))&""

Автор - Светлый
Дата добавления - 16.03.2021 в 19:33
Светлый Дата: Среда, 17.03.2021, 08:16 | Сообщение № 13
Группа: Друзья
Ранг: Старожил
Сообщений: 1569
Репутация: 409 ±
Замечаний: 0% ±

Excel 2010, 2013
Ещё вариант. Выдаёт дубли связанные через "-+-"
Код
=ПОДСТАВИТЬ(ЕСЛИ(СЧЁТЕСЛИ(Пользователи!B:B;C2);"-+-"&ВПР(C2;Пользователи!B:D;2;);"")&ЕСЛИ(СЧЁТЕСЛИ('Сервера и прочее'!B:B;C2);"-+-"&ВПР(C2;'Сервера и прочее'!B:D;2;);"")&ЕСЛИ(СЧЁТЕСЛИ('МФУ и принтера'!B:B;C2);"-+-"&ВПР(C2;'МФУ и принтера'!B:D;2;);"")&ЕСЛИ(СЧЁТЕСЛИ('Камеры и прочее'!B:B;C2);"-+-"&ВПР(C2;'Камеры и прочее'!B:D;2;);"");"-+-";"";1)
*Дубли на одном листе не отмечает


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 17.03.2021, 08:17
 
Ответить
СообщениеЕщё вариант. Выдаёт дубли связанные через "-+-"
Код
=ПОДСТАВИТЬ(ЕСЛИ(СЧЁТЕСЛИ(Пользователи!B:B;C2);"-+-"&ВПР(C2;Пользователи!B:D;2;);"")&ЕСЛИ(СЧЁТЕСЛИ('Сервера и прочее'!B:B;C2);"-+-"&ВПР(C2;'Сервера и прочее'!B:D;2;);"")&ЕСЛИ(СЧЁТЕСЛИ('МФУ и принтера'!B:B;C2);"-+-"&ВПР(C2;'МФУ и принтера'!B:D;2;);"")&ЕСЛИ(СЧЁТЕСЛИ('Камеры и прочее'!B:B;C2);"-+-"&ВПР(C2;'Камеры и прочее'!B:D;2;);"");"-+-";"";1)
*Дубли на одном листе не отмечает

Автор - Светлый
Дата добавления - 17.03.2021 в 08:16
ewgen1307 Дата: Среда, 17.03.2021, 14:28 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Огромная благодарность "мил" человек за оперативность, за труд и просто за хорошее отношение к "заблудившимся"! hands hands hands hands
 
Ответить
СообщениеОгромная благодарность "мил" человек за оперативность, за труд и просто за хорошее отношение к "заблудившимся"! hands hands hands hands

Автор - ewgen1307
Дата добавления - 17.03.2021 в 14:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сводная с нескольких листов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!