Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разделить значения одной ячейки через запятую на столбцы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разделить значения одной ячейки через запятую на столбцы (Формулы/Formulas)
Разделить значения одной ячейки через запятую на столбцы
stoniq Дата: Среда, 17.03.2021, 16:19 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 82
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Всем добрый день!
Есть столбец А:А, в нем имеются различные значения через запятую. Необходимо формулой разделить эти значения по столбцам. Разделить необходимо именно формулой. Значений может быть до 6 штук.
К сообщению приложен файл: 3215277.xlsx(8.2 Kb)
 
Ответить
СообщениеВсем добрый день!
Есть столбец А:А, в нем имеются различные значения через запятую. Необходимо формулой разделить эти значения по столбцам. Разделить необходимо именно формулой. Значений может быть до 6 штук.

Автор - stoniq
Дата добавления - 17.03.2021 в 16:19
Nic70y Дата: Среда, 17.03.2021, 16:27 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6850
Репутация: 1572 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР($A1;ПОИСК("\";ПОДСТАВИТЬ(","&$A1;",";"\";СТОЛБЕЦ(A1)));749);",";ПОВТОР(" ";749));749));"")


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР($A1;ПОИСК("\";ПОДСТАВИТЬ(","&$A1;",";"\";СТОЛБЕЦ(A1)));749);",";ПОВТОР(" ";749));749));"")

Автор - Nic70y
Дата добавления - 17.03.2021 в 16:27
stoniq Дата: Среда, 17.03.2021, 16:37 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 82
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y, А если значения через запятую находятся с столбце С:С ?
 
Ответить
СообщениеNic70y, А если значения через запятую находятся с столбце С:С ?

Автор - stoniq
Дата добавления - 17.03.2021 в 16:37
Nic70y Дата: Среда, 17.03.2021, 16:39 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6850
Репутация: 1572 ±
Замечаний: 0% ±

Excel 2010
$A замените на $C


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение$A замените на $C

Автор - Nic70y
Дата добавления - 17.03.2021 в 16:39
stoniq Дата: Среда, 17.03.2021, 16:55 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 82
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y, получается вот так
К сообщению приложен файл: 3215277-1-.xlsx(8.8 Kb)
 
Ответить
СообщениеNic70y, получается вот так

Автор - stoniq
Дата добавления - 17.03.2021 в 16:55
Nic70y Дата: Среда, 17.03.2021, 17:03 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 6850
Репутация: 1572 ±
Замечаний: 0% ±

Excel 2010
потомушто СТОЛБЕЦ(A1) изменять не надо


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениепотомушто СТОЛБЕЦ(A1) изменять не надо

Автор - Nic70y
Дата добавления - 17.03.2021 в 17:03
gling Дата: Среда, 17.03.2021, 17:06 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2254
Репутация: 584 ±
Замечаний: 0% ±

2010
получается вот так

Замените в начальной формуле СТОЛБЕЦ(C1) на СТОЛБЕЦ(A1)


ЯД-41001506838083
 
Ответить
Сообщение
получается вот так

Замените в начальной формуле СТОЛБЕЦ(C1) на СТОЛБЕЦ(A1)

Автор - gling
Дата добавления - 17.03.2021 в 17:06
stoniq Дата: Среда, 17.03.2021, 18:05 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 82
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y, gling, Спасибо большое!
 
Ответить
СообщениеNic70y, gling, Спасибо большое!

Автор - stoniq
Дата добавления - 17.03.2021 в 18:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разделить значения одной ячейки через запятую на столбцы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!