Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор строк на основе значений в столбце др таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор строк на основе значений в столбце др таблицы (Формулы/Formulas)
Выбор строк на основе значений в столбце др таблицы
Tallen Дата: Среда, 17.03.2021, 22:28 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброй ночи ))
Уважаемые специалисты, знаю что тема стара.. но найти быстро не смогла, а нужно прям вот вчера...
Помогите пожалуйста поставить в столбец С Листа 2 только лицевые счета из столбца В листа 1,если в столбце С стоит Юн Комс
К сообщению приложен файл: 22.xlsx(79.8 Kb)
 
Ответить
СообщениеДоброй ночи ))
Уважаемые специалисты, знаю что тема стара.. но найти быстро не смогла, а нужно прям вот вчера...
Помогите пожалуйста поставить в столбец С Листа 2 только лицевые счета из столбца В листа 1,если в столбце С стоит Юн Комс

Автор - Tallen
Дата добавления - 17.03.2021 в 22:28
gling Дата: Среда, 17.03.2021, 23:26 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2243
Репутация: 581 ±
Замечаний: 0% ±

2010
Здравствуйте.
Попробуйте такую, если порядок не имеет значения.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$1:$B$100;ЕСЛИ(СУММПРОИЗВ(НАИБОЛЬШИЙ((Лист1!$C$1:$C$30="Ю Комс")*СТРОКА(Лист1!$C$1:$C$30);СТРОКА(C1)))>0;СУММПРОИЗВ(НАИБОЛЬШИЙ((Лист1!$C$1:$C$30="Ю Комс")*СТРОКА(Лист1!$C$1:$C$30);СТРОКА(C1)));""));"")
К сообщению приложен файл: 6812378.xlsx(86.2 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Попробуйте такую, если порядок не имеет значения.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$1:$B$100;ЕСЛИ(СУММПРОИЗВ(НАИБОЛЬШИЙ((Лист1!$C$1:$C$30="Ю Комс")*СТРОКА(Лист1!$C$1:$C$30);СТРОКА(C1)))>0;СУММПРОИЗВ(НАИБОЛЬШИЙ((Лист1!$C$1:$C$30="Ю Комс")*СТРОКА(Лист1!$C$1:$C$30);СТРОКА(C1)));""));"")

Автор - gling
Дата добавления - 17.03.2021 в 23:26
Kostya_Ye Дата: Среда, 17.03.2021, 23:28 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 224 ±
Замечаний: 0% ±

Excel 2016
Tallen, добрый день,
вот такой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС( Лист1!$B$1:$B$16; НАИМЕНЬШИЙ( ЕСЛИ(Лист1!$C$2:$C$16="Ю Комс"; СТРОКА($C$2:$C$16); ""); СТРОКА(A1)));"")

формула массива, вводится через Ctrl-Shift-Enter
 
Ответить
СообщениеTallen, добрый день,
вот такой вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС( Лист1!$B$1:$B$16; НАИМЕНЬШИЙ( ЕСЛИ(Лист1!$C$2:$C$16="Ю Комс"; СТРОКА($C$2:$C$16); ""); СТРОКА(A1)));"")

формула массива, вводится через Ctrl-Shift-Enter

Автор - Kostya_Ye
Дата добавления - 17.03.2021 в 23:28
Tallen Дата: Четверг, 18.03.2021, 00:19 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем большое спасибо!
 
Ответить
СообщениеВсем большое спасибо!

Автор - Tallen
Дата добавления - 18.03.2021 в 00:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор строк на основе значений в столбце др таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!